Лабораторный практикум

по дисциплине: "Информатика"

Основы программирования в интегрированной среде разработки приложений Microsoft Visual Basic 6.0

Общие сведения о Visual Basic

Лабораторная работа № 1

Изучение интегрированной среды и основ работы в Visual Basic

Лабораторная работа № 2

Организация ввода-вывода данных, изменение свойств объектов

Лабораторная работа № 3

Разработка приложений с разветвляющимися и циклическими алгоритмами

Лабораторная работа № 4

Работа с массивами

Лабораторная работа № 5

Работа файлами и строками

Лабораторная работа № 6

Работа с графикой

Лабораторная работа № 7

Разработка многооконных приложений с использованием компонентов на базе стандартных шаблонов и меню

© Тархов С.В., Уфа, каф. Информатики УГАТУ, 2003 г.


Для запуска программы из главного меню Windows выполните следующие действия

Введение

назад

Язык Basic

Язык программирования BASIC – Beginner's All purpose Symbolic Instruction Code (универсальный символьный программный код для начинающих) был разработан сотрудниками Дартмутского колледжа (США) в 1964 г. Первоначальная его версия включала всего 14 служебных слов и предназначалась для обучения программированию. С тех пор было создано более 100 версий этого языка, реализованных на различных ЭВМ.

Первый персональный компьютер IBM PC имел 16-разрядный BASIC, разработанный корпорацией IBM. Позже его сменил GW-BASIC и QUICK-BASIC, разработанный корпорацией Microsoft. В QUICK-BASIC была убрана нумерация строк и добавлен компилятор, превращающий BASIC-программу в полноценный исполняемый (.exe) файл. Не оставила без внимания язык BASIC и корпорация Borland, разработавшая в 1987 г. интегрированную среду программирования Turbo-Basic.

Интегрированная среда разработки приложений Visual Basic

Visual Basic развился из первоначального языка Basic и в настоящее время содержит несколько сотен команд, функций и ключевых слов, многие из которых связаны непосредственно с графическим интерфейсом пользователя GUI (Graphical User Interface) операционной системы Windows. Используя Visual Basic даже начинающие программисты могут создавать полезные программы, зная лишь несколько ключевых слов. При этом профессиональные программисты имеют все необходимые средства для разработки сложных приложений, функционирующих под управлением Windows.

В 1992 г. корпорацией Microsoft был разработан и выпущен Visual Basic 1.0 - относительно простой язык программирования для Windows 3.1. Затем были выпущены Visual Basic 3.0, 4.0, 5.0 и наконец Visual Basic 6.0. Версии 5.0 и 6.0 отличаются незначительно: в шестой версии улучшено ядро и добавлен ряд новых функций. ПомимоVisual Basic существует еще язык макросов для приложений Microsoft Office (Word, Excel и т.п.). Он называется VBA (Visual Basic for Application). С его помощью можно разрабатывать макрокоманды для автоматизации работы с приложениями Microsoft Office.

Интегрированная среда разработки приложений Microsoft Visual Basic (в дальнейшем изложении Visual Basic), обладая простыми в обращении средствами визуального проектирования, позволяет в полной мере использовать преимущества графической среды

Windows и быстро конструировать эффективные приложения. Помимо Visual Basic существуют и другие языки визуального программирования с аналогичными возможностями: Borland Delphi, Borland C++ Builder.

Visual Basic – один из первых языков, поддерживающих событийно-управляемое программирование (event-driven programming). Этот стиль хорошо согласуется со стандартом графического пользовательского интерфейса. Традиционно программирование ориентировалось на поэтапное описание конкретного процесса. Однако современные компьютерные приложения слишком сложны и данный стиль программирования для них не подходит.

Основная идея событийно-управляемого программирования заключается в том, что вместо скрупулезного описания каждого шага работы приложения достаточно лишь указать, как необходимо реагировать на различные события (действия пользователя): выбор команды, щелчок или перемещение мыши, нажатие клавиш и др. В результате программист создает не одну большую программу, а приложение, состоящее из набора взаимодействующих процедур, управляемых пользователем.

Программы, или как принято говорить - приложения, разрабатываемы для Windows, имеют, как правило, стандартный пользовательский интерфейс: окна-формы, на которых располагаются окна для текстов или рисунков, меню, кнопки управления и другие элементы. Каждый из этих объектов обладает определенными свойствами: цвет, размеры, надписи и другие. Кроме этого, каждое конкретное приложение в режиме взаимодействия с пользователем посредством вышеупомянутых объектов, выполняет те или иные действия, приводящие к получению определенного результата. Для получения какого-либо конкретного действия должна быть написана соответствующая команда в тексте программы на языке Visual Basic. Таким образом разработка приложения включает следующие этапы:

- создание интерфейса пользователя с использованием средств визуального программирования, в процессе которого на формах размещаются необходимые объекты из набора стандартных элементов интерфейса Windows;

- установка свойств для формы и размещенных на ней объектов (размеры, цвет, надписи и др.);

- написание текста программы, определяющей выполнение приложением необходимых действий.

Разработанная корпорацией Microsoft интегрированная среда разработки приложений Visual Basic объединяет в себе множество функций, позволяющих выполнять визуальное проектирование интерфейса приложения, ввод и редактирование исходного текста программы, компиляцию и отладку приложений.

Приложения, создаваемые в среде Visual Basic принято называть проектами.

назад


Тархов Сергей Владимирович

докторант, кандидат технических наук, доцент
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76

E-mail: TarkhovSV@soros.bachedu.ru

С 1990 г. преподает дисциплины "Информатика", "Компьютерные технологии", Электронный офис", "Системы подготовки деловой документации", "Организация интерфейса в человеко-машинных системах" и др.

Один из авторов новой инструментально обеспеченной методики преподавания дисциплины “Информатика” и других дисциплин компьютерного профиля для подготовки бакалавров и магистров, внедренной в учебный процесс в ряде вузов региона.

В 1998 году им получен и успешно выполнен грант "Института Открытое общество" (фонд Сороса) "Музей истории отечественных компьютеров", опубликованный http://www.bashedu.ru/konkurs/tarhov/index.htm и размещенный на CD Московского Центра интернет-образования в разделе "Ресурсы Интернета".

Тархов С.В. является автором более 90 научных и методических работ.

Область научный интересов: проектирование информационно-обучающих сред для образовательных систем.

[На главную страницу]


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatCurrency

FormatCurrency(Expression[,NumDigitsAfterDecimal [,IncludeLeadingDigit,[UseParensForNegativeNumbers[,GroupDigits]]]])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования числовых выражений, представляющих денежные суммы. Эта функция была введена в качестве альтернативы громоздкой функции Format. Используйте функцию FormatCurrency в силу ее большей читабельности

Возвращаемое значение

Возвращает строковое выражение, отформатированное в виде денежного значения с применением символа валюты, заданного в системной панели управления

Параметры
Часть | Описание
Expression | Обязательный. Форматируемое выражение
NumDigitsAfterDecimal | Необязательный. Числовое значение, задающее число знаков, отображаемых в правой части десятичной дроби. Значением по умолчанию, указывающим, что применяются национальные установки компьютера, является –1
IncludeLeadingDigit | Необязательный. Константа с тремя значениями, которая задает наличие или отсутствие начального нуля при отображении дробных значений. См. значения в разделе «Установки»
UseParensForNegativeNumbers | Необязательный. Константа с тремя значениями, которая указывает, надо ли заключать в круглые скобки отрицательные значения. См. значения в разделе «Установки»
GroupDigits | Необязательный. Константа с тремя значениями, указывающая на необходимость группирования цифр с применением разделителя групп, заданного в национальных установках компьютера. См. значения в разделе «Установки»

Установки

Параметры IncludeLeadingDigit, UseParensForNegativeNumbers и GroupDigits имеют следующие установки:

Константа | Значение | Описание
TristateTrue | –1 | True
TristateFalse | 0 | False
TristateUseDefault | –2 | Применяется установка, соответствующая национальным установкам для компьютера

Примечания

При пропуске одного или нескольких необязательных параметров значения для них присваиваются в соответствии с национальными установками компьютера

Расположение символа валюты по отношению к денежному значению определяется национальными установками для системы

Замечание Все сведения об установках содержатся на закладке Regional Settings Currency, за исключением вводного нуля, информация о котором находится на закладке Number

Пример

' В данном примере функция FormatCurrency
' используется для форматирования числа 100
Print FormatCurrency(100) 'возвращает 100.00р.

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatDateTime

FormatDateTime(Date[,NamedFormat])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования величин дат и времени

Возвращаемое значение

Возвращает строковое выражение, отформатированное в виде даты и времени

Параметры
Часть | Описание
Date | Обязательный. Форматируемое выражение для даты и времени
NamedFormat | Необязательный. Числовое выражение, указывающее используемый формат для даты и времени. Если параметр опущен, применяется формат, задаваемый константой vbGeneralDate

Установки

Для параметра NamedFormat используются следующие установки:

Константа | Значение | Описание
vbGeneralDate | 0 | Отображаются дата и/или время. При наличии области даты она отображается в коротком формате для даты. Если присутствует часть, относящаяся к времени, то время отображается в длинном формате для времени. При наличии обеих частей – производится их отображение
vbLongDate | 1 | Отображается дата с использованием длинного формата для даты, заданного национальными установками компьютера
vbShortDate | 2 | Отображается дата с использованием короткого формата для даты, заданного национальными установками компьютера
vbLongTime | 3 | Отображается время с использованием формата для времени, заданного национальными установками компьютера
vbShortTime | 4 | Отображается время с использованием 24-часового формата (hh:mm)

Пример

' В данном примере функция FormatDateTime
' используется для форматирования даты
Print FormatDateTime(1) 'возвращает 31.12.1899

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatNumber

FormatNumber(Expression[,NumDigitsAfterDecimal [,IncludeLeadingDigit [,UseParensForNegativeNumbers [,GroupDigits]]]])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования числовых выражений. Эта функция была введена в качестве альтернативы громоздкой функции Format. Используйте функцию FormatNumber в силу ее большей читабельности

Возвращаемое значение

Возвращает значение типа String,содержащее отформатированное числовое выражение

Параметры
Часть | Описание
Expression | Обязательный. Форматируемое выражение
NumDigitsAfterDecimal | Необязательный. Числовое значение, задающее число знаков, отображаемых в правой части десятичной дроби. Значением по умолчанию, указывающим, что применяются национальные установки компьютера, является –1
IncludeLeadingDigit | Необязательный. Константа с тремя значениями, которая задает наличие или отсутствие начального нуля при отображении дробных значений. См. значения в разделе «Установки»
UseParensForNegativeNumbers | Необязательный. Константа с тремя значениями, которая указывает, надо ли заключать в круглые скобки отрицательные значения. См. значения в разделе «Установки»
GroupDigits | Необязательный. Константа с тремя значениями, указывающая на необходимость группирования цифр с применением разделителя групп, заданного в национальных установках компьютера. См. значения в разделе «Установки»

Установки

Для параметров IncludeLeadingDigit, UseParensForNegativeNumbers и GroupDigits используются следующие установки:

Константа | Значение | Описание
TristateTrue | –1 | True
TristateFalse | 0 | False
TristateUseDefault | –2 | Применяется установка, соответствующая национальным установкам для компьютера

Примечания

При пропуске одного или нескольких необязательных параметров значения для них присваиваются в соответствии с национальными установками компьютера

Замечание Все сведения об установках содержатся на закладке Regional Settings Number

Пример

' В данном примере функция FormatNumber
' используется для форматирования числа 100
Print FormatNumber(100) 'возвращает 100,00

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция Format

Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])
Format$ (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])

Функция Format служит для форматирования выражения

Возвращаемое значение

Возвращает значение типа Variant (String), содержащее выражение, отформатированное согласно инструкциям, заданным в описании формата

Параметры
Expression
Обязательный аргумент-любое допустимое выражение, подлежащее форматированию
Format
Необязательный аргумент-любое допустимое именованное или определяемое пользователем выражение формата.При форматировании чисел без указания аргумента Format функция Format выдает тот же результат, что и функция Str, хотя эта функция учитывает национальную настройку. Отличие состоит в том, что при преобразовании положительного числа с помощью функции Format пробел в начале строки (на месте знака числа) теряется, а при преобразовании с помощью функции Str останется
FirstDayOfWeek
Необязательный аргумент-константа, определяющая первый день недели
vbUseSystem=0
Используется значение национальных системных установок
vbSunday=1
Воскресенье(по умолчанию)
vbMonday=2
Понедельник
vbTuesday=3
Вторник
vbWednesday=4
Среда
vbThursday=5
Четверг
vbFriday=6
Пятница
vbSaturday
Суббота
FirstWeekOfYear
Необязательный аргумент-числовая константа, указывающая, какую неделю считать первой в году:
vbUseSystem=0
Используется системная информация
vbFirstJan1=1
Неделя,содержащая 1 января
vbFirstFourDays=2
Первая неделя,содержащая как минимум 4 дня нового года
vbFirstFullWeek=3
Первая полная неделя года

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование числовых и денежных величин

General Number
Отображает число без разделителей групп разрядов
A=123456.789
Print Format(A,"General Number") ' возвратит 123456.789
Currency
Отображает значение с разделителями групп разрядов (если требуется). В настройке США отображает две цифры справа от десятичного разделителя. Обозначение денежной единицы и ее положение относительно числа определяется текущей национальной настройкой
A=123456.789
Print Format(A,"Currency") ' возвратит 123 456,79р.
Fixed
Отображает по крайней мере одну цифру слева и две цифры справа от десятичного разделителя
A=123456.789
Print Format(A,"Fixed") ' возвратит 123456,79
Standard
Отображает по крайней мере одну цифру слева и две цифры справа от десятичного разделителя, а также разделители групп разрядов
A=123456.789
Print Format(A,"Standard") ' возвратит 123 456,79
Percent
Отображает число, умноженное на 100, со знаком процентов (%), добавленным справа. Всегда отображает две цифры справа от десятичного разделителя
A=1.23
Print Format(A,"Percent") ' возвратит 123,00%
Scientific
Использует стандартную экспоненциальную нотацию
A=123456.789
Print Format(A,"Scientific") ' возвратит 1,23E+00
Примечание:При форматировании стандартными форматами числа округляются, а не усекаются по стандартным правилам округления
Пользовательские форматы числовых величин

Пользовательский формат чисел(аргумент format) может содержать до четырех разделов, возможно пустых, разделенных точками с запятой(;).Каждый раздел предназначен для раздельного форматирования следующих категорий чисел:
Число разделов

1
Данный формат применяется ко всем значениям
2
Первый элемент применяется к положительным и нулевым значениям, а второй к отрицательным значениям
3
Первый элемент применяется к положительным значениям, второй к отрицательным значениям, а третий к нулевым значениям
4
Первый элемент применяется к положительным значениям, второй к отрицательным значениям, третий к нулевым значениям, а четвертый к значениям Null
Пример

' Пример формата,содержащего два раздела-первый применяется к положительным и нулевым значениям, а второй к отрицательным значениям
"$#,##0;($#,##0)"
' Если формат содержит символы точки с запятой, между которыми ничего нет, значения, соответствующие пропущенному элементу, изображаются согласно формату положительных значений. Например, следующий формат отображает положительные и отрицательные значения согласно первому элементу, а вместо нулевых значений отображает строку "Нуль"
"$#,##0;;\Н\у\л\ь"

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование логических величин

Для вывода логических величин предусмотрены только стандартные форматы
Стандартные форматы логических величин
Yes/No
Отображает значение No(Нет),если число равно нулю, в противном случае отображается Yes(Да)
A=123456.789
Print Format(A,"Yes/No") ' возвратит Да
True/False
Отображает значение False(Ложь),если число равно нулю,в противном случае отображается True(Истина)
A=10
Print Format(A,"True/False") ' возвратит Истина
On/Off
Отображает значение Off(Выкл),если число равно нулю,в противном случае отображается On(Вкл)
A=10
Print Format(A,"On/Off") ' возвратит Вкл
Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование величин дат и времени

General Date
Отображает дату и\или время. Если число имеет и целую, и дробную часть, то изображаются и дата, и время (например, 04.03.93 17:34); если у числа нет дробной части, то отображается только дата (например, 04.03.93); если у числа нет целой части, то отображается только время (например, 17:34). Фактическое изображение даты и времени определяется системной настройкой
A="27.07.66"
Print Format(A,"General Date") ' возвратит 27.07.66
Long Date
Отображает дату согласно длинному системному формату даты
A="27.07.66"
Print Format(A,"Long Date") ' возвратит 27 Июль 1966 г.
Medium Date
Отображает дату согласно среднему формату даты, установленному для языковой версии системы
A="27.07.66"
Print Format(A,"Medium Date") ' возвратит 27-июл-66
Short Date
Отображает дату согласно краткому системному формату даты
A="27.07.66"
Print Format(A,"Short Date") ' возвратит 27.07.66
Long Time
Отображает время согласно длинному системному формату времени: часы, минуты и секунды
A=0.25
Print Format(A,"Long Time") ' возвратит 6:00:00
Medium Time
Отображает значение времени в 12-часовом формате: часы, минуты и индикатор "AM/PM"(если есть в системных установках)
A=0.6
Print Format(A,"Medium Time") ' возвратит 02:24
Short Time
Отображает значение времени в 24-часовом формате
A=0.6
Print Format(A,"Short Time") ' возвратит 14:24
Пользовательские форматы дат и времени
:
Разделитель компонентов времени. В некоторых национальных настройках применяется другой символ. Разделитель компонентов времени используется для разделения компонентов времени (часов, минут и секунд). Фактический символ, используемый в качестве разделителя компонентов времени, определяется текущей национальной настройкой. В России в качестве разделителя компонентов времени используется двоеточие
/
Разделитель компонентов даты. В некоторых национальный настройках применяется другой символ. Разделитель компонентов даты используется для разделения компонентов даты (дня, месяца и года). Фактический символ, используемый в качестве разделителя компонентов даты, определяется текущей национальной настройкой. В России в качестве разделителя компонентов даты используется точка
c
Отображает дату как ddddd и время как ttttt. Если у числа нет дробной части, то отображается только дата; если у числа нет целой части, то отображается только время
d
Выводит номер дня в месяце, содержащий одну или две цифры (1 – 31)
dd
Выводит номер дня в месяце, содержащий одну или две цифры (01 – 31)
ddd
Выводит сокращенное название дня недели (Пн– Вс)
dddd
Выводит полное название дня недели (Понедельник– Воскресенье)
ddddd
Отображает соответствующую числу полную дату (день, месяц и год) согласно краткому системному формату даты.Эквивалентно стандартному формату Short Date
dddddd
Отображает соответствующую числу полную дату (день, месяц и год) согласно длинному системному формату даты.Эквивалентно стандартному формату Long Date
w
Выводит номер дня недели (по умолчанию, от 1 для воскресенья до 7 для субботы),какой день считать первым определяется аргументом FirtsDayOfWeek
ww
Выводит номер недели года (1 – 54),какую недель считать первой определяется аргументом FirtsWeekOfYear
m
Выводит номер месяца, содержащий одну или две цифры (1 – 12). Если символ m следует сразу после символов h или hh, выводится число минут
mm
Выводит номер месяца, содержащий две цифры (01 – 12). Если символ m следует сразу после символов h или hh, выводится число минут
mmm
Выводит сокращенное название месяца (Янв – Дек)
mmmm
Выводит полное название месяца (Январь – Декабрь)
q
Выводит номер квартала года (1 – 4)
y
Выводит номер дня года (1 – 366)
yy
Выводит номер года, состоящий из двух цифр (00 – 99)
yyyy
Выводит номер года, состоящий из трех или четырех цифр (100 – 9999)
h
Выводит число часов, состоящее из одной или двух цифр (0 – 23)
hh
Выводит число часов, состоящее из двух цифр (00 – 23)
n
Выводит число минут, состоящее из одной или двух цифр (0 – 59)
nn
Выводит число минут, состоящее из двух цифр (00 – 59)
s
Выводит число секунд, состоящее из одной или двух цифр (0 – 59)
ss
Выводит число секунд, состоящее из двух цифр (00 – 59)
ttttt
Отображает полное время (часы, минуты и секунды) согласно текущему системному формату времени. В Microsoft Windows формат времени по умолчанию имеет вид "h:mm:ss"
AM/PM
Использует 12-часовую шкалу, добавляя прописные буквы "AM" (до полудня) или "PM" (между полуднем и полуночью)
am/pm
Использует 12-часовую шкалу, добавляя строчные буквы "am" (до полудня) или "pm" (между полуднем и полуночью)
A/P
Использует 12-часовую шкалу, добавляя прописные буквы "A" (до полудня) или "P" (между полуднем и полуночью)
a/p
Использует 12-часовую шкалу, добавляя строчные буквы "a" (до полудня) или "p" (между полуднем и полуночью)
AMPM
Использует 12-часовую шкалу, добавляя текстовую константу, добавляя текстовую константу, заменяющую в текущей системе индикаторы "AM" (до полудня) или "PM" (между полуднем и полуночью). Регистр изображаемой текстовой строки определяется соответствующими системными настройками. В Microsoft Windows по умолчанию используется формат "AM/PM"
Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование строковых величин

Текстовые величины не имеют стандартных форматов. Пользовательский формат строковых величин может содержать до двух разделов, возможно пустых. Разделы нумеруются слева направо и отделяются друг от друга точкой с запятой(;).Каждый раздел предназначен для раздельного форматирования непустой(1) или пустой(2) строк.
Если раздел 1 пуст, строка формата игнорируется.
Если раздел 2 не задан, то возвращается пустая строка

Символы форматирования

@
Прототип символа для вывода символа или пробела. Если форматируемая строка содержит символ в позиции, соответствующей символу @ в строке формата, то будет выведен этот символ, в противном случае выводится пробел. Строка формата заполняется справа налево, если в ней нет символа (!):
Пример

' возвращается Русский Проект
Print "Русский" & Format("Проект","@@@@@@@")
&
Прототип символа. Выводит символ или не выводит ничего.. Если форматируемая строка содержит символ в позиции, соответствующей символу (&) в строке формата, то в данной позиции будет выведен этот символ; в противном случае данная позиция останется пустой. Строка формата заполняется справа налево, если в ней нет символа (!)
<
Символ нижнего регистра. Преобразует все символы к нижнему регистру
>
Символ верхнего регистра. Преобразует все символы к нижнему регистру
!
Заполнение строки формата слева направо. По умолчанию строка формата заполняется справа налево
Пример
' возвращается Проект  Проект(с двумя пробелами)
Print "Format("Проект","@@@@@@@@!") "Проект"
Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatPercent

FormatPercent(Expression[,NumDigitsAfterDecimal [,IncludeLeadingDigit [,UseParensForNegativeNumbers [,GroupDigits]]]])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования числовых выражений в процентном формате. Эта функция была введена в качестве альтернативы громоздкой функции Format. Используйте функцию FormatPercent в силу ее большей читабельности

Возвращаемое значение

Возвращает число, отформатированное в виде процентного отношения (умноженное на 100), с последующим символом %

Параметры
Часть | Описание
выражение | Обязательный. Форматируемое выражение
NumDigitsAfterDecimal | Необязательный. Числовое значение, задающее число знаков, отображаемых в правой части десятичной дроби. Значением по умолчанию, указывающим, что применяются национальные установки компьютера, является –1
IncludeLeadingDigit | Необязательный. Константа с тремя значениями, которая задает наличие или отсутствие начального нуля при отображении дробных значений. См. значения в разделе «Установки»
UseParensForNegativeNumbers | Необязательный. Константа с тремя значениями, которая указывает, надо ли заключать в круглые скобки отрицательные значения. См. значения в разделе «Установки»
GroupDigits | Необязательный. Константа с тремя значениями, указывающая на необходимость группирования цифр с применением разделителя групп, заданного в национальных установках компьютера. См. значения в разделе «Установки»

Установки

Аргументы IncludeLeadingDigit, UseParensForNegativeNumbers и GroupDigits имеют следующие установки

Константа | Значение | Описание
TristateTrue | –1 | True
TristateFalse | 0 | False
TristateUseDefault | –2 | Применяется установка, соответствующая национальным установкам для компьютера

Примечания

При пропуске одного или нескольких необязательных параметров значения для них присваиваются в соответствии с национальными установками компьютера

Замечание Все сведения об установках содержатся на закладке Regional Settings Number
Пример
' В данном примере функция FormatPercent
' используется для форматирования числа 50
Print FormatPercent(50) 'возвращает 500,00%

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Символы форматирования, применяемые для создания пользовательских форматов числовых величин

назад

0
Прототип цифры. Выводит цифру или нуль. Если форматируемое выражение содержит цифру в позиции, соответствующей прототипу "0" в строке формата, то в данной позиции будет выведена эта цифра; в противном случае в данной позиции будет выведен нуль. Если число цифр в целой или дробной части форматируемого числа меньше, чем число прототипов "0" слева или справа от десятичного разделителя в строке формата, соответственно, то в начало или конец числа будут добавлены недостающие нули. Если количество цифр в дробной части форматируемого числа больше, чем количество прототипов "0" справа от десятичного разделителя в строке формата, то число будет округлено с соответствующей точностью. Если количество цифр в целой части форматируемого числа больше, чем количество прототипов "0" слева от десятичного разделителя в строке формата, то лишние цифры будут выведены без изменения
Print Format(6.789, "00.0000") ' возвратит 06,7890
#
Прототип цифры. Выводит цифру или не выводит ничего. Если форматируемое выражение содержит цифру в позиции, соответствующей символу # в строке формата, то в данной позиции будет выведена цифра; в противном случае данная позиция останется пустой. Отличие данного символа от символа формата "0" состоит в том, что если количество цифр в целой или дробной части форматируемого числа меньше, чем число символов "#" слева или справа от десятичного разделителя в строке формата, соответственно, то недостающие нули в начале или конце числа добавлены не будут
Print Format(6.789, "##.0000") ' возвратит 6,7890
.
Десятичный разделитель. В некоторых национальных настройках десятичным разделителем служит запятая. Десятичный разделитель указывает, сколько цифр следует вывести в целой и дробной части форматируемого числа, т.е. слева и справа от десятичного разделителя. Если строка формата содержит слева от десятичного разделителя только символы "#", то число, меньшее единицы, при выводе будет начинаться с десятичного разделителя. Если требуется, чтобы дробные числа всегда изображались с начальным нулем перед десятичным разделителем, следует использовать символ формата "0" в качестве первого символа строки числового формата. Фактический символ, используемый в качестве десятичного разделителя, определяется установленным в системе числовым форматом. В России в качестве десятичного разделителя используется запятая
Print Format(0.789, "##.0000") ' возвратит ,7890
%
Процентный формат. Выражение умножается на 100. Символ процентов (%) выводится в позиции, соответствующей позиции прототипа в строке формата
Print Format(0.17, "0%") ' возвратит 17%
,
Разделитель групп разрядов. В некоторых национальных настройках в качестве разделителя групп разрядов используется точка. Разделитель групп разрядов разделяет позиции тысяч и сотен в числе, целая часть которого состоит из четырех или большего числа цифр. Стандартное применение разделителя групп разрядов задается в строке формата, в которой пробел окружен символами вывода цифры (0 или #). Два соседних разделителя групп разрядов или разделитель групп разрядов, стоящие сразу перед десятичным разделителем (даже если символ десятичного разделителя не указан явно), означают, что масштаб числа следует изменить, разделив его указанное число раз на 1000 и округлив по мере надобности. Такой способ позволяет выводить большие числа. Например, строка формата "##0,," отображает сто миллионов как 100, а числа, меньшие одного миллиона, как 0. Два соседних разделителя групп разрядов, находящихся в любой другой позиции, обрабатываются как один разделитель групп разрядов. Фактический символ, используемый в качестве разделителя групп разрядов, определяется установленным в системе числовым форматом. В России в качестве разделителя групп разрядов используется пробел
:
Разделитель компонентов времени. В некоторых национальный настройках в качестве разделителя компонентов времени используется другой символ. Разделитель компонентов времени используется для разделения компонентов времени (часов, минут и секунд). Фактический символ, используемый в качестве разделителя компонентов времени, определяется текущей национальной настройкой. В России в качестве разделителя компонентов времени используется двоеточие
Print Format(Now, "h:m:s") ' возвратит к примеру 11:23:35
/
Разделитель компонентов даты. В некоторых национальный настройках в качестве разделителя компонентов даты используется другой символ. Разделитель компонентов даты используется для разделения компонентов даты (дня, месяца и года). Фактический символ, используемый в качестве разделителя компонентов даты, определяется текущей национальной настройкой. В России в качестве разделителя компонентов даты используется точка
E- E+ e- e+
Экспоненциальный формат. Если строка формата содержит хотя бы один прототип цифры (0 или #) справа от символов "E-", "E+", "e-" или "e+", то число выводится в экспоненциальном формате, а между числом и показателем степени помещаются символы "E" или "e". Число цифр в показателе степени определяется числом символов вывода цифры справа от символа экспоненциального формата. Для вывода знака минус (-) перед отрицательными значениями показателя степени следует использовать символы "E-" или "e-"; в этом случае знак перед положительными значениями показателя степени не ставится. Для вывода знака плюс перед положительными значениями показателя степени и знака минус перед отрицательными значениями показателя степени следует использовать символы "E+" или "e+"
- + $ ()
Вывод указанного символа. Для вывода любого не перечисленных здесь символов следует поместить перед ним символ обратной косой черты (\) или заключить символ в прямые кавычки (" ")
\
Вывод следующего символа из строки формата. Многие символы в строке формата имеют специальное назначение и не могут быть выведены в явном виде, если перед ними не стоит символ обратной косой черта. Сам символ "обратная косая черта" при этом не отображается. Наличие данного символа форматирования эквивалентно заключению следующего за ним в строке формата символа в прямые кавычки. Для вывода самого символа "обратная косая черта" следует указать его дважды (\\).Примерами символов, которые не могут быть включены в строку форматирования явным образом, являются символы форматирования даты и времени (a, c, d, h, m, n, p, q, s, t, w, y, / и :), символы форматирования чисел (#, 0, %, E, e, запятая и точка) и символы форматирования строк (@, &, <, > и !)
"ABC"
Вывод строки, заключенной в прямые кавычки (" "). Для представления кавычек в аргументе формат в программе необходимо использовать функцию Chr(34) (34 является кодом символа прямых кавычек ("))

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


форматный вывод

Организация форматного вывода значений

на главную страницу

Функция формат

Форматирование числовых и денежных величин

Форматирование логических величин

Форматирование строковых величин

Форматирование величин дат и времени

Функция FormatCurrency

Функция FormatDateTime

Функция FormatNumber

Функция FormatPercent

Символы форматирования числовых величин

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Изучение среды и основ работы в Visual Basic

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является изучение основных компонентов интегрированной среды разработки приложений Visual Basic, и приобретение начальных навыков работы в среде при создании простейших приложений.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • В порядке, описанном в методических указаниях, изучить основные компоненты интегрированной среды разработки приложений Visual Basic.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - запуск Visual Basic и создание нового проекта в Visual Basic

  • Задание 2 - изучение основных компонентов интерфейса Visual Basic

  • Задание 3 - изучение окна конструктора форм и панели элементов управления

  • Задание 4 - создание формы приложения с размещенными на ней объектами и сохранение проекта

  • Задание 5 - запуск приложения и изучение окна редактора исходного кода

  • Задание 6 - создание простейшего приложения

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных компонентов интегрированной среды разработки приложений Visual Basic и файлы результатов выполнения заданий.

Дополнительный материал

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Заключение и выводы

начало

вперед

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены основные компоненты интегрированной среды разработки приложений Visual Basic, изучены приемы разработки макета формы приложения с размещением на ней стандартных компонентов графического интерфейса прикладных программ, создано простейшее приложение.

Были рассмотрены темы:

  • Задание 1 - запуск Visual Basic и создание нового проекта в Visual Basic

  • Задание 2 - изучение основных компонентов интерфейса Visual Basic

  • Задание 3 - изучение окна конструктора форм и панели элементов управления

  • Задание 4 - создание формы приложения с размещенными на ней объектами и сохранение проекта

  • Задание 5 - запуск приложения и изучение окна редактора исходного кода

  • Задание 6 - создание простейшего приложения

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • краткое описание основных компонентов интегрированной среды разработки приложений Visual Basic;

  • описание приемов создания формы приложения;

  • файл с проектом, представляющим собой форму с размещенными на ней объектами (на дискете);

  • файл с проектом простейшего приложения (на дискете);

  • заключения и выводы.

Дополнительный материал

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Вопросы к лабораторной работе

конец

вопросы

задания

  1. Чем Visual Basic отличается от других версий языка Basic?

  2. Что в среде Visual Basic принято называть проектами?

  3. Каким образом можно создать новый проект в среде Visual Basic?

  4. Назовите основные рабочие окна среды Visual Basic

  5. Для чего нужно окно конструктора форм?

  6. Каким образом можно открыть окно конструктора форм?

  7. Для чего нужна сетка в окне конструктора форм?

  8. Как изменить шаг сетки окна конструктора форм?

  9. Для чего нужна панель элементов управления?

  10. Как поместить новые компоненты на панель элементов управления?

  11. Как показать в окне выбора компонентов только активные (отмеченные ключами) пункты?

  12. Как разместить объекты на форме?

  13. Как сохранить подготовленный проект?

  14. Что надо сделать для запуска (выполнения) созданного в Visual Basic приложения?

  15. Для чего предназначен редактор исходного кода?

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Запуск Visual Basic и создание нового проекта (шаблон Standard EXE).

начало

назад

вперед

конец

вопросы

задания

Запустить программу Visual Basic 6.0 можно: из главного меню Windows; используя ярлык на рабочем столе; выполнив файл VB6.EXE

ЗАДАНИЕ 1.
Запустите Visual Basic, используя один из приемов запуска приложений в Windows.

При запуске Visual Basic 6.0 (в дальнейшем изложении - Visual Basic, без указания версии) на экране появляется диалоговое окно New Project (Новый проект), используя которое можно:

- создать новый проект используя шаблоны создания проекта (вкладка New)
- создать новый проект используя мастера создания проекта (вкладка New)
- открыть ранее созданный проект (вкладки Existing и Recent)

Окно создания проекта содержит три вкладки следующего назначения:

- New (Новый) — содержит шаблоны и мастера для создания нового проекта;

- Existing (Существующий) — позволяет открыть ранее созданный проект или проекты-примеры, поставляемые с Visual Basic. Вкладка имеет раскрывающийся список, с помощью которого можно выбрать любую папку на имеющихся ресурсах компьютера;

- Recent (Недавно созданный) — содержит список проектов, открывавшихся в последнее время.

По умолчанию ключ (Don't show dialog in the future), расположенный в нижней части окна выключен.
Выключенный ключ Don't show dialog in the future (не показывать этот диалог в будущем) означает, что это окно будет появляться всегда при запуске Visual Basic
Включенный ключ Don't show dialog in the future (не показывать этот диалог в будущем) означает, что это окно не будет появляться при запуске Visual Basic. НЕ включате этот ключ.

Типы шаблонов и мастеров проекта:

- Standard EXE — стандартное выполняемое приложение;

- ActiveX EXE — выполняемое приложение ActiveX;

- ActiveX DLL — динамическая библиотека ActiveX;

- ActiveX Control — элемент управления ActiveX;

- VB Application Wizard — мастер приложений;

- VB Wizard Manager — мастер создания пользовательских мастеров;

- Data Project — проект управления базой данных;

- IIS Application — приложение, размещаемоt на сервере Web-узла (IIS — Internet Information Server);

- Addin — надстройка, дополнительные утилиты, расширяющие возможности приложений;

- ActiveX Document DLL — динамическая библиотека документов ActiveX;

- ActiveX Document EXE — выполняемое приложение документов ActiveX;

- DHTML Application — приложение, создающее динамические HTML-страницы.

ЗАДАНИЕ 2.
 Создайте новый проект приложения, выбрав в окне создания проекта вкладку New шаблон Standard EXE.

начало

назад

вперед

конец

вопросы


Запуск Visual Basic

Из главного меню Windows. Для этого выполните следующие действия.

1. Нажмите кнопку Пуск, расположенную на панели задач Windows.

2. В открывшемся главном меню Windows:
- выберите подменю Программы;
- в нем Microsoft Visual Basic 6.0 (или, возможно, Microsoft Visual Studio 6.0)
- затем выберите Microsoft Visual Basic 6.0

Используя ярлык на рабочем столе. (если этот ярлык был создан и помещен на рабочий стол).
Выполнив файл VB6.EXE c:\Program Files\Microsoft Visual Studio\VB98\VB6.EXE (путь указан для установки программы Visual Basic по умолчанию).


Для запуска программы из главного меню Windows выполните следующие действия

Основные компоненты интерфейса Visual Basic

конец

вопросы

задания

После выбора типа проекта (в нашем случае Standard EXE) мы перейдем непосредственно в инструментальную среду проектирования Visual Basic. Ее внешний вид показан на рисунке.

Главное меню (текстовое меню), как и во всех приложениях Microsoft, представляет собой линейку раскрывающихся меню. Оно содержит следующие основные команды: File (Файл), Edit (Правка), View (Вид), Project (Проект), Format (Формат), Debug (Отладка), Run (Запуск), Query (Запрос), Diagram (Диаграмма), Tools (Сервис), Add-Ins (Надстройки), Window (Окно), Help (Справка).

Наиболее часто используемые команды меню отображены в виде кнопок со значками на панели инструментов (пиктографическом меню), размещенной ниже меню.

ЗАДАНИЕ 3.
Используя пиктографическое меню и пункт View (Вид) главного меню, откройте основные рабочие окна среды Visual Basic и расположите их на экране так, чтобы они не перекрывали друг друга.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Текстовое и пиктографическое меню

Главное меню

Наиболее часто используемые команды меню отображены в виде кнопок со значками на стандартной панели инструментов, размещенной ниже меню. Рассмотрим основные команды главного меню.

Меню File (Файл) содержит команды для работы с файлами проекта. Используя эти команды, можно выполнять такие действия, как создание нового проекта, открытие проекта для внесения изменений, добавление проекта для параллельной работы над несколькими проектами или копирование форм из проекта в проект и т. п. Все команды этого меню перечислены в табл. 1- 13 Приложения.

Меню Edit (Правка) содержит команды, предназначенные для редактирования. Часть из них соответствует подобным командам редактирования других приложений Microsoft, например, отменить предыдущую команду, повторить предыдущую команду, вырезать фрагмент текста, скопировать фрагмент в буфер обмена. В составе этого меню целый набор команд для работы с таблицами базы данных: добавлять и удалять поля, назначать первичный ключ в таблице базы данных.

Меню View (Вид) содержит команды вызова окон и панелей инструментальной среды Visual Basic 6.

Меню Project (Проект) содержит команды управления проектом и его элементами. Они позволяют добавить в проект и удалить из него элементы проекта, такие как форма, программный модуль, класс и другие. С помощью команд данного меню вы также можете открыть окно свойств приложения, добавить ссылки на подключаемые библиотеки, добавить дополнительные компоненты на панель элементов.

Меню Format (Формат) содержит большое количество команд форматирования объектов в форме.

Меню Debug (Отладка) содержит команды, предназначенные для отладки приложения. Используя команды этого меню, можно установить точки останова программы и проверить значения выражении и переменных, выполняя программу по шагам.

Меню Run (Запуск) содержит команды управления запуском приложения. Используя команды данного меню, можно запустить приложение на выполнение с компиляцией или без компиляции, приостановить или прервать выполнение приложения.

Меню Query (Запрос) содержит команды создания и выполнения запросов к базе данных. При помощи этого меню, например, можно выполнить запрос, преобразовать результаты запроса в табличный вид.

Меню Diagram (Диаграмма) содержит команды построения диаграммы, отображающей структуру базы данных.

Меню Tools (Сервис) содержит команды управления настройками инструментария среды Visual Basic 6. Они позволяют добавить процедуру и определять ее атрибуты, вызвать окно редактора меню, изменить настройки программы в диалоговом окне Options (Параметры), а также управлять хранилищем проектов SourseSafe.

Меню Add-Ins (Надстройки) содержит команды вызова дополнительных утилит, часто называемых надстройками (add-ins).

Меню Window (Окно) содержит стандартные команды управления окнами. При вызове окон приложения меню Window пополняется соответствующими командами активизации окон приложения. При этом команды активизации окон называются по именам открытых окон.

Меню Help (Справка) содержит команды вызова справочной системы Visual Basic 6. При помощи этого меню можно вызывать справочную систему с различными вариантами представления информации. Отличие между ними состоит в открывающейся по умолчанию вкладке.

Стандартная панель инструментов

Команды, которые часто используются при работе, можно разместить в виде кнопок на панели инструментов. Можно также исключить из панели редко применяемые команды.

Кнопки панели инструментов снабжены всплывающими подсказками.

Стандартная панель инструментов, расположенная под главным меню, показана в том виде, в каком она настроена при установке Visual Basic.

Если эта панель отсутствует в главном окне программы, для ее отображения в меню View (Вид) выберите команду Toolbars (Панели инструментов), а затем значение Standard (Стандартная).

На стандартной панели инструментов расположены кнопки для вызова наиболее часто употребляемых команд меню. Вы можете изменить расположение стандартной панели инструментов, разместив ее в нижней части главного окна, справа или слева. Для этого с помощью кнопки мыши захватите любую границу панели и переместите ее в любое удобное для вас место.


Для запуска программы из главного меню Windows выполните следующие действия

Окна: конструктора форм и панель элементов управления

конец

вопросы

задания

Основными рабочими элементами среды Visual Basic, с помощью которых выполняется визуальное проектирование приложения являются окно конструктора форм и панель элементов управления.

Окно конструктора форм

В окне конструктора форм визуально конструируются все формы приложения с использованием инструментария среды разработки. Окно конструктора форм открывается автоматически после загрузки среды Visual Basic.

Если окно закрыто, вызвать его можно из главного меню командой Object (Объект) меню View (Вид) или командой View Object контекстного меню объекта, находящегося в группе Forms в проводнике проекта.

Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять. При необходимости сетку можно отключать, воспользовавшись параметрами диалогового окна Options, открываемого командой Options (Параметры) из меню View (Вид).

Размер формы в окне можно изменять, используя маркеры выделения формы и мышь. Для изменения размера формы необходимо установить указатель мыши на маркер и, когда он примет вид двунаправленной стрелки, перемещать до получения требуемого размера.

Панель элементов управления

Панель элементов управления открывается автоматически после загрузки среды Visual Basic. Если панель элементов закрыта, вызывать ее можно из меню View (Вид) командой Toolbox (Панель элементов управления) или воспользоваться кнопкой Toolbox на стандартной панели инструментов.

В составе панели элементов управления содержатся основные элементы (компоненты), размещаемые на форме при ее проектировании — метки, текстовые поля, кнопки, списки и другие элементы для быстрого визуального проектирования макета формы.

Для размещения элементов управления в форме с помощью панели элементов выполните следующие действия:

1. Выделите требуемый элемент управления с помощью мыши.

2. Перейдите в окно конструктора форм. Указатель мыши при этом превратится в крестик, при помощи которого можно установить местоположение размещаемого объекта. Левой кнопкой мыши зафиксируйте позицию нового объекта и, удерживая кнопку, задайте размеры объекта.

Поместить на панель элементов управления компоненты можно используя пункт Components...(Компоненты) контекстного меню, вызываемого правой кнопкой мыши при нахождении курсора на свободной области панели элементов управления. При этом откроется окно выбора компонентов.

Окно выбора компонентов содержит три вкладки:

Controls (Средства управления) - позволяет выбрать компоненты, размещаемые на панели элементов управления. Компоненты хранятся в файлах, имеющих расширение .OCX или в файлах динамических библиотек .DLL. Выбрать файлы можно также вручную, используя кнопку Browse... (Просмотр)

Designers (Проектировщики) - позволяет подключить динамические библиотеки, необходимые для работы создаваемого в среде Visual Basic приложения.

Insertable Objects (Встраиваемые объекты) - позволяет выбрать компоненты, представляющие собой OLE - объекты или программные приложения. Компоненты хранятся в файлах, имеющих расширение .OCX, в файлах динамических библиотек .DLL или в исполняемых файлах .EXE.

Ключ Select Items Only (Только выбранные пункты) позволяет исключить из списка компонентов пункты, не отмеченные ключами выбора.

ЗАДАНИЕ 4.
Разместите на панели элементов управления компоненты Microsoft Windows Commom Controls 6.0.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание формы приложения и сохранение проекта

конец

вопросы

задания

Создание любого приложения в Visual Basic начинается с создания проекта. Проектом является совокупность файлов, входящих в приложение и хранящих информацию о его компонентах. Проект стандартного приложения создается на основе шаблона Standard EXE.

Большинство приложений, созданных в Visual Basic, работают в интерактивном режиме. На экран выводится информация, предназначенная для пользователя программы, и ожидается его ответная реакция в виде ввода данных или команд. Интерактивное приложение в Visual Basic создается на базе формы, являющейся, как правило, основным окном интерфейса, с элементами управления, позволяющими осуществлять взаимодействие с пользователями.

В Visual Basic при создании форм разработчик может использовать шаблоны и мастера, а также конструктор форм. Конструктор форм предназначен для самостоятельной разработки формы с заданными свойствами или для изменения формы, созданной с помощью мастера.

Размещение элементов управления в форме осуществляется следующим образом:

1. На панели элементов управления выбирается необходимый компонент, на основе которого будет создан объект, размещаемый на форме, например TextBox

2. Курсор, принявший вид перекрестия, устанавливается в место предполагаемого размещения объекта в форме.

3. При нажатой левой кнопке мыши прорисовывается рамка требуемого размера. При этом рядом с курсором мыши появляются текущие размеры создаваемого объекта.

4. После того, как кнопка мыши будет отпущена, на форме появится изображение объекта.

Для сохранения проекта выполните следующие действия:

1. В меню File (Файл) выберите команду Save Project (Сохранить проект) или нажмите кнопку Save Project на стандартной панели инструментов.

2. В открывшемся диалоговом окне Save File As список Тип файла содержит значение Form Files, указывая, что сохраняется входящая в приложение форма (файл с расширением .frm). Используя раскрывающийся список Папка, выберите папку, в которой будет сохранена форма, затем в поле Имя файла введите имя формы и нажмите кнопку Сохранить.

3. Так как никаких компонентов, кроме формы, новое приложение не содержит, появляется диалоговое окно Save Project As (Сохранить проект как) для сохранения самого проекта (файлы с расширениями .vbp и vpw). По умолчанию в списке Папка выбрана папка, в которой сохранили форму. Введите наименование проекта и нажмите кнопку Сохранить.

При последующем сохранении проекта Visual Basic по умолчанию сохраняет файлы под их именами. Если же в проект с момента последнего сохранения были добавлены новые компоненты, откроется диалоговое окно Save File As для присвоения им имен.

Замечание: Для облегчения работы с проектом и входящими в его состав файлами, прежде чем сохранять проект, создайте отдельную папку, в которой затем и сохраните все файлы.

ЗАДАНИЕ 5.
Создайте форму, показанную на рисунке, разместив на ней необходимые объекты и сохраните проект на диске в папке, указанной преподавателем.

Замечание: при создании формы используйте компоненты панели элементов управления General и Microsoft Windows Commom Controls 6.0

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Запуск приложения и работа с окном редактора исходного кода

конец

вопросы

задания

Для запуска (выполнения) созданного в Visual Basic приложения можно:

- выполнить команду Start , расположенную в пункте Run (Выполнить) главного меню;
- нажать кнопку Start на стандартной панели инструментов Visual Basic;
- нажать клавишу <F5> на клавиатуре ПК.

После этого приложение начнет выполнять запрограммированные в нем действия.

ЗАДАНИЕ 6.
Выполните созданное Вами приложение.

После запуска Вашего приложения (созданная Вами форма) приложения Вы сможете:

- заполнять текстовое поле;

- устанавливать значения ключей (флажков) и переключателей;

- выбирать диски;

- перемещаться по папок и выбирать их

- перемещаться по списку фацлов и выбирать их

- перемещать ползунок по шкале вправо и влево.

- активизировать командные кнопки, нажимая их;

Однако при этом никакой взаимосвязи между объектами формы не будет и никаких других действий это приложение выполнять не будет, поскольку для объектов не созданы тексты (коды) процедур.

Для завершения работы приложения можно:

- нажать на крестик в правом верхнем углу формы;
- выполнить команду End , расположенную в пункте Run главного меню;
- нажать кнопку End на стандартной панели инструментов Visual Basic;
- нажать сочетание клавиш Alt + <F4> на клавиатуре ПК.

Окно редактора исходного кода

Редактор кода Code (Код) — это мощный встроенный редактор с удобными средствами ввода текста (исходного кода) программы.

Из меню View (Вид) перейти в редактор кода можно с помощью команды Code (Код). Для быстрого открытия окна редактора кода достаточно дважды щелкнуть левой кнопкой мыши, установив указатель на форме приложения. После начала редактирование кода программы имя открытого окна появляется и в списке команд перехода между окнами Window (Окно) главного меню. Переход между макетом и окном редактора кода можно выполнять, используя список меню Window.

ЗАДАНИЕ 7.
Откройте окно редактора исходного кода (Code) и просмотрите заготовки текста процедур, автоматически сгенерированные средой Visual Basic для созданной Вами формы.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание простейшего приложения

конец

вопросы

задания

Задача: создайте приложение, позволяющее по заданному пользователем программы радиусу R вычислять площадь S и длину окружности L. (S=3.14*R*R; L=2*3.14*R)
Для создания приложения подготовим форму, содержащую два объекта:

1. Кнопку (CommandButton)
2. Текстовое поле (TextBox)

В окне редактора исходного кода ( в процедуре Private Sub Command1_Click() ) наберем текст программы:
ЗАДАНИЕ 8.
Выполните приложение, введите в Текстовое поле (TextBox) вместо слова Text1 некоторое число, например 27, щелкните мышкой по Кнопке (CommandButton) Command1 и получите результат.

начало

назад

вперед

конец

вопросы


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работ а: Организация ввода-вывода данных, изменение свойств объектов

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является изучение основных компонентов интегрированной среды разработки приложений Visual Basic, и приобретение начальных навыков работы в среде при создании простейших приложений.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • В порядке, описанном в методических указаниях, изучить правила организации ввода-вывода данных в Visual Basic.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить указанные в заданиях результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение способов ввода данных в Visual Basic

  • Задание 2 - изучение способов вывода результатов в Visual Basic

  • Задание 3 - изучение возможностей организации форматного вывода данных

  • Задание 4 - изменение названий объектов

  • Задание 5 - создание простого приложения

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он долджен содержать:

  • название, цель и задачи лабораторной работы;

  • описание приемов организации ввода-вывода данных в Visual Basic;

  • файлы проектов с результатами выполнения заданий.

Дополнительный материал:

Организация форматного вывода данных

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Заключение и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены основные приемы организации ввода данных и вывода значений (результатов работы программы) в интегрированной среде разработки приложений Visual Basic, изучены правила организации форматного вывода значений создано приложение, использующее ввод-вывод данных.

Были рассмотрены темы:

  • Задание 1 - изучение способов ввода данных в Visual Basic

  • Задание 2 - изучение способов вывода результатов в Visual Basic

  • Задание 3 - изучение возможностей организации форматного вывода данных

  • Задание 4 - создание простого приложения

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • описание приемов организации ввода-вывода данных в Visual Basic;

  • файлы проектов с результатами выполнения заданий.

Дополнительный материал:

Организация форматного вывода данных

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Вопросы к лабораторной работе

конец

вопросы

задания

  1. Какие способы организации ввода данных в Visual Basic Вы знаете?

  2. Как организовать ввод данных с помощью функции функции InputBox?

  3. Как организовать ввод данных с помощью элемента управления TextBox?

  4. Какие способы организации ввода данных в Visual Basic Вы знаете?

  5. Как организовать ввод значения переменной на форму?

  6. Как организовать ввод значения переменной в окно PictureBox?

  7. Как организовать ввод значения переменной в окно TextBox?

  8. Для чего функция Format?

  9. Приведите общий вид функции Format и объясните назначение ее параметров?

  10. Какие символы форматирования применяются для создания пользовательских форматов числовых величин?

начало

назад

вперед

конец

вопросы


Задания к лабораторной работе

Все задания к лабораторной работе

конец

вопросы

задания

ЗАДАНИЕ 1.
Создайте новый проект приложения и реализуйте ввод данных с помощью функции InputBox и элемента управления TextBox. Сохраните проект на диске.

ЗАДАНИЕ 2.
Создайте форму, разместив на ней компоненты PictureBox и TextBox. Выполните вывод значений переменной на форму, в окно PictureBox и в окно TextBox.

ЗАДАНИЕ 3.
 Используя ранее созданный проект, выполните форматный вывод значений переменной на форму, в окно PictureBox и в окно TextBox. Сохраните проект на диске.
ЗАДАНИЕ 4.
Создайте форму с 3-4 объектами и измените их свойства. Сохраните проект на диске.
ЗАДАНИЕ 5.
Создайте проект и напишите программу вычисления площади сектора Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Используйте различные варианты организации ввода-вывода данных. Для вывода результатов используйте форматный вывод.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Организация ввода данных

конец

вопросы

задания

Практически любая создаваемая программа, выполняющая заложенные в ней действия должна получить от пользователя исходные данные для работы. Ввод данных как правило осуществляется сразу после запуска программы. Данные могут быт также запрошены для продолжения выполнения программы в процессе ее работы.

С помощью функции InputBox

1. Из модального диалогового окна по запросу приложения сразу после его запуска. При этом не имеет значения, какие объекты расположены на форме, она может быть даже пустой.

 Для этого необходимо в процедуру формы записать оператор (здесь и далее программный код, который должен быть написаны разработчиком приложения выделен жирным шрифтом):

Private Sub Form_Load()
x = InputBox("Введите значение переменной X", "Ввод данных")
End Sub

2. Из модального диалогового окна, после наступления некоторого события, активизирующего InputBox, например при нажатии кнопки на форме.

 Для этого необходимо в процедуру командной кнопки записать оператор:

Private Sub Command1_Click()
x = InputBox("Введите значение переменной X", "Ввод данных")
End Sub

Замечание: Функция InputBox возвращает строковое значение, поэтому если вы вводите числа, то лучше использовать функцию Val, которая преобразует строку в число:
x=Val(InputBox("Введите значение переменной X", "Ввод данных"))

С помощью элемента управления TextBox

Для этого необходимо в процедуру элемента TextBox записать оператор:

Private Sub Command1_Click()
a = Text1
End Sub

ЗАДАНИЕ 1.
 Создайте новый проект приложения и реализуйте ввод данных с помощью функции InputBox и элемента управления TextBox. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Организация вывода результатов

конец

вопросы

задания

Вывод значения переменной на форму с помощью процедуры Print

Private Sub Command1_Click()
x = 127
Print "Значение x="; x
End Sub

Вывод значения переменной в окно PictureBox с использованием метода Print

 Private Sub Command1_Click()
x = 127
Picture1.Print "Значение x=";x
End Sub

Вывод значения переменной в окно TextBox

Private Sub Command1_Click()
x = -326.597
Text1 = x
End Sub

Вывод значения переменной на метку Label

Форма с размещенной на ней меткой Label1

Private Sub Command1_Click()
St = "Значение Х = "
X = -567.12343
Label1.Caption = St & X
End Sub
ЗАДАНИЕ 2.
Создайте форму, разместив на ней компоненты PictureBox и TextBox. Выполните вывод значений переменной на форму, в окно PictureBox и в окно TextBox и на метку Label.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Форматы вывода данных

конец

вопросы

задания

Для форматирования данных (выражения) в Visual Basic используется функция Format.

Функция Format возвращает значение типа Variant (String), содержащее выражение, отформатированное согласно инструкциям, заданным в описании формата

Общий вид функции (в скобках указаны необязательные параметры, которые можно опустить при обращении к функции):
Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])

Параметры функции

Параметр Expression
Обязательный аргумент-любое допустимое выражение, подлежащее форматированию.
Параметр Format
Необязательный аргумент-любое допустимое именованное или определяемое пользователем выражение формата. При форматировании чисел без указания аргумента Format функция Format выдает тот же результат, что и функция Str(number) - Возвращает строку, представляющую число), хотя эта функция учитывает национальную настройку. Отличие состоит в том, что при преобразовании положительного числа с помощью функции Format пробел в начале строки (на месте знака числа) теряется, а при преобразовании с помощью функции Str останется

Символы форматирования, применяемые для создания пользовательских форматов числовых величин

0
Прототип цифры. Выводит цифру или нуль.
Print Format(6.789, "00.0000") ' возвратит 06,7890
#
Прототип цифры. Выводит цифру или не выводит ничего.
Print Format(6.789, "##.0000") ' возвратит 6,7890
.
Десятичный разделитель. В некоторых национальных настройках десятичным разделителем служит запятая. Десятичный разделитель указывает, сколько цифр следует вывести в целой и дробной части форматируемого числа, т.е. слева и справа от десятичного разделителя.
Print Format(0.789, "##.0000") ' возвратит ,7890
%
Процентный формат. Выражение умножается на 100. Символ процентов (%) выводится в позиции, соответствующей позиции прототипа в строке формата
Print Format(0.17, "0%") ' возвратит 17%
,
Разделитель групп разрядов. В некоторых национальных настройках в качестве разделителя групп разрядов используется точка. Разделитель групп разрядов разделяет позиции тысяч и сотен в числе, целая часть которого состоит из четырех или большего числа цифр.
:
Разделитель компонентов времени. В некоторых национальный настройках в качестве разделителя компонентов времени используется другой символ.
Print Format(Now, "h:m:s") ' возвратит к примеру 11:23:35
/
Разделитель компонентов даты. В некоторых национальный настройках в качестве разделителя компонентов даты используется другой символ.
E- E+ e- e+
Экспоненциальный формат. Для вывода знака плюс перед положительными значениями показателя степени и знака минус перед отрицательными значениями показателя степени следует использовать символы "E+" или "e+"
- + $ ()
Вывод указанного символа. Для вывода любого не перечисленных здесь символов следует поместить перед ним символ обратной косой черты (\) или заключить символ в прямые кавычки (" ")
\
Вывод следующего символа из строки формата. Примерами символов, которые не могут быть включены в строку форматирования явным образом, являются символы форматирования даты и времени (a, c, d, h, m, n, p, q, s, t, w, y, / и :), символы форматирования чисел (#, 0, %, E, e, запятая и точка) и символы форматирования строк (@, &, <, > и !)
"ABC"
Вывод строки, заключенной в прямые кавычки (" "). Для представления кавычек в аргументе формат в программе необходимо использовать функцию Chr(34) (34 является кодом символа прямых кавычек ("))

Дополнительно: Подробное описание символов форматирования, применяемые для создания пользовательских форматов числовых величин

Параметр FirstDayOfWeek
Необязательный аргумент-константа, определяющая первый день недели
Параметр FirstWeekOfYear
Необязательный аргумент-числовая константа, указывающая, какую неделю считать первой в году:

Дополнительно: Описание параметров FirstDayOfWeek и FirstWeekOfYear

Ниже приведено окно формы программы, демонстрирующей примеры форматирования числовых данных с использованием функции Format.

Фрагмент текста программы, демонстрирующей примеры форматирования числовых данных с использованием функции Format.

ЗАДАНИЕ 3.
Используя ранее созданный проект, выполните форматный вывод значений переменной на форму, в окно PictureBox и в окно TextBox. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Текстовое и пиктографическое меню

Общий вид функции:
Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])
Параметр Format
Необязательный аргумент-любое допустимое именованное или определяемое пользователем выражение формата. При форматировании чисел без указания аргумента Format функция Format выдает тот же результат, что и функция Str(number) - Возвращает строку, представляющую число), хотя эта функция учитывает национальную настройку. Отличие состоит в том, что при преобразовании положительного числа с помощью функции Format пробел в начале строки (на месте знака числа) теряется, а при преобразовании с помощью функции Str останется

Символы форматирования, применяемые для создания пользовательских форматов числовых величин

0
Прототип цифры. Выводит цифру или нуль. Если форматируемое выражение содержит цифру в позиции, соответствующей прототипу "0" в строке формата, то в данной позиции будет выведена эта цифра; в противном случае в данной позиции будет выведен нуль. Если число цифр в целой или дробной части форматируемого числа меньше, чем число прототипов "0" слева или справа от десятичного разделителя в строке формата, соответственно, то в начало или конец числа будут добавлены недостающие нули. Если количество цифр в дробной части форматируемого числа больше, чем количество прототипов "0" справа от десятичного разделителя в строке формата, то число будет округлено с соответствующей точностью. Если количество цифр в целой части форматируемого числа больше, чем количество прототипов "0" слева от десятичного разделителя в строке формата, то лишние цифры будут выведены без изменения
Print Format(6.789, "00.0000") ' возвратит 06,7890
#
Прототип цифры. Выводит цифру или не выводит ничего. Если форматируемое выражение содержит цифру в позиции, соответствующей символу # в строке формата, то в данной позиции будет выведена цифра; в противном случае данная позиция останется пустой. Отличие данного символа от символа формата "0" состоит в том, что если количество цифр в целой или дробной части форматируемого числа меньше, чем число символов "#" слева или справа от десятичного разделителя в строке формата, соответственно, то недостающие нули в начале или конце числа добавлены не будут
Print Format(6.789, "##.0000") ' возвратит 6,7890
.
Десятичный разделитель. В некоторых национальных настройках десятичным разделителем служит запятая. Десятичный разделитель указывает, сколько цифр следует вывести в целой и дробной части форматируемого числа, т.е. слева и справа от десятичного разделителя. Если строка формата содержит слева от десятичного разделителя только символы "#", то число, меньшее единицы, при выводе будет начинаться с десятичного разделителя. Если требуется, чтобы дробные числа всегда изображались с начальным нулем перед десятичным разделителем, следует использовать символ формата "0" в качестве первого символа строки числового формата. Фактический символ, используемый в качестве десятичного разделителя, определяется установленным в системе числовым форматом. В России в качестве десятичного разделителя используется запятая
Print Format(0.789, "##.0000") ' возвратит ,7890
%
Процентный формат. Выражение умножается на 100. Символ процентов (%) выводится в позиции, соответствующей позиции прототипа в строке формата
Print Format(0.17, "0%") ' возвратит 17%
,
Разделитель групп разрядов. В некоторых национальных настройках в качестве разделителя групп разрядов используется точка. Разделитель групп разрядов разделяет позиции тысяч и сотен в числе, целая часть которого состоит из четырех или большего числа цифр. Стандартное применение разделителя групп разрядов задается в строке формата, в которой пробел окружен символами вывода цифры (0 или #). Два соседних разделителя групп разрядов или разделитель групп разрядов, стоящие сразу перед десятичным разделителем (даже если символ десятичного разделителя не указан явно), означают, что масштаб числа следует изменить, разделив его указанное число раз на 1000 и округлив по мере надобности. Такой способ позволяет выводить большие числа. Например, строка формата "##0,," отображает сто миллионов как 100, а числа, меньшие одного миллиона, как 0. Два соседних разделителя групп разрядов, находящихся в любой другой позиции, обрабатываются как один разделитель групп разрядов. Фактический символ, используемый в качестве разделителя групп разрядов, определяется установленным в системе числовым форматом. В России в качестве разделителя групп разрядов используется пробел
:
Разделитель компонентов времени. В некоторых национальный настройках в качестве разделителя компонентов времени используется другой символ. Разделитель компонентов времени используется для разделения компонентов времени (часов, минут и секунд). Фактический символ, используемый в качестве разделителя компонентов времени, определяется текущей национальной настройкой. В России в качестве разделителя компонентов времени используется двоеточие (функция Now возвращает Variant значение, содержащее текущие системные дату и время).
Print Format(Now, "h:m:s") ' возвратит к примеру 11:23:35
/
Разделитель компонентов даты. В некоторых национальный настройках в качестве разделителя компонентов даты используется другой символ. Разделитель компонентов даты используется для разделения компонентов даты (дня, месяца и года). Фактический символ, используемый в качестве разделителя компонентов даты, определяется текущей национальной настройкой. В России в качестве разделителя компонентов даты используется точка
E- E+ e- e+
Экспоненциальный формат. Если строка формата содержит хотя бы один прототип цифры (0 или #) справа от символов "E-", "E+", "e-" или "e+", то число выводится в экспоненциальном формате, а между числом и показателем степени помещаются символы "E" или "e". Число цифр в показателе степени определяется числом символов вывода цифры справа от символа экспоненциального формата. Для вывода знака минус (-) перед отрицательными значениями показателя степени следует использовать символы "E-" или "e-"; в этом случае знак перед положительными значениями показателя степени не ставится. Для вывода знака плюс перед положительными значениями показателя степени и знака минус перед отрицательными значениями показателя степени следует использовать символы "E+" или "e+"
- + $ ()
Вывод указанного символа. Для вывода любого не перечисленных здесь символов следует поместить перед ним символ обратной косой черты (\) или заключить символ в прямые кавычки (" ")
\
Вывод следующего символа из строки формата. Многие символы в строке формата имеют специальное назначение и не могут быть выведены в явном виде, если перед ними не стоит символ обратной косой черта. Сам символ "обратная косая черта" при этом не отображается. Наличие данного символа форматирования эквивалентно заключению следующего за ним в строке формата символа в прямые кавычки. Для вывода самого символа "обратная косая черта" следует указать его дважды (\\).Примерами символов, которые не могут быть включены в строку форматирования явным образом, являются символы форматирования даты и времени (a, c, d, h, m, n, p, q, s, t, w, y, / и :), символы форматирования чисел (#, 0, %, E, e, запятая и точка) и символы форматирования строк (@, &, <, > и !)
"ABC"
Вывод строки, заключенной в прямые кавычки (" "). Для представления кавычек в аргументе формат в программе необходимо использовать функцию Chr(34) (34 является кодом символа прямых кавычек ("))

Использован материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Для запуска программы из главного меню Windows выполните следующие действия

Дополнительные сведения о функции Format

Общий вид функции:
Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])
Параметр FirstDayOfWeek
Необязательный аргумент-константа, определяющая первый день недели
vbUseSystem=0
Используется значение национальных системных установок
vbSunday=1
Воскресенье(по умолчанию)
vbMonday=2
Понедельник
vbTuesday=3
Вторник
vbWednesday=4
Среда
vbThursday=5
Четверг
vbFriday=6
Пятница
vbSaturday
Суббота
Параметр FirstWeekOfYear
Необязательный аргумент-числовая константа, указывающая, какую неделю считать первой в году:
vbUseSystem=0
Используется системная информация
vbFirstJan1=1
Неделя, содержащая 1 января
vbFirstFourDays=2
Первая неделя, содержащая как минимум 4 дня нового года
vbFirstFullWeek=3
Первая полная неделя года

Использован материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Для запуска программы из главного меню Windows выполните следующие действия

Изменение свойств объектов

конец

вопросы

задания

Для настройки свойств формы, а также размещенных в ней объектов предназначено окно Properties (Свойства) В нем, например, содержатся такие свойства выбранного объекта, как название, высота, ширина, цвет и др.

Диалоговое окно Properties вызывается командой Properties Window (Окно свойств) из меню View (Вид), кнопкой Properties Window на стандартной панели инструментов или командой Properties контекстного меню выбранного объекта. Поскольку форма и элементы управления каждый сами по себе являются объектами, набор свойств в этом окне меняется в зависимости от выбранного объекта. При помощи вкладок Alphabetic (По алфавиту) и Categorized (По категориям) свойства объекта можно просмотреть в алфавитном порядке или по группам (категориям) соответственно.

В нижней части окна вы всегда найдете подсказку, поясняющую назначение выбранного атрибута объекта. Более подробную информацию найдете в справочной системе Visual Basic 6, нажав клавишу <Fl>. При этом необходимо предварительно выделить интересующее вас свойство.

Используя диалоговое окно Properties, можно изменить установленные по умолчанию свойства объектов. Часть свойств объекта, например, размеры и расположение объектов, можно задать перемещением объекта и изменением его размеров с помощью мыши в конструкторе форм.

Ряд свойств, установленных на этапе разработки приложения в окне свойств Properties, допускается изменять при выполнении приложения, написав соответствующие коды в процедурах, создаваемых с помощью редактора кода.

Как правило, форма содержит много объектов. Если выбрать сразу несколько объектов, то в окне свойств отобразятся общие для этих объектов свойства.

В окне свойств Properties можно воспользоваться вкладкой Categorized (По категориям), которая выводит свойства, сгруппированные по типам (категориям). Вкладка Alphabetic (По алфавиту), расположит свойства в алфавитном порядке их названий, что даст возможность быстрее найти нужное свойство.

Рассмотрим основные группы свойств, представленные на вкладке Categorized окна Properties.

Свойства, определяющие внешний вид объекта.

В группе Appearance (Оформление) окна Properties содержатся свойства объекта, которые задают атрибуты его внешнего вида. Основные свойства данной группы:

Caption | - задает текст в строке заголовка объекта;
BorderStyle | - задает стиль рамки объекта;
Palette | - устанавливает цветовую палитру;
Picture | - назначает значок, картинку для объекта. Используя данное свойство формы, можно задать фоновое графическое изображение.

Свойства, определяющие поведение объекта.

Свойства объектов, отвечающие за их поведение, собраны в группе Behavior (Поведение). Основные свойства данной группы:

Causes Validation | - устанавливает признак проверки условия достоверности данных при выходе из объекта;
Enabled | - разрешает или запрещает доступ к объекту;
MaxLength | - устанавливает максимальную длину данных в объекте;
Visible | - устанавливает видимость объекта.

Свойства, определяющие шрифт.

Группа Font (Шрифт) содержит всего одно свойство Font, позволяющее с помощью диалогового окна Выбор шрифта задать шрифт текста объекта, размер, начертание.

Свойства группы Misc задают общие атрибуты объекта, в том числе для его идентификации.

Name | - задает имя объекта;
Text | - устанавливает текст в поле по умолчанию;
Index | - задает уникальный индекс объекта в коллекции;

По имени, указанному в свойстве Name (Имя), объект идентифицируется в форме и в тексте программы. Поэтому необходимо иметь в виду, что в одной форме не может быть двух объектов с одинаковыми именами. По умолчанию это свойство устанавливается автоматически. Вместо имени, заданного по умолчанию, лучше использовать имя, отражающее его смысловое значение.

Свойства позиционирования.

Left | - задает положение объекта по горизонтальной оси от левого края формы или, в общем случае, от объекта-контейнера;
Top | - задает положение объекта по вертикальной оси от его верхнего края до верхней стороны формы;
Width | - задает горизонтальный размер (ширину) объекта;
Height | - задает вертикальный размер (высоту) объекта.

Группа Position (Расположение) окна Properties служит для позиционирования объектов в системе координат формы и установки размеров объектов.

Свойства шкалы размеров объекта.

Свойства группы Scale (Масштаб) устанавливают шкалу максимальных размеров объектов в системе координат формы.

ScaleLeft | - задает максимальное положение объекта по горизонтальной оси;
ScaleTop | - задает максимальное положение объекта по вертикальной оси;
ScaleWidth | - задает максимальный горизонтальный размер (максимальная ширина);
ScaleHeight | - задает максимальный вертикальный размер (максимальная высота).

Дополнительно: Описание некоторых объектов и их основных свойств.

Пример формы с размещенными на ней объектами и измененными свойствами (цвет, шрифт, строка заголовка формы, надписи на объектах и др.

ЗАДАНИЕ 4.
Создайте форму с 3-4 объектами и измените их свойства. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Описание некоторых свойств объектов

Форма (Form)

AutoRedraw - способ автоматической перерисовки окна формы. Это свойство определяет, каким образом осуществляется повторное создание (восстановление) формы, например, после сворачивания (и последующего развертывания окна) или перекрытия изображения другими окнами. Если свойству присвоено значение True, то происходит автоматическое восстановление изображения. Если False (по умолчанию) – вызывается процедура обработки события перерисовки и выполняется код, написанный программистом.

BackColor - цвет фона окна формы. Значения цвета определяются шестнадцатеричной константой. В поле параметров окна свойств, можно из палитры цветов выбрать нужный цвет.

Border Style - тип границ окна и строки заголовка формы. Границы и строка заголовка окна могут отсутствовать (None), очерчиваться линиями, а окно иметь постоянный размер (Fixed Single), окно может быть масштабируемо (Sizeable) и др. Выбрать необходимое значение можно из раскрывающегося списка. Изменение этого свойства допускается только на этапе разработки приложения.

Caption - название формы, размещаемое в строке заголовка. Это свойство содержит текст, выводимый в строку заголовка окна формы.

Enabled - доступ. Любой объект по умолчанию обладает свойством Enabled (активизирован, доступен), т.е. установлено значение True. Если установлено значение False – объект неактивен (блокируется воздействие на объект (форму) любых событий, связанных с мышью или клавиатурой).

FontName - название шрифта, используемого в объектах формы. Смена шрифта действует лишь на новый объект, размещенный на форме, не влияет на уже имеющиеся объекты.

FontSize - размер шрифта. Измеряется в пунктах. Пункт – стандартная единица измерения, равная 0,035 см.

ForeColor - основной цвет. Это цвет текста или графических изображений. Устанавливается с помощью палитры цветов аналогично свойству BackColor.

Height, Width - размер формы - высота и ширина. Определяется в twips. 1 twip=0.0018 см.

Icon (значок). Значок, в который превращается свернутая форма.

Name - имя. Свойство задает имя формы в программном коде, изменять которое в период выполнения программы нельзя.

Picture - картинка. Это свойство позволяет отобразить на окне формы растровую картинку (bitmap picture). Для изменения свойства в период выполнения программы используется функция LoadPicture.

Top, Left - верхняя и левая координаты окна. Свойства определяют позиционирование формы на экране. Координаты измеряются в twips.

WindowState -состояние окна. Свойство определяет, в каком виде окно отображается на экране: нормальном (Normal), свернутом в значок (Minimized) или развернутом (Minimized).

Окна рисунков и изображений (PictureBox)

Эти объекты обладают свойствами Enabled, Height, Width, Top, Left, Name, Picture, поведение которых аналогично поведению свойств формы. Однако, координаты объекта в случае свойств Height, Width, Top, Left, относительны, а не абсолютны, т. е. они измеряются как смещение от начала координат формы, а не экрана (это касается всех элементов, расположенных на форме). Свойство Picture позволяет выводить на экран либо растровую картинку (bitmap), либо значок (icon).

Stretch - подгонка. Это свойство имеют окна изображений. По умолчанию оно False, что означает, что элемент управления (окно) подгоняется под размеры загружаемого в него изображения. Значение True означает, что изображение подгоняется под элемент управления.

Метки (Label)

Alignment - выравнивание. Способ выравнивания текста на метке: по левой границе, по правой и по центру.

AutoSize - подгонка размера. True – размер метки автоматически подгоняется под размер текста. False – метка сохраняет заданный размер, а лишние символы отсекаются.

BorderStyle - тип границ. Метка может либо иметь контур, либо нет.

Caption - название. Свойство содержит текст, отображаемый в поле метки.

Текстовые окна (TextBox)

MaxLenth - максимальная длина. По умолчанию значение равно нулю, что означает, что в текстовое окно можно вводить любое количество символов. Если значение свойства не равно нулю, то Visual Basic ограничивает количество символов заданной величиной.

MultiLine - количество строк. Значение True разрешает ввод нескольких строк текста, нажимая Enter. False запрещает ввод более одной строки текста.

Text - текст, размещенный в текстовом окне до ввода другого текста. С помощью этого свойства программа распознает, какой именно текст введен пользователем.

Текстовое окно не реагирует на события, связанные с мышью, но позволяет отслеживать нажатие любой клавиши.

Командные кнопки, флажки, переключатели (CommandButton, CheckBox, OptionButton)

Cancel - отмена. Это свойство связано только с командными кнопками. True – щелчок кнопки эквивалентен нажатию клавиши Escape. Значение True у свойства может иметь только одна командная кнопка на форме.

Default - по умолчанию. Поддерживается лишь командными кнопками. True – щелчок кнопки эквивалентен нажатию клавиши Enter. Значение True у свойства может иметь только одна командная кнопка на форме.

Value - состояние. Значение этого свойства отражает состояние флажка или переключателя. Для переключателя: True – переключатель активен (в центре кружочка жирная точка); False – переключатель неактивен (точка отсутствует). Для флажка: 0 – флажок не помечен, 1 – флажок установлен (в центре крестик), 2 – флажок затенен (имеет блеклый вид).


Для запуска программы из главного меню Windows выполните следующие действия

Создание формы приложения и сохранение проекта

конец

вопросы

задания

Напишем программу вычисления площади сектора при известных: наружном диаметре D1, внутреннем диаметре D2 и центральном угле A.

Площадь кольца можно вычислить по формуле:

S = 3,14*(D1/2-D2/2)^2*A/360

Пример формы рабочего окна программы

На форме размещены:

- три текстовых поля (TextBox) для ввода исходных данных;

- графическое поле (PictureBox) для вывода результатов вычислений (значения площади сектора);

- метки (Label) для поясняющих надписей рядом с полями для ввода-вывода данных;

- метки (Label) для вывода текста и значения процента площади сектора от площади кольца (вывод данных на метку);

- фреймы (Frame) для для функционального объединения однотипных элементов в группы;

- кнопка (CommandButton) для запуска программы вычислений.

При создании формы изменены свойства объектов - их цвет и шрифт.

Может быть спроектирован и другой интерфейс программы с использованием различных вариантов оформления формы и организации ввода-вывода данных.

Текст программы нахождения площади сектора.

ЗАДАНИЕ 5.
Создайте проект и напишите программу вычисления площади сектора Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Используйте различные варианты организации ввода-вывода данных. Для вывода результатов используйте форматный вывод.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Разветвляющиеся и циклические алгоритмы

конец

вопросы

задания

Цель работы

Целью работы является изучение возможностей разработки приложений с разветвляющимися и циклическими алгоритмическими структурами

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • Изучить правила использования операторов условного перехода и операторов циклов.

  • Изучить возможности разработки приложений с разветвляющимися и циклическими алгоритмическими структурами и контроля за их выполнением с использованием объектов Visual Basic: ключ, переключатель, ползунок, индикатор процесса выполнения программы.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение операторов условного перехода.

  • Задание 2 - разработка приложения с разветвляющимися алгоритмическими конструкциями.

  • Задание 3 - изучение операторов организации циклов.

  • Задание 4 - разработка приложения с циклическими структурами.

  • Задание 5 - изучение возможностей использования ключей, переключателей, ползунков.

  • Задание 6 - изучение возможностей использования ползунка и индикатора процесса.

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он должен содержать:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Заключение и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены возможностей разработки приложений с разветвляющимися и циклическими алгоритмическими структурами, реализованными как с использованием операторов условного перехода и организации циклов языка Visual Basic, так и с использованием объектов Visual Basic: ключ, переключатель, ползунок, индикатор процесса выполнения программы.

Были рассмотрены темы:

  • Задание 1 - изучение операторов условного перехода.

  • Задание 2 - разработка приложения с разветвляющимися алгоритмическими конструкциями .

  • Задание 3 - изучение операторов организации циклов.

  • Задание 4 - разработка приложения с циклическими структурами.

  • Задание 5 - изучение возможностей использования ключей, переключателей, ползунков.

  • Задание 6 - изучение возможностей использования ползунка и индикатора процесса.

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Вопросы к лабораторной работе

конец

вопросы

задания

  1. Какие операторы используются для организации условного перехода?

  2. Какие логические отношения могут использоваться в операторах условного перехода?

  3. Что такое логическое выражение?

  4. Какие логические операции могут использоваться в логических выражениях?

  5. В каких случаях используется Конструкция Select Case?

  6. Какой оператор используется для организации цикла при известном числе повторений?

  7. Какие операторы используются для организации циклов при известном заранее числе повторений?

  8. Каким образом организовать выход из цикла до исчерпания значений его параметра?

  9. Для чего используется объект Ключ?

  10. Для чего используется объект Переключатель?

  11. Для чего используется элемент управления (объект) Ползунок?

  12. В каких случаях используется Индикатор процесса?

начало

назад

вперед

конец

вопросы


Задания к лабораторной работе

Все задания к лабораторной работе

конец

вопросы

задания

ЗАДАНИЕ 1.
Создайте проект и напишите программу вычисления корней квадратного уравнения a*x^2+b*x+c=0. Предусмотрите условный переход и вывод результата решения уравнения для равных корней (x1=x2 при D=0). Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Для вывода результатов используйте форматный вывод. Сохраните проект на диске.
Создайте вариант проекта с использованием конструкции Select Case.
Сохраните проект на диске.
ЗАДАНИЕ 2.
Создайте проект "Поиск простых чисел" и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их. Используйте для организации циклов конструкцию Do...Loop.
Сохраните проект на диске.
ЗАДАНИЕ 3.
Создайте проект, позволяющий вычислять одну из величин: длину окружности (2*3,1415*R), площадь круга ( 3,1415*R*R), площадь или периметр квадрата по заданному значению R. (R- радиус окружности, вписанной в квадрат)
Для выбора вычисляемой величины используйте Переключатель.
При выводе результатов используйте форматный или бесформатный вывод в зависимости от выбранного значения ключа.
При создании проекта используйте различные варианты ввода-вывода данных (см. лабораторную работу №2).
Сохраните проект на диске.
ЗАДАНИЕ 4.
Используя ранее созданный проект "Поиск простых чисел" (с циклами Do...Loop) исправьте форму (сохранив старый проект на дискете) и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Программирование условий в V isual Basic

конец

вопросы

задания

Операторы в программе выполняются в той последовательности, в которой они записаны. Однако достаточно часто требуется изменить порядок выполнения операторов в зависимости от выполнения (или невыполнения) определенного условия. В Visual Basic, как и во всех языках программирования, существуют управляющие конструкции, предназначенные для управления порядком выполнения команд.

Различают три типа управляющих операторов, позволяющих программировать разветвляющиеся алгоритмы:

1. If ... Then ...

2. If ... Then ... Else ...

3. Select Case ...

Основанием для принятия решений в управляющих конструкциях являются логические ( условные) выражения.

В операторах If ...Then ... и If ...Then ... Else ... условие и выполняемые при соблюдении условий действия располагаются в одной строке.

В том случае, если при выполнении условия требуется выполнение блока операторов, используются многострочные операторы, имеющие следующий синтаксис:

IF логическое выражение Then

операторы

End If

Конструкция If ... Then ... применяется, когда необходимо выполнить определенные действия в зависимости от некоторого условия.

IF условие Then

Конструкции для обработки истинного условия

Конструкция If ... Then ... Else ... используется в том случае, когда необходимо выполнить разные действия в зависимости от условия.

IF условие Then .

Конструкции для обработки истинного условия

Else

Конструкции для обработки ложного условия

End If

Ключевое слово End if обозначает конец многострочной конструкции и его наличие в операторе в этом случае обязательно.

Конструкция Select Case позволяет обрабатывать в программе несколько условий. Эта конструкция состоит из анализируемого выражения и набора операторов CASE на каждое возможное значение выражения.

Select Case Селектор

СASE значение 1

конструкция 1

CASE значение 2

конструкция 2

. . .

End Select

Работает эта конструкция следующим образом. Сначала Visual Basic вычисляет значение заданного в конструкции выражения - Селектора. Затем полученное значение сравнивается со значениями, задаваемыми в операторах CASE конструкции. Если найдено искомое значение, выполняются команды, приписанные данному оператору CASE. После завершения выполнения конструкций управление будет передано конструкции, следующей за ключевым словом End Select.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Логические выражения

Логические выражения — это такие выражения, которые возвращают одно из двух значений: True (Истина) или False (Ложь). Логические выражения содержат логические отношения (операции сравнения): = (равно), > (больше), < (меньше), <> (не равно), >= (больше или равно), <= (меньше или равно)

Логические отношения могут быть связаны логическими операциями:

AND (И) реализует конъюнкцию логических значений — возвращает значение True (Истина), если все участвующие в операции выражения имеют значение True. В остальных случаях возвращается значение False (Ложь);

OR (ИЛИ) реализует дизъюнкцию логических значений — возвращает значение True, если хотя бы одно из участвующих в операции выражений имеет значение True. В случае, когда все выражения имеют значение False, возвращается значение False;

XOR (Исключающее ИЛИ) — возвращает значение True (Истина), если только одно из участвующих в операции выражений имеет значение True. В остальных случаях возвращается значение False;

NOT (HE) реализует инверсию логических значений — операция отрицания. Возвращает обратное для значения выражения значение, то есть если выражение равно True, то возвращается False и наоборот, если значение выражения равно False, то возвращается значение True.


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложения, реализующего алгоритм с разветвлением

конец

вопросы

задания

Напишем программу для решения квадратных уравнений a*x^2 + b*x + c = 0

Чтобы решить такое уравнение, нужно найти дискриминант и затем, корни.

Дискриминант ищется по формуле:

D = b*b - 4*a*c

А корни:

Если дискриминант > 0, то

X1 = (b + (корень из D)) / 2*a
X2 = (b - (корень из D)) / 2*a

Если дискриминант = 0, то

X1 = X2 = b / 2*a

Если дискриминант < 0, то корней не существует.

Пример реализации интерфейса приложения (окна формы проекта) для решения квадратного уравнения

На форме размещены:

- текстовые окна (TextBox), предназначенные для ввода исходных данных;

- метки (Label) для подписи текстовых окон;

- графическое окно (PictureBox) для вывода результатов решения уравнения;

- фрейм для визуального объединения компонентов формы;

- кнопки для выполнения действий приложения.

Может быть спроектирован и другой интерфейс программы с использованием различных вариантов организации ввода-вывода данных.

Текст программы решения квадратного уравнения. В нем для нахождения не равных друг другу и равных друг другу корней используются одни и те же формулы, то есть не проверяется условие равенства нулю дискриминанта.

ЗАДАНИЕ 1.
Создайте проект и напишите программу вычисления корней квадратного уравнения a*x^2+b*x+c=0. Предусмотрите условный переход и вывод результата решения уравнения для равных корней (x1=x2 при D=0). Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Для вывода результатов используйте форматный вывод. Сохраните проект на диске.

Создайте вариант проекта с использованием конструкции Select Case. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Программирование циклов в V isual Basic

конец

вопросы

задания

В программах Visual Basic для выполнения повторяющихся действий используются циклы. Они бывают трех типов:

1. For ... Next

2. For Each ... Next

3. Do ... Loop

Конструкция For...Next выполняет последовательность команд определенное число раз. Такую конструкцию называют циклом, а выполняемые ею программные коды — телом цикла.

For Счетчик = НачальноеЗначение То КонечноеЗначение [Step Шаг]

конструкции

Next [счетчик]

Первый аргумент конструкции — Счетчик — определяет имя переменной, которая будет "считать" количество выполнений цикла. Параметр НачальноеЗначение указывает числовое значение, которое присваивается переменной-счетчику при первом проходе цикла. Цикл выполняется до тех пор, пока значение счетчика не превысит КонечноеЗначение, указанное после ключевого слова To. После каждого прохода цикла значение счетчика изменяется на величину Шаг, указанную за ключевым словом Step. Ключевое слово Next обозначает конец тела цикла и является обязательным.

Конструкция For Each ... Next используется для обработки всех элементов некоторого набора объектов, например массива. Ее удобно использовать в том случае, когда количество обрабатываемых элементов не известно.

For Each Элемент In группа

конструкции

Next элемент

При использовании конструкции For Each ... Next необходимо иметь в виду, что для набора объектов параметр Элемент может быть только переменной типа Variant, общей переменной типа Object или объектом, перечисленным в Object Browser. Для массивов параметр Элемент может быть только переменной типа Variant.

Конструкция Do...Loop с ключевым словом While выполняется до тех пор, пока задаваемое в цикле условие истинно.

Do While Условие

Конструкции

Loop

и

Do

Конструкции

Loop While Условие

Аргумент конструкции Условие является логическим выражением, значение которого проверяется перед каждым проходом цикла. Если это значение равно True, то выполняется последовательность команд, которые расположены между Do while и ключевым словом Loop. Эти конструкции образуют тело цикла. Если при очередном проходе цикла условие равно False, то происходит выход из цикла и управление передается конструкции, следующей за Loop.

Конструкция Do ... Loop с ключевым словом Until выполняется до тех пор, пока задаваемое в цикле условие ложно.

Do Until Условие

Конструкции

Loop

и

Do

Конструкции

Loop Until Условие

В циклах может быть использован оператор Exit. В некоторых случаях необходимо прервать выполнение цикла до его завершения. Это можно сделать с помощью команды безусловного перехода Exit. Команда Exit завершает выполнение цикла и передает управление следующей за циклом конструкции.

Синтаксис этого оператора внутри цикла For выглядит так: Exit For. Внутри цикла Do синтаксис оператора Exit Do.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложения, реализующего алгоритм с циклом

конец

вопросы

задания

Программа на использование циклов.

Определить, сколько среди целых чисел от M до N простых чисел и вывести их?. Простым считается число делящееся без остатка на единицу и на само себя.

Пример реализации интерфейса приложения (окна формы проекта) для решения задачи нахождения простых чисел.

Текст программы.

Для нахождения простых чисел используются вложенные друг в друга циклы с параметрами. Переменная k используется для определения количества простых чисел.

Переменная p (остаток от деления k на 19) позволяет организовать перенос выводимых чисел на следующую строку графического окна (PictureBox).

Приведенный текст программы с полным перебором не является оптимальным для решения данной задачи и служит только примером использования циклов в Visual Basic.

ЗАДАНИЕ 2.
Создайте проект "Поиск простых чисел" и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их. Используйте для организации циклов конструкцию Do...Loop. Остальные элементы программы и ее интерфейс возьмите из приведенного выше примера.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Использование объектов: ключ, переключатель, ползунок

конец

вопросы

задания

Ключ (флажок)

Ключ (CheckBox) позволяет сделать активной какую либо опцию приложения.

На рисунке показан фрагмент формы с двумя расположенными на ней ключами.

Переключатель (поля выбора или «радиокнопки»)

Переключатель (OptionButton) позволяет выбрать одну из возможных опций, представленных в форме в виде списка.

На рисунке показан фрагмент формы с двумя расположенными на ней переключателями.

Пример проекта (приложения), реализованного с использованием ключей и переключателей, позволяющего выполнять одно из выбранных арифметических действий над двумя заданными числами.

Текст программы на Visual Basic:

Private Sub Command1_Click()
If Check2.Value Then Picture1.Cls
If Option1.Value Then x = Val(Text1) + Val(Text2)
If Option2.Value Then x = Val(Text1) - Val(Text2)
If Option3.Value Then x = Val(Text1) * Val(Text2)
If Option4.Value Then x = Val(Text1) / Val(Text2)
If Check1.Value Then Picture1.Print Round(x) Else Picture1.Print x
End Sub

ЗАДАНИЕ 3.
Создайте проект, позволяющий вычислять одну из величин: длину окружности (2*3,1415*R), площадь круга ( 3,1415*R*R), площадь или периметр квадрата по заданному значению R (смотри рисунок)

Для выбора вычисляемой величины используйте Переключатель.

При выводе результатов используйте форматный или бесформатный вывод в зависимости от выбранного значения ключа.

При создании проекта используйте различные варианты ввода-вывода данных (см. лабораторную работу №2).

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Использование объектов: ползунок и индикатор процесса

конец

вопросы

задания

Ползунок (Slider)

Элемент управления Ползунок позволяет вводить в программу числовые значения путем перемещения указателя ползунка.

Индикатор процесса (ProgressBar) выполнения программы

Некоторые операции приложения могут выполняться довольно долго, например, обработка большого массива данных или сложная выборка из базы данных, содержащей огромное количество записей. В этой ситуации пользователь начинает беспокоиться, не зависла ли программа.

Работа продолжительных задач может сопровождаться отображением на экране индикатора процесса выполнения.

Пример программы с использованием ползунка и индикатора процесса.

Определить, сколько среди целых чисел от M до N простых чисел и вывести их?.

Пример реализации интерфейса приложения (окна формы проекта) для решения задачи нахождения простых чисел. Значения переменных M и N вводятся с помощью ползунков. Для индикации процесса поиска простых чисел использован индикатор процесса.

Текст программы.

ЗАДАНИЕ 4.
Используя ранее созданный проект "Поиск простых чисел" (с циклами Do...Loop) исправьте форму (сохранив старый проект на дискете) и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Работа с массивами

конец

вопросы

задания

Цель работы

Целью работы является изучение возможностей разработки приложений с использованием одномерных и двумерных массивов.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • Изучить правила работы с одномерными и двумерными массивами - описание, ввод-вывод элементов массива, операции с элементами массива.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение правил описания и ввода вывода элементов массива .

  • Задание 2 - разработка приложения с использованием одномерного массива.

  • Задание 3 - разработка приложения с использованием двумерного массива.

  • Задание 4 - разработка приложения с выводом элементов двумерного массива в таблицу.

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он должен содержать:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Заключение и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены возможностей разработки приложений с использованием одномерных и двумерных массивов.

Были рассмотрены темы:

  • Задание 1 - изучение правил описания и ввода вывода элементов массива .

  • Задание 2 - разработка приложения с использованием одномерного массива.

  • Задание 3 - разработка приложения с использованием двумерного массива.

  • Задание 4 - разработка приложения с выводом элементов двумерного массива в таблицу.

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Вопросы к лабораторной работе

конец

вопросы

задания

  1. Что такое массив?

  2. Что называется размером массива?

  3. Могут ли элементы одного и того же массива иметь разный тип?

  4. Как выполняется обращение к элементам массива?

  5. Что понимается под диапазоном значений индекса массива?

  6. Как задается размерность массива при его описании?

  7. Какое значение принимает нижняя граница диапазона значений индекса по умолчанию?

  8. Чем ограничена верхняя граница диапазона значений индекса?

  9. Как можно организовать ввод элементов одномерного массива?

  10. Как можно организовать ввод элементов двумерного массива?

  11. Как можно организовать вывод элементов одномерного массива?

  12. Как можно организовать вывод элементов двумерного массива?

  13. Для чего при работе с массивами используется функция Split?

  14. Как организовать вывод элементов двумерного массива в таблицу?

начало

назад

вперед

конец

вопросы


Задания к лабораторной работе

Все задания к лабораторной работе

конец

вопросы

задания

ЗАДАНИЕ 1.
Решите задачи на работу с одномерными массивами (см. варианты заданий) с использованием ввода элементов из текстового поля. Для вывода результатов расчета используйте графические окна и форматный вывод.
Сохраните проект на диске.
ЗАДАНИЕ 2.
Решите задачи на работу с двумерными массивами (см. варианты заданий) с использованием ввода элементов массива из модального диалогового окна по запросу приложения. Для вывода результатов расчета используйте графические окна.
Сохраните проект на диске.

ЗАДАНИЕ 3.
Решите задачи на работу с с двумерными массивами (см. варианты заданий) с использованием вывода элементов массива в таблицу.

Сохраните проект на диске.

Варианты индивидуальных заданий к лабораторной работе

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Вариатны индивидуальных заданий на массивы

1. Сколько положительных элементов содержит матрица размера 10х10, если a [i,j]=sin(i+j/2).

2. Определить сумму отрицательных элементов матрицы размера 20х10, если a [i,j]=cos(i-5*j).

3. В матрице размера 3х5 найти среднее арифметическое каждого из столбцов.

4. В матрице размера 4х3 найти значение максимального элемента в каждой строке.

5. В матрице размера 4х3 найти разность между суммой и произведением элементом.

6. Найти сумму и количество положительных элементов матрицы размера 4х4.

7. Найти место расположения максимального по модулю элемента матрицы размера 5х3 указав номер строки и столбца.

8. Найти разность между максимальным элементом матрицы размера 4х4 и суммой ее положительных элементов.

9. Определить сумму и произведение элементов матрицы размера 4х5, имеющих оба четных индекса.

10.Найти сумму элементов матрицы размера 4х4 в четных строках и произведение элементов в нечетных строках.

11.Найти среднее арифметическое наибольшего и наименьшего значений элементов матрицы размера 4х3.

12.В матрице размера 5х4 найти сумму наибольших значений элементов ее строк.

13.В матрице размера 6х3 найти номера строк, все элементы которых положительны.

14.В матрице размера 4х4 найти номера (i,j) и определить сумму отрицательных элементов.

15.Преобразовать матрицу размера 4х4 по правилу: вторую строку сделать четвертым столбцом, а четвертый столбец - второй строкой.

16.В матрице размера 4х4 найти сумму элементов над главной диагональю.

17.В матрице размера 4х4 найти максимальный по модулю элемент на побочной диагонали.

18.Преобразовать матрицу размера 4х4, поменяв местами в каждой строке элементы главной и побочной диагонали.

19.Определить является ли целочисленная матрица размером 4х4 симметричной относительно главной диагонали.

20.Сделать целочисленную матрицу размером 4х4 симметричной относительно главной диагонали, заменяя при отсутствии симметрии меньший элемент на больший.

21.В целочисленной матрице размера 4х5 все элементы с наибольшим значением заменить суммой положительных элементов.

22.В целочисленной матрице размера 4х5 определить количество наибольших по модулю элементов и их номера.

23.В матрице размером 5х3 поменять местами строку с наибольшим элементом и строку с наименьшим элементом.

24.В матрице размера 4х3, все элементы которые различны, найти произведение элементов строки, содержащие наибольший по модулю элемент матрицы.

25.Если в матрице размера 4х4 произведение элементов побочной диагонали отрицательно, то все элементы на главной диагонали заменить на 0, если положительно - на 1.

26.В символьной матрице размера 5х5 заменить все буквы W на букву Q, если количество букв W больше 3.

27.В символьной матрице размера 4х4 определить количество цифр и если оно больше 2, то все цифры заменить на &.

28.В символьной матрице размера 5х5 определить количество цифр и все цифры заменить латинскими буквами по правилу: 1-А; 2-В; 3-С... О-J (не используя 10 раз подряд оператор IF).

29.Определить, сколько прописных букв латинского алфавита содержит символьная матрица 4х5.

30.Определить сумму и произведение цифр, расположенных на главной диагонали символьной матрицы размера 5х5.


Для запуска программы из главного меню Windows выполните следующие действия

Программирование условий в V isual Basic

конец

вопросы

задания

Массивы

Для хранения величин кроме простых переменных можно использовать массивы. Массив представляет собой набор переменных с одним именем и разными индексами. Каждая такая переменная называется элементом массива. Количество хранящихся в массиве элементов называется размером массива. Размер массива ограничен объемом оперативной памяти и типом данных элементов массива.

Все элементы массива имеют одинаковый тип. Однако если массив имеет тип variant, то отдельные элементы могут содержать данные разных типов. Например, одни элементы могут быть числами, другие — строками или объектами.

Обращение к элементам массива выполняется по индексу. Индекс элемента указывается в круглых скобках после имени массива.

Например,

strNames(l), strNames(2), strNames(l0) - являются элементами массива с именем strNames.

Элементы массива можно использовать точно так же, как и простую переменную.

В зависимости от области видимости, которую должен иметь массив, для его объявления используются операторы: Public, Private, Dim и Static.

Диапазон значений индекса массива имеет верхнюю и нижнюю границу значений. При объявлении массива после его имени в скобках задается верхняя граница диапазона значений индекса. Эта граница не может превышать диапазона, представляемого типом Long. По умолчанию, нижней границей диапазона значений индекса является 0, но нижнюю границу можно и указать явно.

Рассмотрим примеры объявления массивов:

Dim Sum(50) As Integer

Public Name(17) As String

Private Ln(11 to 31) As Double

Массивы могут быть многомерными:

Dim XYCol(100,100,16) As Integer

Public Tempr(15 to 30, 1 to 24) As Integer

Дополнительно: описание переменных, констант и типов данных.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Переменные, константы и типы данных

Переменные

Переменная представляет собой зарезервированное место в оперативной памяти для временного хранения данных. Каждая переменная имеет собственное имя. После того как переменной присвоено значение, ее можно использовать в программе вместо самого значения.

Имена переменных

Для того чтобы сделать переменные более наглядными и простыми для чтения, рекомендуется давать им имена, имеющие определенное смысловое значение. Существует несколько правил задания имен переменных;

- имя переменной может содержать не более 255 символов;

- имя переменной может содержать любые буквы и цифры;

- первый символ в имени переменной должен быть буквой;

- в имени переменной должны отсутствовать пробелы;

- имя должно быть уникальным в пределах области видимости.

Список ограничений достаточно велик, но ошибки будут выявлены при проверке синтаксиса программы.

Например, допустимы следующие имена переменных:

CurrentNum, Total, Date_of_birth

Следующие имена недопустимы:

1Time, $Total, Date of birth

Типы данных

В Visual Basic вы можете применять следующие типы данных:

- числовой:

-    integer - 2 байта: целые числа от —32768 до 32767,

-    Long - 4 байта: целые числа от —2 147483648 до 2 147483648,

-    Single - 4 байта: десятичные числа с плавающей точкой:
отрицательные -3,4^38 ... -1,4^-45, положительные: 1,4^-45 .. 3,4^38,

-    Double - 8 байт: десятичные числа с плавающей точкой:
отрицательные -1,7^-308 ... -4,9^-324,
положительные 4,9^-324 ... l,7^+308,

-    Currency - 8 байт десятичные числа с фиксированной точкой,
целая часть числа может содержать до 15 цифр, а дробная — до 4.

- строковый (String) - строки как фиксированной (до 216 символов), так и переменной длины (до 231 символов). При использовании ASCCII кодировки для каждого символа строки выделяется один байт, а при использовании кодировки Unicode — два байта. Кроме этого выделяется 10 байт для строки в целом.

- типа дата (Date) –для хранения даты и времени. Переменная этого типа требует 8 байт в оперативной памяти;

- байтовый (Byte) - 1 байт: для хранения двоичных;

- логический (Boolean) - для хранения данных, принимающих одно из двух значений: True (Истина) или False (Ложь). По умолчанию переменной данного типа присваивается значение False;

- произвольный (variant) – универсальный тип данных. Переменная этого типа может хранить любой из выше описанных типов данных.;

- объектный (object) - для хранения ссылок на объекты используется тип данных object. Каждая переменная данного типа требует 4 байта.

В наименованиях переменных рекомендуется использовать префиксы, отражающие тип переменной и область ее действия. При таком обозначении переменных повышается читабельность программы и снижается количество ошибок программирования.

Тип данных | Префикс | Пример
Boolean | bin | binSuccess
Byte | byt | bytImage
Currency | cur | curPrice
Date | dtm | dtmFinish
Double | dbl | dblSum
Integer | int | intQuantity
Long | Ing | IngTotal
Single | sng | sngLength
String | str | strLastname
Variant | vnt | vntValue

Объявление переменной

В Visual Basic используется явное и неявное объявление переменной. Явное объявление осуществляется операторами Dim, private, Static, public, которые имеют следующий синтаксис:

Dim имяПеременной [As типДанных]

Private имяПеременной [As типДанных]

Static имяПеременной [As типДанных]

Public имяПеременной [As типДанных]

Операторы Dim, Private, static, public определяют область действия переменной.

Dim - уровень отдельной процедуры или модуля;

Private - уровень модуля;

Public - уровень всех модулей приложения.

Переменные уровня процедуры доступны только в процедуре, в которой они были объявлены. Такие переменные называются локальными. Переменные, объявленные с помощью зарезервированного слова Dim существуют только во время выполнения процедуры. Если их объявить с помощью зарезервированного слова Static (статические переменные), то они будут существовать в течение всего времени выполнения приложения. Этим определяется жизненный цикл переменной. Чтобы объявить все локальные переменные в процедуре статическими, можно поместить зарезервированное слово Static перед заголовком процедуры. С помощью одного оператора вы можете объявлять несколько переменных, разделяя их запятыми.

Примеры объявления переменных:

Private bInSuccess As Boolean

Dim strLastname As String, dblSum As Double

Предпочтительнее использовать явное объявление переменных. в случае неявного объявления переменной ее тип определяется при первом операторе присвоения, и в этот же момент переменной будет выделена память. Если вы не используете специальные концевые символы, определяющие тип переменной, ей будет присвоен тип variant.

Присваивая имена переменным с учетом области ее действия, придерживайтесь следующего формата:

Область действия переменной | Префикс | Пример
Глобальная | g | gdtmFinish
Локальная внутри модуля | m | msngLength
Локальная внутри процедуры | нет префикса | strLastname

Для создания глобальной переменной, в раздел General Declarations главного модуля приложения помещают оператор public.

Например:

Public gdtmFinish As Date

Для объявления переменной, локальной внутри модуля или формы, используют оператор private или Dim в разделе General Declarations модуля или формы. В этом случае объявленная переменная будет доступна для всех входящих в форму или модуль процедур, но в то же время недоступной в процедурах других модулей и форм.

Переменные, локальные на уровне процедуры, создаются операторами Dim или static внутри процедуры.

Например:

Sub CalcTotal

Dim bSuccess As Boolean

. . .

End Sub


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложения с одномерными массивами

конец

вопросы

задания

Пример реализации формы приложения. В текстовом поле (TextBox), рядом с которым расположена метка (Label) задается количество элементов массива. Ввод элементов массива - из текстового поля (TextBox) . В качестве разделителя значений элементов массива используется пробел. Результаты расчета выводятся графическое поле (PictureBox).

Текст программы.

ЗАДАНИЕ 1.
Решите задачи на работу с одномерными массивами (см. варианты заданий) с использованием ввода элементов из текстового поля. Для вывода результатов расчета используйте графические окна и форматный вывод.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложения с двумерными массивами

конец

вопросы

задания

Пример реализации формы приложения. Ввод элементов массива - построчный из модального диалогового окна по запросу приложения с помощью функции InputBox. Вывод элементов двумерного массива в графическое поле (PictureBox).

Текст программы.

ЗАДАНИЕ 2.
Решите задачи на работу с двумерными массивами в соответствии с индивидуальным заданием (см. раздел "Задания") с использованием ввода элементов массива из модального диалогового окна по запросу приложения. Для вывода результатов расчета используйте графические окна.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Вывод элементов двумерного массива в таблицу

конец

вопросы

задания

Пример реализации формы приложения с выводом элементов двумерного массива в таблицу.

Ниже приведен текст программы.

Для вывода результатов использована таблица - объект MSFlexGrid1. В процедуре Private Sub Command2_Click() создается таблица, размерностью n+1 строк и m+1 столбцов. Дополнительная строка и столбец в таблице нужны для простановки номеров (на форме эти элементы таблицы имеют серый фон).

В программе задается ширина ячеек таблицы (), т.е. определяются значения параметров ColWidth. Они различны для первой (ширина равна 300) и последующих (ширина равна 700) колонок.

Для вывода значений элементов массива использован форматный вывод данных.

ЗАДАНИЕ 3.
Решите задачи на работу с с двумерными массивами в соответствии с индивидуальным заданием (см. раздел "Задания") с использованием вывода элементов массива в таблицу.

начало

назад

вперед

конец

вопросы


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Работа с файловой системой

конец

вопросы

задания

Цель работы

Целью работы является изучение возможностей разработки приложений, взаимодействующих с файловой системой персонального компьютера и работы со строками.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • Изучить правила работы с файлами (ввод-вывод данных) и строками

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение операторов по работе с файлами.

  • Задание 2 - разработка приложения, читающего текст из файла.

  • Задание 3 - разработка приложения, осуществляющего ввод исходных данных из файла.

  • Задание 4 - разработка приложения с визуальным поиском файла и работа со строками.

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он должен содержать:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Заключение и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены возможностей разработки приложений, взаимодействующих с файловой системой персонального компьютера - ввод-вывод данных с использованием файлов.

Были рассмотрены темы:

  • Задание 1 - изучение операторов по работе с файлами.

  • Задание 2 - разработка приложения, читающего текст из файла.

  • Задание 3 - разработка приложения, осуществляющего ввод исходных данных из файла.

  • Задание 4 - разработка приложения с визуальным поиском файла и работа со троками .

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Вопросы к лабораторной работе

конец

вопросы

задания

  1. Какие основные операции операции с файлами есть в Visual Basic?

  2. Как открыть или создать файл?

  3. Как закрыть файл?

  4. Как закрыть все открытые файлы?

  5. Как прочитать данные из файла?

  6. Как записать данные в файл?

  7. Как задать имя файла, находящегося в некоторой папке на жестком диске?

  8. Как добавить данные в файл?

  9. Как определить метку конца файла?

  10. Что должно присутствовать в текстовом файле, чтобы запятые не воспринимались как признак перехода на новую строку?

  11. Какой объект можно использовать для вывода текста, прочитанного из текстового файла?

  12. Какой символ является разделителем при вводе числовых данных из файла?

  13. Какой объект используется для визуального выбора диска?

  14. Какой объект используется для визуального выбора папки?

  15. Какой объект используется для визуального выбора файла?

начало

назад

вперед

конец

вопросы


Задания к лабораторной работе

Все задания к лабораторной работе

конец

вопросы

задания

ЗАДАНИЕ 1.
Создайте проект "Чтение текста из файла" и напишите программу, позволяющую выводить прочитанный из файла текст в графическое поле. Обеспечьте возможность многократного чтения и вывода в графическое поле текстов из разных файлов, для чего предусмотрите очистку графического поля перед очередным выводом текста.
Сохраните проект на диске.
ЗАДАНИЕ 2.
Создайте проект и напишите программу на массивы и файлы в соответствии с индивидуальным заданием
Сохраните проект на диске.
ЗАДАНИЕ 3.
Создайте проект и напишите программу на текстовые файлы и строки в соответствии с индивидуальным заданием
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Задание 2: Вариатны индивидуальных заданий на массивы и файлы

назад

Исходные данные ввести из файла:

  1. В матрице размера 6х4 найти произведение наибольших значений элементов ее столбцов.

  2. В матрице размера 5х4 найти номера столбцов, все элементы которых отрицательны.

  3. В матрице размера 4х4 найти номера (i,j) и определить произведение положительных элементов.

  4. В матрице размера 5х5 найти максимальный элемент под главной диагональю.

  5. В матрице размера 5х5 поменять местами элементы второго столбца и третьей строки.

  6. В матрице размера 5х5 найти максимальный по модулю элемент под побочной диагональю.

  7. Преобразовать матрицу размера 4х4, поменяв местами в каждой строке положительные элементы главной и побочной диагонали.

  8. Определить является ли целочисленная матрица размером 4х4 симметричной относительно побочной диагонали.

  9. Сделать целочисленную матрицу размером 4х4 симметричной относительно побочной диагонали, заменяя при отсутствии симметрии меньший элемент на больший.

  10. В целочисленной матрице размера 4х5 все элементы с наибольшим значением заменить суммой положительных элементов.

  11. В целочисленной матрице размера 5х4 определить количество наименьших по модулю элементов и их номера.

  12. В матрице размером 4х6 поменять местами элементы строк с наибольшим элементом и наименьшим элементами.

  13. В матрице размера 4х5, все элементы которые различны, найти сумму элементов столбца, содержащего наибольший по модулю элемент матрицы.

  14. В матрице размером 4х6 вставить после столбцов, содержащих максимальный элемент массива столбец из единиц.

  15. В матрице размером 4x5 вставить между средними строками первую строку.

  16. В матрице размером 4x5 удалить столбцы, в которых первый элемент больше заданного.

  17. Если в матрице размера 4х4 произведение элементов главной диагонали отрицательно, то все элементы на побочной диагонали заменить на 1, если положительно - на 0.

  18. Дана матрица размером 6x4.Определить, есть ли в ней столбец, сумма элементов которого больше максимального элемента матрицы

  19. Дана матрица размером 5x6.Определить, есть ли в ней строка, в которой имеется два элемента массива, имеющих наименьшие значения.

  20. Дана матрица размером 5x6. Сформировать одномерный массив, каждый элемент которого равен сумме положительных элементов соответствующей строки.

  21. В символьной матрице размера 6х5 заменить все буквы R на букву F, если количество букв R больше 4.

  22. В символьной матрице размера 5х5 определить количество цифр и если оно больше 5, то все цифры заменить на @.

  23. В символьной матрице размера 6х4 определить количество цифр и все цифры заменить латинскими буквами по правилу: 1-А; 2-В; 3-С... О-J (не используя 10 раз подряд оператор IF).

  24. Определить, сколько строчный букв латинского алфавита содержит символьная матрица 4х5.

  25. Определить сумму и произведение цифр, расположенных на главной под побочной диагональю символьной матрицы размера 5х5.


Для запуска программы из главного меню Windows выполните следующие действия

Вариатны индивидуальных заданий на файлы и строки

Используя визуальный поиск файлов, создайте проект и напишите программу, позволяющую.

  1. Определить сколько раз в тексте встречается заданный символ.

  2. Подсчитать количество цифр в текстовом файле.

  3. Подсчитать количество знаков препинания в текстовом файле.

  4. Определить, встречается ли в текстовом файле заданная подстрока.

  5. Объединить два текстовых файла, дописав текст из второго в конец первого.

  6. Объединить два текстовых файла, дописав текст из второго в в начало первого.

  7. Заменить в текстовом файле один заданный символ на другой.

  8. Определить наибольшую цифру, которая встретилась в текстовом файле.

  9. Определить сумму цифр, встретившихся в текстовом файле

  10. Преобразовать все строчные буквы, имеющиеся в текстовом файле в прописные.

  11. Преобразовать все прописные буквы, имеющиеся в текстовом файле в строчные.

  12. Вывести текст, записанный в файле в обратном порядке

  13. Определить, сколько в текстовом файле слов.

  14. Определить длину самого длинного слова, имеющегося в файле и вывести это слово

  15. Определить длину самого короткого слова, имеющегося в файле и вывести это слово


Для запуска программы из главного меню Windows выполните следующие действия

Работа с файлами

конец

вопросы

задания

Visual Basic позволяет открывать текстовый файл для чтения из него данных, создавать файл для записи в него данных, добавлять данные в уже существующий файл и изменять атрибуты файлов.

Выполняемое действие | Функции, операторы | Действия
Открыть или создать файл | Open | Открывает файл
Закрыть файл | Close Reset | Закрывает файл Закрывает все открытые файлы, записывает содержимое буферов
Определение параметров вывода данных | Format Spc Tab Width # |
Скопировать файл | FileCopy | Копирует файл
Получить информацию о файле | EOF FileAttr DateTime FileLen GetAttr Loc LOF | Определяет метку конца файла Возвращает режим доступа открытого файла Возвращает дату и время создания файла Возвращает размер файла в байтах Получает атрибуты файла Возвращает номер текущей позиции в файле Возвращает размер открытого файла в байтах
Организовать управление файлами | Dir Kill Lock Unlock Name | Возвращает содержимое текущей директории Удаляет файл Блокирует файл при работе в многопользоват. Среде Снимает блокировку с файла Задает (переименовывает) имя файла
Прочитать данные из файла | Input # Get # Line Input # | Чтение данных из файла Чтение строки из файла
Установить атрибуты файла | SetAttr | Устанавливает атрибуты файла
Найти позиции в файле | Seek | Устанавливает указатель на заданную номером позицию
Записать данные в файл | Print # Put # Write # | Записывает данные в файл

Примеры операторов работы с файлами.

Ввод данных из файла:

Open "test.dat" For Input As #1

Input #1, strS

Close #1

Запись данных в файл:

Open "test.txt" For Output As #2

Print #2, "Сумма ="; sngSum

Close #2

Добавление данных в файл:

Open "test1.txt" For Append As #3

Print #3, strSS

Close #3

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Ввод данных из файла

конец

вопросы

задания

Напишем программу, читающую текст из файла и выводящую его в графическое поле, расположенное на форме.

Текст в заданном файле должен быть заключен в двойные кавычки (" ... текст ..."), иначе запятые, встречающиеся в тексте читаться не будут, а будут восприниматься как признак перехода на новую строку.

Пример реализации интерфейса приложения (окна формы проекта) для решения задачи чтения текст из файла

Текст программы.

ЗАДАНИЕ 1.
Создайте проект "Чтение текста из файла" и напишите программу, позволяющую выводить прочитанный из файла текст в графическое поле. Обеспечьте возможность многократного чтения и вывода в графическое поле текстов из разных файлов, для чего предусмотрите очистку графического поля перед очередным выводом текста.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Ввод исходных данных из файла

конец

вопросы

задания

Создадим проект и напишем программу, позволяющую:

- сделать целочисленную матрицу размером 4х4 симметричной относительно главной диагонали, заменяя при отсутствии симметрии меньший элемент на больший и

- вычислить сумму элементов на главной диагонали.

- исходные данные для работы программы - размерность и элементы матрицы - ввести из файла.

Пример реализации интерфейса приложения

Исходные данные, хранящиеся в файле:

- первая строка - размерность матрицы (квадратная матрица 4х4)

- последующие строки - элементы матрицы (в качестве разделителя используется запятая)

Текст программы.

ЗАДАНИЕ 2.
Создайте проект и напишите программу на массивы и файлы в соответствии с индивидуальным заданием (см. раздел "Задания")
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Визуальный поиск файла

конец

вопросы

задания

Напишем программу, читающую текст из файла и выводящую его в графическое поле (PictureBox), расположенное на форме. Для визуального поиска файла на диске и его открытия (задания имени) используем объекты:

- DriveListBox
- DirListBox
- FileListBox

Текст в заданном файле должен быть заключен в двойные кавычки (" ... текст ..."), иначе запятые, встречающиеся в тексте читаться не будут, а будут восприниматься как признак перехода на новую строку.

Пример реализации интерфейса приложения (окна формы проекта) для решения задачи чтения текст из файла

Текст программы.

Дополнительно: строковые функции Visual Basic

ЗАДАНИЕ 3.
Создайте проект и напишите программу на текстовые файлы и строки в соответствии с индивидуальным заданием (см. раздел "Задания")
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Функции обработки строк

Asc преобразует символ в числовое значение.

Chr позволяет получить символ по значению его числового кода ANSI или Unicode.

Filter отбирает в выходной массив строки входного массива в соответствии с заданным образцом.

InStr служит для поиска номера символа, с которого начинается в заданной строке образец поиска.

InStrRev служит для поиска номера символа, с которого начинается в заданной строке образец поиска, поиск идет от указанной позиции справа налево.

Join служит для слияния всех элементов заданного массива в одну строку со вставкой между ними необязательного разделителя.

LCase преобразует символы строки в строчные; все буквы в нижнем регистре и небуквенные символы остаются неизмененными.

Left служит для усечения исходной строки до заданной длины.

Len вычисляет число символов в строке или размер заданной переменной.

LTrim удаляет пробелы в начале строки.

Mid используется для считывания заданного числа символов или байт подряд от заданной позиции в строке слева направо.

Partition служит для определения числовой оси, в который попадает заданное число.

Replace возвращает строку с замененным строковым фрагментом исходной строки.

Right служит для усечения справа исходной строки заданной длины.

RTrim удаляет пробелы в конце строки

Space используется для создания строки с указанным числом пробелов.

Spc используется вместе с инструкцией Print # или методом Print для установки позиции вывода для создания более красивого вида.

Split используется для расщепления строки на субстроки с использованием разделителя субстрок.

Str используется для приведения числового выражения типа Long в строку (тип String).

StrComp служит для сравнения двух строк.

StrConv служит для преобразования всех символов строки в соответствии с заданным видом преобразования.

String используется для создания строки из одинаковых символов.

StrReverse используется для построения заданной строки в обратном порядке.

Tab используется вместе с инструкцией Print # или методом Print для указания позиции вывода для создания более красивого вида.

Trim объединяет действия двух функций LTrim и RTrim, удаляя пробелы как справа, так и слева.

TypeName определяет тип данных переменной или свойства объекта

UCase преобразует символы строки в верхний регистр.

Val служит для преобразования аргумента в числовой тип данных.

Функция Asc

Asc(String)
AscB(String)
AscW(String)

Функция Asc(ASCII code) преобразует символ в числовое значение

Возвращаемое значение

В результате действия функции возвращается
Asc - код ANSI первого символа строки типа Integer
AscB - первый байт строки, вне зависимости от кодировки
AscW - Unicode-код для первого символа строки, если система поддерживает Unicode. В остальных случаях аналогична Asc

Параметры
String
Обязательный аргумент может представлять любое строковое выражение. Если строка не содержит символов, возникает ошибка выполнения
Пример
Dim retval
retval=Asc("Ananas") 'возвращается 65-код символа A
retval=Asc("a") 'возвращается 97-код символа a

Функция Chr

Chr(CharCode)
Chr$(CharCode)
ChrB(CharCode)
ChrW(CharCode)

Функция Chr(Character)позволяет получить символ по значению его числового кода ANSI или Unicode

Возвращаемое значение

Функции Chr, ChrB, ChrW возвращают значение субтипа String типа Variant, содержащее символ, соответствующий указанному коду символа ANSI или Unicode. Функции Chr$, ChrB$, ChrW$ возвращают соответственно значение типа String

Примечание

Chr и Chr$ возвращают символ по его кодировке в стандарте ANSI
ChrB и ChrB$ возвращают однобайтовую строку
ChrW возвращает символ Unicode, однако в системах, не поддерживающих Unicode, ее поведение аналогично Chr
Использование в параметре CharCode значения больше, чем 255, генерирует ошибки стадии выполнения 5: Invalid procedure call or argument или 6: Overflow

Параметры
CharCode
Обязательный аргумент является значением типа Long, определяющим символ. Обычно, функция Chr применяется при вставке в текстовые строки непечатных символов(возврат каретки, перевод строки, табулятор и т.д.). Коды 0-31 соответствуют стандартным управляющим символам ASCII. Например, Chr(10) возвращает символ перевода строки
Пример
Dim retval
retval = Chr(65)
Debug.Print retval ' возвращается A

Функция Filter

Filter(SourceArray, Match[, Inclule, [Compare]])

Новая функция, которая появилась в версии Visual Basic 6.0
Функция Filter отбирает в выходной массив строки входного массива в соответствии с заданным образцом(либо только содержащие вхождения заданного образца, либо только не содержащие)

Возвращаемое значение

Функция возвращает нулевой строковый массив, содержащий строки, отобранные из входного массива в соответствии с заданным образцом

Параметры
SourceArray
Обязательный аргумент - одномерный массив строк, в котором производится поиск
Match
Обязательный аргумент, содержащий поисковую строку-образец для отбора(фильтрации)
Include
Необязательный аргумент, содержащий булево значение(Boolean) и указывающий, включают или не включают возвращаемые в качестве ответа строки поисковую строку-образец. Если значение Include равно True, значит возвращаемые подстроки содержат поисковую строку-образец; если False, то результат не содержит поисковую строку-образец
Compare
Необязательный аргумент - число, указывающее на используемый вид сравнения:
vbUseCompareOption=-1
Используются установки, задаваемые оператором Option Compare. Используется по умолчанию
vbBinaryCompare=0
Двоичное сравнение. Сравнение строк производится по внутренним кодам символов, определяемых кодовой страницей. Буквы разных регистров считаются разными
vbTextCompare=1
Текстовое сравнение. Сравнение строк без учета регистра на основе системной национальной настройки
vbDatabaseCompare=2
Сравнение на основе установок, принятых в обрабатываемой базе данных. Применяется в MS Access

Функция InStr

InStr([Start,]String1,String2[,Compare])
InStrB([Start,]String1,String2[,Compare])

Функция InStr(In String) служит для поиска номера символа(номера байта для InStrB), с которого начинается в заданной строке образец поиска. Поиск идет от указанной позиции слева направо. Поиск вхождения одной строки в другую весьма часто используемая операция. Нумерация символов всегда начинается с единицы

Примечание

В функции InStr при очень длинных строках при текстовом методе сравнения, возможно возникновение ошибки времени исполнения Stack overflow. Избежать этой ошибки можно, переведя исходную строку и образец в один регистр и перейдя на бинарное сравнение

Возвращаемое значение

Возвращает значение типа Variant(Long), указывающее позицию первого появления одной строки внутри другой

Перечень возвращаемых значений
Вариант | Значение, возвращаемое функцией InStr
String1 имеет нулевую длину | 0
String1 имеет значение Null | Null
String2 имеет нулевую длину | Start
String2 имеет значение Null | Null
String2 не найдена | 0
String2 найдена внутри String1 | Позиция, в которой обнаружено совпадение
Start > String2 | 0

Параметры
Элемент | Описание
Start | Необязательный. Числовое выражение, которое задает первую позицию для каждого поиска. Если параметр опущен, поиск начинается с позиции первого символа. В том случае, когда значение параметра Start равно Null, возникает ошибка. Параметр Start является обязательным, если задан параметр Compare
String1 | Обязательный. Строковое выражение,в котором ведется поиск
String2 | Обязательный. Отыскиваемое строковое выражение
Compare | Необязательный. Задает тип сравнения для строк. Если значение параметра Compare равно Null, возникает ошибка. В том случае, когда параметр Compare опущен,тип сравнения определяется установками оператора Option Compare

Установки

Для параметра Compare используются следующие установки:
Константа | Значение | Описание
vbUseCompareOption | -1 | Сравнение выполняется с использованием установок для оператора Option Compare
vbBinaryCompare | 0 | Выполняется побитовое сравнение
vbTextCompare | 1 | Выполняется текстовое сравнение
vbDatabaseCompare | 2 | Только для Microsoft Access. Сравнение выполняется с применением сведений из базы данных пользователя

Пример

' В данном примере функция InStr
' возвращает позицию первого появления
' одной строки внутри другой строки
Dim SearchString, SearchChar, MyPos
SearchString ="Русский_Проект"   ' Исходная строка
SearchChar = "Р"   ' Следует найти "P"

' Посимвольное сравнение, начиная с позиции 4. Возвращает 10
MyPos = Instr(4, SearchString, SearchChar, vbTextCompare)

' Двоичное сравнение, начиная с позиции 1. Возвращает 1
MyPos = Instr(1, SearchString, SearchChar, 0)

' Сравнение является двоичным по умолчанию (последний аргумент опущен)
MyPos = Instr(SearchString, SearchChar)   ' Возвращает 1

MyPos = Instr(1, SearchString, "W")   ' Возвращает 0

Функция InStrRev

InstrRev(StringCheck,StringMatch[,Start[,Compare]])

Новая функция, которая появилась в версии Visual Basic 6.0
Функция служит для поиска номера символа, с которого начинается в заданной строке образец поиска. Поиск идет от указанной позиции справа налево

Возвращаемое значение

Возвращает позицию местоположения одной строки внутри другой, отсчитываемую от конца строки типа Variant

Перечень возвращаемых значений
Вариант сравнения | Возвращаемые InStrRev значения
StringCheck имеет нулевую длину | 0
StringCheck имеет значение Null | Null
StringMatch имеет нулевую длину | Значение параметра Start
StringMatch имеет значение Null | Null
StringMatch не найдена | 0
StringMatch найдена внутри StringCheck | Позиция, начиная с которой найдено совпадение
Start > Len(StringMatch) | 0

Параметры
Функция содержит именованные аргументы
StringCheck | Обязательный. Строковое выражение, в котором проводится поиск
StringMatch | Обязательный. Строковое выражение - образец поиска
Start | Необязательный. Числовое выражение, устанавливающее начальную позицию для каждого поиска. Если этот параметр опущен, используется значение –1, задающее начало поиска с позиции последнего символа. Если параметр Start содержит Null, возникает ошибка
Compare | Необязательный. Числовое значение, задающее тип сравнения, который применяется при оценке подстрок. Если параметр опущен, применяется побитовое сравнение. См. значения в разделе «Установки»

Установки

Параметр Compare может иметь следующие значения:
Константа | Значение | Описание
vbUseCompareOption | –1 | Сравнение выполняется с применением установки, задаваемой оператором Option Compare
vbBinaryCompare | 0 | Выполняется побитовое сравнение. Буквы разных регистров считаются разными
vbTextCompare | 1 | Выполняется текстовое сравнение без учета регистров символов
vbDatabaseCompare | 2 | Только для Microsoft Access. Сравнение выполняется на основе информации, хранящейся в базе данных пользователя

Примечания

Обратите внимание на различие в синтаксисах для функций InStrRev и InStr

Пример
' Ищем символ "р" в слове "Русский_Проект"
Print InStrRev("Русский_Проект", "р")

Функция Join

Join(SourceArray[,Delimiter])

Новая функция,которая появилась в Visual Basic 6.0
Функция служит для слияния всех элементов заданного массива в одну строку со вставкой между ними необязательного разделителя

Возвращаемое значение

Возвращает строку, созданную путем объединения множества подстрок, содержащихся в массиве с разделителем между ними

Параметры
SourceArray | Обязательный аргумент - одномерный массив, содержащий объединяемые подстроки
Delimiter | Необязательный аргумент - символ, используемый для разграничения подстрок в возвращаемой строке. Если параметр опущен, применяется символ пробела (" "). В том случае, когда аргумент является строкой нулевой длины (""), производится конкатенация всех элементов списка без добавления разделителей
Пример
' Соединяем два слова
Dim vArr(1 to 2)
Dim retval as String
vArr(1)="Русский"
vArr(2)="Проект"
retval=Join(vArr,"_")
Print retval

Функция LCase

LCase(String)
LCase$(String)

Функция LCase(Lower Case) преобразует символы строки в строчные; все буквы в нижнем регистре и небуквенные символы остаются неизмененными. Вместо LCase можно использовать универсальную функцию преобразования строк StrConv

Возвращаемое значение

Возвращет строку, которая отличается от входной тем, что все буквы преобразованы в строчные. Если параметр String содержит Null, то и возвращаемым значением является Null

Параметры
String Обязательный аргумент может представлять любое строковое выражение
Пример
 ' Преобразуем  строчку в нижний регистр
Form1.Caption=LCase("РусСкий_ПРОект")

Функция Left

Left(String, Length)
Left$(String, Length)
LeftB(String, Length)
LeftB$(String, Length)

Функция Left служит для усечения исходной строки до заданной длины. Для определения числа символов в строке следует использовать функцию Len

Возвращаемое значение

Возвращает строку прочитанных данных. Даннные могут быть символами или байтами

Параметры
Функция содержит именованные аргументы
String | Обязательный аргумент - строковое выражение, из которого извлекаются символы. Если выражение имеет значение Null, то возвращается Null
Length | Обязательный аргумент - значение типа Variant(Long). Числовое выражение, указывающее число возвращаемых символов. Если равно 0, то возвращается пустая строка (" "). Если значение Length больше либо равняется числу символов в исходной строке, то возвращается вся строка Примечание: При отрицательных значениях аргумента генерируется ошибка времени исполнения Invalid procedure call or argument Если аргумент Null, то генерируется ошибка времени исполнения Invalid use of Null
Пример
' Используем функцию для извлечения
' указанного числа первых символов строки
Dim strMyString, retval
' Задаем строку
strMyString = "Русский_Проект"
retval = Left(strMyString, 1)  ' Возвращает "Р"
retval = Left(strMyString, 7) ' Возвращает "Русский"
retval = Left(strMyString, 27)	' Возвращает "Русский_Проект"

Функция Len

Len(String | Varname)
LenB(String | Varname)

Функция Len вычисляет число символов в строке или размер заданной переменной. Из двух возможных аргументов должен быть указан только один. Для определяемых пользователем типов Len возвращает размер, который требуется для записи переменной в файл

Возвращаемое значение

Возвращает значение типа Long, содержащее число символов в строке или число байт, необходимое для размещения переменной

Параметры
String
Обязательный аргумент - любое допустимое строковое выражение
Varname
Обязательный аргумент - любое допустимое имя переменной. Если выражение имеет значение Null, то возвращается Null. Если же аргумент имеет значение типа Variant, то функция Len обрабатывает его так же, как и значение типа String, и всегда возвращает число содержащихся в нем символов
Пример
 ' Вычисляем длину строки Русский_Проект
Print Len("Русский_Проект")

Функция LTrim

LTrim(String)
LTrim$(String)

Функция LTrim(Left Trim) удаляет пробелы в начале строки

Возвращаемое значение

Возвращает исходную строку типа Variant(String) без начальных пробелов. Если аргумент имеет значение Null, то возвращается Null

Параметры
String Обязательный аргумент может представлять любое строковое выражение
Пример
Dim retval
retval=LTrim("  <-Русский_Проект->  ")
Print retval

Функция Mid

Mid(String,Start,[Length])
Mid$(String,Start,[Length])
MidB(String,Start,[Length])
MidB$(String,Start,[Length])

Функция Mid(Middle) используется для считывания заданного числа символов или байт подряд от заданной позиции в строке слева направо. Нумерация символов в строке всегда начинается с единицы. Для определения числа символов в строке следует использовать функцию Len

Возвращаемое значение

Возвращает значение типа Variant (String), содержащее указанное число символов строки

Параметры
Функция содержит именованные аргументы
String
Обязательный аргумент - строка, из которой извлекаются символы. Если аргумент имеет значение Null, возвращается Null
Start
Обязательный аргумент - значение типа Long. Позиция символа в строке String, с которого начинается нужная подстрока. Если Start больше числа символов в строке string, функция Mid возвращает пустую строку ("")
Примечание Если аргумент имеет отрицательное значение или равен 0, то генерируется ошибка времени исполнения
Length
Необязательный аргумент - значение типа Variant (Long). Число возвращаемых символов. Если этот аргумент опущен или превышает число символов, расположенных справа от позиции Start, то возвращаются все символы от позиции Start до конца строки
Примечание Если аргумент имеет отрицательное значение, то генерируется ошибка времени исполнения
Пример
' Используем функцию для извлечения
' указанного числа символов
' из слова колобок
Dim Mystring,retval
Mystring="колобок"
retval=Mid(Mystring,3,3)
Print retval ' возвращает лоб

Функция Partition

Partition(Number,Start,Stop,Interval)

Функция служит для определения числовой оси, в который попадает заданное число. Применяется в задачах статистической обработки, для построения гистограмм

Возвращаемое значение

Возвращает значение типа Variant(String), указывающее положение числа в вычисляемом наборе диапазонов. Возвращаемая строка состоит из двух полей, разделенных двоеточием. Каждое поле содержит число символов, на единицу большее числа цифр в Stop, выводимые числа выравниваются по правому краю поля. Если любой из аргументов имеет значение Null, возвращается значение Null

Параметры
Функция содержит именованные аргументы
Number | Обязательный аргумент - целое число, для которого проверяется положение относительно набора диапазонов
Start | Обязательный аргумент - целое число, задающее начало набора диапазонов. Это число должно быть неотрицательным
Stop | Обязательный аргумент - целое число, задающее конец набора диапазонов. Это число должно быть больше, чем значение Start
Interval | Обязательный аргумент - целое число, задающее размер каждого диапазона в наборе диапазонов от Start до Stop. Это число не может быть меньше 1

Пример

' Предположим, что таблица "Заказы"
' содержит поле "Доставка". Описанный ниже
' запрос на выборку подсчитывает число заказов,
' расходы на доставку которых попадают в каждый
' диапазон. Сначала функция Partition задает
' границы диапазонов, а затем функция SQL Count
' подсчитывает число заказов, попадающих
' в каждый диапазон. В данном примере
' аргументы функции Partition имеют
' следующие значения: начало = 0, конец = 500,
'интервал = 50. Первым диапазоном будет 0:49,
' и так далее до 500

SELECT DISTINCTROW Partition([Доставка],0, 500, 50) AS Range,
Count(Заказы.Доставка) AS Count
FROM Заказы
GROUP BY Partition([Доставка],0,500,50);

Функция Replace

Replace(Expression,Find,Replace[,Start[,Count[,Compare]]])

Новая функция,которая появилась в Visual Basic 6.0

Возвращаемое значение

В результате действия функции Replace возвращается исходная строка с замененным строковым фрагментом

Параметры
Expression
Обязательный аргумент - строка, в которой требуется замена
Find
Обязательный аргумент - подстрока, которую нужно заменить
Replace
Обязательный аргумент - подстрока замены
Start
Необязательный аргумент - указывает позицию
Count
Необязательный аргумент - указывает число
Compare
Необязательный аргумент - вид сравнения

Пример

' меняем слово "хочу" на "люблю" 1 раз
Dim sample$, findstr$, newstr$,retval$
sample = "Я хочу, хочу, хочу тебя" 'строка,которую будем менять
findstr = "хочу" 'подстрока для замены
newstr = "люблю" ' новая подстрока для  замены
retval = Replace (sample,findstr, repl, 1, 1)  ' меняем один раз, начиная с первого символа
Debug.Print retval

Функция Right

Right(String, Length)
Right$(String, Length)
RightB(String, Length)
RightB$(String, Length)

Функция Right служит для усечения справа исходной строки заданной длины. Для определения числа символов в строке следует использовать функцию Len

Возвращаемое значение

Возвращает значение типа Variant (String), содержащее указанное число последних символов или байтов строки

Параметры
Функция содержит именованные аргументы
String
Обязательный аргумент - строковое выражение, из которого извлекаются символы. Если выражение имеет значение Null, то возвращается Null
Length
Обязательный аргумент - значение типа Variant (Long). Числовое выражение, указывающее число возвращаемых символов. Если равно 0, то возвращается пустая строка (" "). Если значение Length больше либо равняется числу символов в исходной строке, то возвращается вся строка
Примечание:При отрицательных значениях аргумента генерируется ошибка времени исполнения Invalid procedure call or argument
Если аргумент Null, то генерируется ошибка времени исполнения Invalid use of Null

Пример

' Используем функцию для извлечения
' указанного числа первых символов строки
Dim strMyString, retval
' Задаем строку
strMyString = "Русский_Проект"
retval = Right(strMyString, 1)  ' Возвращает "т"
retval =Right(strMyString, 7) ' Возвращает "_Проект"
retval =Right(strMyString, 27)	' Возвращает "Русский_Проект"

Функция RTrim

RTrim(String)
RTrin$(String)

Функция RTrim(Right Trim) удаляет пробелы в конце строки

Возвращаемое значение

Возвращает исходную строку типа Variant(String) без завершающих пробелов. Если аргумент имеет значение Null, то возвращается Null

Параметры
String
Обязательный аргумент - любое строковое выражение

Пример

Dim retval
retval=RTrim("  <-Русский_Проект->  ")
Print retval

Функция Space

Space(Number)

Функция Space используется для создания строки с указанным числом пробелов. Функцию целесообразно использовать для форматирования и удобного представления данных в строках фиксированной длины. Данная функция часто применяется при работе с функциями API, обрабатывающие строковые данные

Возвращаемое значение

Функция Space возвращает значение типа Variant(String), содержащее указанное число пробелов

Параметры
Number
Любое положительное целое число. Если аргумент равен нулю, то возвращается пустая строка. Дробные значения аргумента округляются(не усекаются)
Примечание: При отрицательных значениях аргумента генерируется ошибка времени исполнения Invalid procedure call or argument

Пример

Dim MyString
' Вставляем 10 пробелов между словами
MyString = "Русский" & Space(10) & "Проект"
MsgBox MyString

Функция Spc

Spc(n)

Функция Spc используется вместе с инструкцией Print # или методом Print для установки позиции вывода для создания более красивого вида. Больше ее нигде не используют, поэтому назвать функцией ее можно назвать весьма условно. При использовании метода Print и пропорционального шрифта поле печати разбивается на позиции фиксированной ширины, ширина которых равняется средней ширине всех символов текущего размера в используемом шрифте. Такую же ширину имеют пробелы, задаваемые функцией Spc. Следует отметить, что не существует зависимости между числом напечатанных символов и числом позиций фиксированной ширины, занимаемых этими символами. Например, прописная буква "W" шире одной позиции, а строчная буква "I" уже

Возвращаемое значение

Функция Spc что-то возвращает, раз это функция. Только что!

Параметры
n
Обязательный аргумент, задающее число пробелов, которые следует вставить перед выводом на экран или печать следующего выражения в списке. Если n меньше, чем ширина строки вывода, следующий символ печатается сразу после указанного числа пробелов. Если n больше, чем ширина строки вывода, следующая позиция печати вычисляется по приведенной ниже формуле:
текущаяПозицияВывода + (n Mod ширина)
Например, если текущая позиция печати равняется 24, а ширина строки вывода равняется 80, то выражение Spc(90) установит следующую позицию печати равной 34 (текущая позиция печати + остаток от деления 90 на 80). Если разность между текущей позицией печати и шириной строки вывода меньше, чем n (или n Mod ширина), функция Spc задает переход в начало следующей строки и вставку n – (ширина – текущаяПозицияВывода) пробелов
Примечание: Убедитесь, что табличные колонки достаточно широки для размещения широких букв

Пример

' В данном примере функция Spc
' используется для позиционирования вывода
' в файле и в окне Отладка
' Функцию Spc можно использовать в инструкции Print #
Open "TESTFILE" For Output As #1 ' открываем файл для записи
Print #1, "10 пробелов между этой строкой"; Spc(10); "и этой строкой."
Close #1	' Закрываем файл

' Следующая инструкция выводит текст
' в окно Отладка с помощью метода Print,
' печатая перед ним 30 пробелов

Debug.Print Spc(30); "После тридцати пробелов..."

Функция Split

Split(Expression,[Delimiter],[Limit],[Compare] )

Новая функция, которая появилась в Visual Basic 6.0
Функция Split используется для расщепления строки на субстроки с использованием разделителя субстрок

Возвращаемое значение

Функция Split(Expression) возвращает одномерный массив с типом данных Variant(String), содержащий в качестве элементов найденные субстроки

Параметры
Expression
Обязательный аргумент - строка, которую нужно расщепить. Если аргумент содержит нулевую строку(""), то возвращается пустой массив, т.е. массив без элементов и данных
Delimiter
Необязательный аргумент - символы типа String, которые используются в качестве разделителя строки. Если аргумент опущен, то по умолчанию используется символ пробела(" "). Если же аргумент содержит нулевую строку(""), то возвращается одноэлементный массив, содержащее целую строку
Limit
Необязательный аргумент, содержащий число возвращаемых субстрок. Если аргумент опущен или равен -1, то обрабатывается вся строка
Compare
Необязательный аргумент - числовая константа, определяющая вид сравнения:
vbUseCompareOption=-1
Используется по умолчанию метод сравнения, заданный инструкцией Option Compare
vbBinaryCompare=0
Двоичный метод сравнения. Буквы разных регистров считаются разными
vbTextCompare=1
Текстовый метод сравнения. Сравнение без учета регистров
vbDatabaseCompare=2
Только для Microsoft Access. Сравнение с использованием информации базы данных

Пример

' Считаем число вхождений слова "кол" в строке
Dim stroka As String ' строчка для подсчета
Dim retval ' возвращаемое значение
stroka = "Шит колпак не по-колпаковски. Ливерная колбаса."
retval = Split(stroka, "кол")
MsgBox "'кол' встречается в строке'" & stroka _
& "' " & UBound(retval) & " раза"

Функция Str

Str(Number)

Функция Str(String) используется для приведения числового выражения типа Long в строку(тип String)

Возвращаемое значение

Функция Str(Expression) возвращает значение Number, преобразованное в текстовый тип данных String.
При преобразовании в начале строки возвращаемого значения резервируется место для знака числа. Если число положительно, то в этом месте будет пробел, если число отрицательно, то выводится знак минус.
В качестве десятичного разделителя дроби функция Str воспринимает только точку. При использовании других десятичных разделителей (например, запятой) следует использовать функцию CStr

Параметры
Number
Любое выражение, которое можно записать в виде строки

Пример

Dim retval
retval = Str(123)' получаем " 123"
retval=Str(-12.3)' получаем "-12.3"

Функция StrComp

StrComp(String1, String2[, Compare])

Функция StrComp служит для сравнения двух строк. Аналогична сравнению строк с помощью операторов арифметического сравнения

Возвращаемое значение

Возвращает значение типа Variant (Integer), представляющее результат сравнения строк

Возвращаемые значения
string1 меньше чем string2 | -1
string1 равняется string2 | 0
string1 больше чем string2 | 1
string1 или string2 имеет значение Null | Null

Параметры
Функция содержит именованные аргументы
String1 | Обязательный аргумент - любое допустимое строковое выражение
String2 | Обязательный аргумент - любое допустимое строковое выражение
Compare | Необязательный аргумент. Указывает способ сравнения строк. Аргумент может быть опущен или иметь значение -1, 0, 1 или 2. Если аргумент имеет значение Null, возникает ошибка

Именованный аргумент Compare имеет следующие значения:
Константа | Значение | Описание
vbBinaryCompare | 0 | Двоичное сравнение по внутренним кодам символов.Буквы разных регистров считаются разными.Установлен по умолчанию
vbTextCompare | 1 | Текстовое сравнение строк без учета регистра на основе системной национальной настройки
vbDatabaseCompare | 2 | По установкам базы данных.Используется только в Microsoft Access

Примечание: В справке указывается еще одно неправильное значение (vbUseCompareOption,-1). Однако, вы не сможете использовать этот параметр в своих программах, невзирая на справку

Пример

 'В данном примере функция StrComp
' используется для сравнения строк

Dim MyStr1, MyStr2, MyComp
MyStr1 = "ABCD": MyStr2 = "abcd"
MyComp = StrComp(MyStr1, MyStr2, 1)  ' Возвращает 0
MyComp = StrComp(MyStr1, MyStr2, 0)  ' Возвращает -1
MyComp = StrComp(MyStr2, MyStr1)  ' Возвращает 1

Функция StrConv

StrConv(String,Conversion,[LocaleID])

Функция StrConv служит для преобразования всех символов строки в соответствии с заданным видом преобразования.В версии VB/VB 6 добавлены дополнительные возможности

Возвращаемое значение

Возвращает значение типа Variant (String), содержащее преобразованную строку

Параметры
Функция содержит именованные аргументы
String | Обязательный аргумент - строковое выражение, которое следует преобразовать
Conversion | Обязательный аргумент - значение типа Integer, равное сумме констант, указывающих тип преобразования, которое следует выполнить. Смотри ниже
LocaleID | Необязательный аргумент - локальный идентификатор, если отличается отличается от системного идентификатора. По умолчанию - локальный идентификатор

Константы, задающие коды допустимых преобразований строки:
Константа | Значение | Описание
vbUpperCase | 1 | Преобразование строки к верхнему регистру
vbLowerCase | 2 | Преобразование строки к нижнему регистру
vbProperCase | 3 | Преобразование первой буквы каждого слова в строке в прописную
vbWide | 4 | Преобразование однобайтовых символов в двухбайтовые. Применимо только к дальневосточным национальным настройкам
vbNarrow | 8 | Преобразование двухбайтовых символов в однобайтовые. Применимо только к дальневосточным национальным настройкам
vbHiragana | 32 | Преобразование символов катаканы в символы хираганы. Применимо только к японскому языку
vbUnicode | 64 | Преобразование строки в Unicode с помощью используемой по умолчанию системной кодовой страницы
vbFromUnicode | 128 | Преобразование строки из Unicode с помощью используемой по умолчанию системной кодовой страницы

Константы можно складывать, только если они не являются взаимно обратными

Ниже перечислены допустимые символы, служащие разделителями слов: Null (Chr$(0)), горизонтальная табуляция (Chr$(9)), перевод строки (Chr$(10)), вертикальная табуляция (Chr$(11)), конец страницы (Chr$(12)), возврат каретки ( Chr$(13)), пробел (однобайтовая система) (Chr$(32)). Код пробела в двухбайтовых системах (DBCS) зависит от текущей страны

Пример

Dim mystring
mystring = "русский проект"
 ' Преобразуем первые буквы в прописные
Print StrConv(mystring, vbProperCase)

Функция String

String(Number,Character)

Функция String используется для создания строки из одинаковых символов

Возвращаемое значение

Возвращает значение типа Variant (String), содержащее повторяющуюся строку указанной длины

Параметры
Функция содержит именованные аргументы
Number
Обязательный аргумент - число типа Long, определяющее длину возвращаемой строки. Если аргумент имеет значение Null, то возвращаемое значение тоже Null
Character
Обязательный аргумент - значение типа Variant. Код символа или строковое выражение, первый символ которого используется при создании возвращаемой строки. Если аргумент имеет значение Null, возвращается значение Null. Значения аргумента, превышающие 255, преобразуются функцией String в допустимые коды символов по следующей формуле:

character Mod 256

Пример

' В данном примере функция String
' используется для генерации строк,
' содержащих указанное число
' повторяющихся символов

Dim MyString
MyString = String(3, "M") ' Возвращает "MMM"
MyString = String(5, 65) ' Возвращает "ААААА".Возвращает 5 раз символ,код которого 65
MyString = String(6, "Русский_Проект") ' Возвращает "РРРРРР".Повторяет 6 раз первый символ исходной строки

Функция StrReverse

StrReverse(Expression)

Новая функция,которая появилась в Visual Basic 6.0
Функция StrReverse используется для построения заданной строки в обратном порядке

Возвращаемое значение

Функция StrReverse возвращает строку Expression в обратном порядке

Параметры
Expression
Любое выражение,которое можно записать в виде строки

Пример

' Получаем обратный порядок
' и выводим надпись в заголовке формы
Form1.Caption = StrReverse("Русский_Проект"

Функция Tab

Tab(n)

Функция Tab используется вместе с инструкцией Print # или методом Print для указания позиции вывода для создания более красивого вида. Больше ее нигде не используют, поэтому назвать функцией ее можно назвать весьма условно. При использовании метода Print и функции Tab поле печати разбивается на позиции фиксированной ширины, ширина которых равняется средней ширине всех символов текущего размера в используемом шрифте. Следует отметить, что не существует зависимости между числом напечатанных символов и числом позиций фиксированной ширины, занимаемых этими символами. Например, прописная буква "W" шире одной позиции, а строчная буква "I" уже

Возвращаемое значение

Функция Tab что-то возвращает, раз это функция. Только что!

Параметры
n
Необязательный аргумент задает номер столбца, к которому следует перейти перед выводом на экран или печать следующего выражения из списка. Если аргумент опущен, Tab устанавливает курсор в начало следующей зоны печати. Это позволяет использовать функцию Tab вместо запятой в качестве разделителя списка, если в текущей национальной настройке запятая используется в качестве десятичного разделителя.
Если текущая позиция печати на текущей строке больше n, функция Tab вызывает переход к n-му столбцу на следующей строке вывода. Если n меньше 1, Tab переходит к столбцу 1. Если n больше, чем ширина строки вывода, следующая позиция печати вычисляется по приведенной ниже формуле:

n Mod ширина

Например, если ширина равняется 80, то выражение Tab(90) установит следующую позицию печати равной 10 (остаток от деления 90 на 80). Если n меньше, чем текущая позиция печати, печать начинается в вычисленной позиции печати в следующей строке. Если вычисленная позиция печати больше, чем текущая позиция печати, печать начинается в вычисленной позиции печати в той же строке. Крайней левой позицией печати строки вывода всегда является 1. При печати в файл с помощью инструкции Print # крайней правой позицией печати является текущая ширина результирующего файла, которая устанавливается с помощью инструкции Width #
Примечание: Убедитесь, что табличные колонки достаточно широки для размещения широких букв

Пример

' В данном примере функция Tab
' используется для позиционирования вывода
' в файле и в окне Отладка
' Функцию Tab можно использовать в инструкции Print #
Open "TESTFILE" For Output As #1 ' открываем файл для записи
' Второе слово печатается в столбце 20
Print #1, "Всем"; Tab(20); "привет"
' Если аргумент опущен, курсор
' перемещается в начало следующей зоны печати
Print #1, "Русский"; Tab; "Проект"
Close #1	' Закрываем файл

' Следующая инструкция выводит текст
' в окно Отладка с помощью метода Print,
' печатая текст,начиная со столбца 10

Debug.Print Tab(10); "Начиная со столбца 10"

Функция Trim

Trim(String)

Функция Trim объединяет действия двух функций LTrim и RTrim, удаляя пробелы как справа, так и слева

Возвращаемое значение

Возвращает исходную строку типа Variant(String) без начальных и завершающих пробелов. Если аргумент имеет значение Null, то возвращается Null

Параметры
String
Обязательный аргумент может представлять любое строковое выражение

Пример

Dim retval
retval=Trim("  <-Русский_Проект->  ")
Print retval

Функция TypeName

TypeName(VarName)

Функция TypeName определяет тип данных переменной или свойства объекта

Возвращаемое значение

Возвращает значение типа String, представляющее тип переменной

Список возвращаемых значений
Byte | Byte
Integer | Integer
Long | Long
Single | Single
Double | Double
Currency | Currency
Decimal | Decimal
Date | Date
String | String
Boolean | Boolean
Variant(Error) | Error
Variant(Empty) | Empty
Variant(Null) | Null
Object | Object
Объект неизвестного типа | Unknown
Объектная переменная, не содержащая ссылки на объект | Nothing
Примечание

Если аргумент представляет массив, то возвращается одна из перечисленных выше строк (или Variant) с добавлением пустых скобок. Например, если аргумент представляет массив целых значений, то функция возвращает строку "Integer()"

Параметры
VarName
Обязательный аргумент представляет выражение типа Variant, определяющее любую переменную, за исключением переменной с определяемым пользователем типом
Пример
Dim myVar
myVar = "Русский_Проект"
Print TypeName(myVar) 'возвращается String

Функция UCase

UCase(String)

Функция UCase(Upper Case) преобразует символы строки в верхний регистр.Вместо UCase можно использовать универсальную функцию преобразования строк StrConv

Возвращаемое значение

Возвращет строку, которая отличается от входной тем, что все буквы преобразованы в прописные

Параметры
String
Обязательный аргумент может представлять любое строковое выражение
Пример
 ' Преобразуем  строчку в верхний регистр
Form1.Caption=UCase("русский_проект")

Функция Val

Val(String)

Функция Val(Value) служит для преобразования аргумента в числовой тип данных. Функция Val прекращает чтение строки на первом символе, который она не может распознать в качестве части числа. Символы, которые часто рассматриваются в качестве частей числовых значений, типа знака доллара и запятых, не распознаются. Однако, эта функция распознает префикс основания &O (для восьмеричных) и &H (для шестнадцатеричных значений). Пробелы, символы табуляции и символы перевода строк удаляются из значения параметра. Функция Val распознает в качестве разделителя целой и дробной части только точку (.). Если используются другие разделители целой и дробной частей (например в национальных версиях приложений), следует применять для преобразования строки в число функцию CDbl

Внимание У функции имеется баг! Например, при вызове функции Val("7.1%") генерируется ошибка Type mismatch. Хотя другие примеры работают нормально: Val("7%") возвращает 7, Val("7.%") возвращает 7, Val("7.0%") возвращает 7

Возвращаемое значение

Возвращает числовое представление аргумента с подходящим типом данных

Параметры
String
Обязательный аргумент является любым допустимым строковым выражением
Пример
' В следующем примере возвращается
' числовое значение 1615198
Print Val("    1615 198th Street N.E.")

' В следующем примере возвращается десятичное
' значение -1 для приведенного ниже
' шестнадцатеричного значения
Print Val("&HFFFF")

Использован материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Работа графикой

конец

вопросы

задания

Цель работы

Целью работы является изучение возможностей разработки графических приложений

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • Изучить графические операторы языка Visual Basic

  • Изучить возможности просмотра графических файлов в Visual Basic

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение графических операторов языка Visual Basic .

  • Задание 2 - разработка приложения с использованием графических операторов.

  • Задание 3 - изучение возможностей изменения цветовой палитры.

  • Задание 4 - изучение возможностей рисования в графическом окне.

  • Задание 5 - разработка приложения просмотра графических файлов.

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он должен содержать:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Заключение и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены возможностей разработки графических приложений

Были рассмотрены темы:

  • Задание 1 - изучение графических операторов языка Visual Basic .

  • Задание 2 - разработка приложения с использованием графических операторов.

  • Задание 3 - изучение возможностей изменения цветовой палитры.

  • Задание 4 - изучение возможностей рисования в графическом окне.

  • Задание 5 - разработка приложения просмотра графических файлов.

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Вопросы к лабораторной работе

конец

вопросы

задания

  1. Где находится начало координат окна?

  2. Какими способами можно задать цвет?

  3. Назовите процедуры вывода графических примитивов вы знаете?

  4. Какие параметры имеет процедура вывода точки?

  5. Какие параметры имеет процедура построения линии (отрезка), прямоугольника?

  6. Какие параметры имеет процедура построения окружности, дуги, сектора, эллипса

  7. Как выполнить закраску замкнутых фигур?

  8. Как описываются события в Visual Basic?

  9. Какие события вы знаете, приведите примеры событий?

  10. Как в Visual Basic можно организовать вывод готового рисунка?

  11. Для чего используется объект CommonDialog?

  12. Как очистить графическое поле PictureBox после вывода на него рисунка?

начало

назад

вперед

конец

вопросы


Задания к лабораторной работе

Все задания к лабораторной работе

конец

вопросы

задания

ЗАДАНИЕ 1.
Создайте проект, позволяющий строить графики в соответствии с индивидуальным заданием
Сохраните проект на диске.
ЗАДАНИЕ 2.
Создайте проект и напишите программу "Светофор", позволяющую по нажатию кнопки "включать" заданный свет светофора.
Сохраните проект на диске.

ЗАДАНИЕ 3.
Создайте проект и напишите программу рисования треугольников и колец и вычисляющую площади нарисованных фигур.
Сохраните проект на диске.

ЗАДАНИЕ 4.
Создайте проект, позволяющий просматривать графические файлы. Спроектируйте свою форму (рабочее окно) программы просмотра графических файлов. Используйте различные варианты поиска и открытия файла
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Вариатны индивидуальных заданий на массивы

1. Построить график функции Y=k*x на отрезке [0, 1] при K=3.5

2. Построить график функции Y=3*x2 на отрезке [-5, 5]

3. Построить график функции Y=Cos(x)+1 на отрезке [0, 2*Pi]

4. Построить график функции Y=(x+3)/(x-2) на отрезке [3, 10]

5. Построить график функции Y=3+2/x+3/x2 на отрезке [-3, -1]

6. Построить график функции Y=1/(x2-2*x+1) на отрезке [-10, 0]

7. Построить окружность радиуса R=30 c центром в начале координат по заданному параметрическому представлению X=R*Cos(t); Y=R*Sin(t) 0 <= t <= 2*Pi

8. Построить эллипс с большой и малой полуосями, равными R1=10 и R2=30 и расположенными параллельно осям координат по заданному параметрическому представлению X=R1*Cos(t); Y=R2*Sin(t); 0 <= t <= 2*Pi

9. Построить кардиоиду по заданному параметрическому представлению X=a*Cos(t)*(1+Cos(t)); Y=a*Sin(t)*(1+Cos(t)); a=15; 0 <= t <= 2*Pi

10. Построить эпициклоиду по заданному параметрическому представлению X=(a+b)*Cos(t)-a*Cos((a+b)*t/a); Y=(a+b)*Sin(t)-a*Sin((a+b)*t/a); a=12; b=5; 0 <= t<= 2*PI

11. Построить лемнискату по уравнениям в полярных координатах (p - радиус вектор; f - угол) p=a*(2*Cos(2*f))^(1/2); при a=5


Для запуска программы из главного меню Windows выполните следующие действия

Графические операторы V isual Basic

конец

вопросы

задания

Графический режим работы подразумевает использование операторов, позволяющих создавать графические объекты: точки, отрезки, прямоугольники, окружности, дуги, сектора, эллипсы. Из этих элементарных объектов можно создавать более сложные.

Общими параметрами для всех графических объектов являются:

  • координаты, определяющие его расположение в окне;

  • цвет объекта;

  • цвет заливки объекта, если он ограничен замкнутой линией.

Координаты расположения объектов

Координаты отсчитываются от левого верхнего угла окна. Единицей отсчета по умолчанию является Twip. В процессе разработки приложения можно изменить единицу измерения, используя свойство объекта ScaleMode.

Цвета

Цвет может задаваться двумя способами, в зависимости от выбранной палитры:

  • 16 цветовая палитра использует команду QBcolor(n), где n - номер цвета:

  • палитра, полученная при смешивании разного количества красного, зеленого и голубого цветов задается:

    • командой RGB(n1,n2,n3). Здесь n1, n2 и n3 числа в диапазоне от 0 до 255, которые задают количество каждого из базовых цветов в полученном оттенке. Например: RGB(0, 255, 0) - задает зеленый цвет без примеси других оттенков (цветов).

    • константами вида: &H8000000F&, &H000000FF& и т.д.

Графические примитивы

Рассмотрим процедуры вывода графических примитивов на заданный объект.

  1. Точка.

    [объект.] Pset (x,y) [,цвет]

    - где (x,y) - координаты точки

  2. Линия (отрезок), прямоугольник.

    [объект.] Line [(x1,y1)] - (x2,y2) [,Цвет] [,B[F]]

    - где (x1,y1) - координаты начальной точки отрезка. Если они не указаны, отрезок начинается от текущей позиции. Координаты конечной точки отрезка (x2,y2) нужно указывать обязательно.

    Параметр Цвет определяет цвет линии. Если он не задан, то для рисования используется значение свойства формы ForeColor. Для явного задания значения цвета можно использовать функцию QBColor(n) или RGB(n1,n2,n3).

    Если указан параметр B (Box-прямоугольник), то вместо линии вычерчивается прямоугольник; пары координат определяют положение его противоположных по диагонали углов. Прямоугольник заполняется цветом (см. далее закраску фигур), указанным в FillColor, а тип заполнения определяется свойством FillStyle формы. Если указан параметр F, то прямоугольник закрашивается тем же цветом, что и границы. Параметр F используется только вместе с параметром B.

  3. Окружность, дуга, сектор, эллипс.

    Circle(x,y), R [,Цвет][[-]n1,[-]n2 [,n3]]

    - где (x,y) - координаты центра окружности (дуги, сектора, эллипса)

    Параметр Цвет определяет цвет линии. Если он не задан, то для рисования используется значение свойства формы ForeColor. Для явного задания значения цвета можно использовать функцию QBColor(n) или RGB(n1,n2,n3).

    Параметры n1 и n2 определяют углы начала и конца дуги в радианах и отсчитываются против часовой стрелки. Знак минус перед параметрами является признаком сектора, а при его отсутствии вычерчивается дуга.

    Параметр n3 определяет коэффициент сжатия при вычерчивании эллипса. Если его знамение меньше 1 то осуществляется сжатие в вертикальном направлении, если больше 1 - сжатие в горизонтальном направлении.

    Примеры использования процедур вывода графических примитивов

Закраска замкнутых фигур

Замкнутую фигуру - прямоугольник, окружность, сектор эллипс - можно закрасить (заливка). Для этого необходимо указать цвет и стиль закраски.

Стиль заливки

FillStyle = n

- где n - числа в диапазоне от 0 до 7, задающие сплошную закраску, закраску горизонтальной или вертикальной штриховкой и т. д.

Пример закраски замкнутых фигур

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Переменные, константы и типы данных

Таблица единиц измерений, устанавливаемых в свойстве ScaleMode

ScaleMode | Единицы измерения
0 | Определяются пользователем
1 | Twip (по умолчанию) - 1/20 пункта или 1/1440 дюйма или ~0.002 см
2 | Point (пункт) - 1/72 дюйма или 0,035 см.
3 | Pixel - точки
4 | Character (cимволы) - 1/6 дюйма по вертикали и 1/12 дюйма по горизонтали
5 | Inch - дюймы
6 | Millimeter - миллиметры
7 | Centimeter - сантиметры


Для запуска программы из главного меню Windows выполните следующие действия

Переменные, константы и типы данных

Примеры использования процедур вывода графических примитивов на графическое поле (PictureBox)

Точка

Picture1.Pset (3000,4500),RGB(0,20,255)

В скобках указываются координаты точки.

Например:

Линия из текущей точки:

Picture1.Line -(3000, 4000)

В скобках указаны координаты конца отрезка.

Линия по двум заданным точкам:

Picture1.Line(50,30) - (2000,2500),RGB(200,150,200)

В скобках указаны координаты противоположных концов отрезка.

Прямоугольник:

Picture1.Line(50,30) - (200,250),RGB(200,150,200), B

Команда для построения отрезка легко превращается в команду для построения прямоугольника: добавка параметра B превращает концы отрезка в противоположные вершины прямоугольника (левый верхний и правый нижний углы).

Окружность:

Picture1.Circle(130,250), 50, RGB(100,140,80)

В скобках указаны координат центра и после скобок - радиус окружности (в данном случае 50).

Дуга (часть окружности):

Picture1.Circle(200,200), 40, RGB(100,200,100), 2.4,3.8

В скобках указаны координат центра и после скобок - радиус окружности, затем цвет и в конце - параметры характеризующие начало и конец дуги. Эти параметры определяют угол в радианах и отсчитываются против часовой стрелки

Сектор (часть круга, ограниченная дугой и двумя радиусами):

Picture1.Circle(200,200), 40, RGB(100,200,100), -2.4, -3.8

В скобках указаны координат центра и после скобок - радиус окружности, затем цвет и в конце - параметры начало и конец дуги. Эти параметры определяют угол в радианах и отсчитываются против часовой стрелки. Признаком сектора является знак минус перед параметрами начала и конца дуги.

Эллипс (окружность, сжатая в горизонтальном или вертикальном направлении):

Picture1.Circle(200,200), 40, RGB(100,200,100), , , 0.7

В скобках указаны координат центра и после скобок - радиус окружности, затем цвет и параметры, характеризующие начало и конец дуги (если сжимается вся окружность, то эти места остаются пустыми) и в конце - коэффициент сжатия. Число <1 указывает сжатие в вертикальном направлении, число >1 - сжатие в горизонтальном направлении.


Для запуска программы из главного меню Windows выполните следующие действия

Переменные, константы и типы данных

Пример закраски замкнутых фигур

Picture1.FillColor = QBColor(8)

Picture1.FillStyle = 0

Picture1.Circle (150, 150), 60, RGB(0, 0, 225)

Таблица цветов

Номер | Цвет
0 | Чёрный
1 | Синий
2 | Зелёный
3 | Циан
4 | Красный
5 | Мажента
6 | Жёлтый
7 | Белый
8 | Серый
9 | Светло-синий
10 | Светло-зелёный
11 | Светлый циан
12 | Светло-красный
13 | Светлая мажента
14 | Светло-жёлтый
15 | Ярко-белый


Для запуска программы из главного меню Windows выполните следующие действия

Построение графиков

конец

вопросы

задания

Создадим проект и напишем программу, позволяющую строить спираль вокруг начала координат с N витками и внешним радиусом R. Параметрическое представление спирали X=R*Cos(t); Y=R*Sin(t); R=t/2; 0 <= t <= 2*N*Pi

Пример реализации интерфейса приложения

Текст программы

ЗАДАНИЕ 1.
Создайте проект, позволяющий строить графики (в соответствии с индивидуальным заданием (см. раздел "Задания")
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложение с использованием графических операторов

конец

вопросы

задания

Создадим проект и напишем программу "Светофор". Программа должна по нажатию кнопки "включать" заданный свет светофора.

Пример реализации интерфейса приложения

Фрагмент текста программы

Контуры светофора прорисовываются сразу после запуска приложения. Для этого в процедуре Form -изменено событие - установлено Activate. Событие Activate вызывается в тот момент, когда форма становится активной (получает фокус).

В Visual Basic события указываются в заголовке процедуры:

[Private | Public] Sub НазваниеОбъекта_ИмяСобытия ([СписокАргументов])

Текст процедуры

End Sub

Дополнительно: описание событий в Visual Basic

ЗАДАНИЕ 2.
Создайте проект и напишите программу "Светофор", позволяющую по нажатию кнопки "включать" заданный свет светофора.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Описание событий для основных элементов упра вления Visual Basic 5

назад

Список событий Visual Basic

  • Activate,Deactivate
  • Change
  • Click
  • DblClick
  • DragDrop
  • DragOver
  • Error
  • GotFocus
  • Initialize
  • ItemCheck
  • KeyDown, KeyUp
  • KeyPress
  • LinkClose,LinkError,LinkNotify,LinkOpen
  • Load
  • LostFocus
  • MouseDown, MouseUp
  • MouseMove
  • ObjectMove
  • OLECompleteDrag
  • OLEDragDrop
  • OLEDragOver
  • OLEGiveFeedback
  • OLEStartDrag
  • Paint
  • PathChange
  • PatternChange
  • QueryUnload
  • Reposition
  • Resize
  • Scroll
  • Terminate
  • Timer
  • Unload
  • Updated
  • Validate
Событие
Причина возникновения
Activate,
Deactivate

Это событие имеет только форма.

Activate - вызывается в тот момент, когда форма становится активной (получает фокус). Однако, если перейти к другому приложению Windows, а затем вернуться к своему, то это событие не произойдёт. Оно срабатывает только при переключении между формами внутри программы.

Deactivate - Событие, обратное событию Activate. Вызывается при потере фокуса формы.
Change

ComboBox ≈ меняется текст в текстовой части элемента. Происходит только тогда, когда свойство Style установлено в 0 (Dropdown Combo) или 1 (Simple Combo) и юзер изменяет текст или вы меняете его в коде программы.

DirListBox ≈ Меняется выбранная директория. Происходит когда пользователь делает двойной клик на новой директории или когда меняется свойство Path в коде.

DriveListBox ≈ Меняется выбранное устройство. Происходит когда юзер меняет устройство, выбрав его из списка, или когда меняется свойство Drive в коде.

HScrollBar и VScrollBar (горизонтальная и вертикальная прокрутки) ≈ Подвинулся скрол. Происходит когда юзер передвинул и отпустил полоску прокрутки или меняется свойство Value в коде.

Label ≈ Меняется содержимое метки. Происходит когда меняется свойство Caption в коде.

PictureBox ≈ Меняется содержимое PictureBox. Происходит при смене свойства Picture. (а также при использовании LoadPicture, прим.eax)

TextBox ≈ Меняется текст в текстовом поле. Происходит при смене текста юзером или при смене свойства Text в коде.
Click

Происходит когда юзер нажимает и отпускает кнопку мышки над оъектом. Оно также может происходить при смене некоторого значения объекта.

Для формы такое собитие выполняется при клике на свободном месте формы, или по отключённому элементу управления (т.е. когда его Enabled = False).

Вообще событие происходит и для правой кнопки мыши и для левой. Но для элементов CheckBox, CommandButton, Listbox, и OptionButton происходит только при нажатии левой кнопки мыши.

Для ComboBox или ListBox оно происходит и при клике мышой и также при смене текущего элемента клавишами курсора.

Происходит при нажатии на "ПРОБЕЛ" у элементов CommandButton, OptionButton, или CheckBox, когда те имею фокус.

При нажатии на ENTER при фокусе на элементе CommandButton (то бишь гашей кнопке) и когда установлено свойство Default.

Происходит при нажатии на ESC когда форма имеет Cancel кнопку - CommandButton с установленым свойством Cancel.

Также происходит при нажатии на горячую последовательность. Например, если кнопка имеет Caption - "&Go", то при нажатии Alt+G запуститься событие.

Также, событие Click может быть сгенерировано в следующих случаях в коде: Установка значения Value для OptionButton и CheckBox.
DblClick

Происходит при двойном клике по объекту.

Для формы происходит при двойном клике по форме, а также по отключённому объекту.

Для других элементов:

Двойной клик по объекту левой кнопкой.

Двойной клик по элементу в ComboBox, когда Style = 1. Или также в FileListBox, ListBox, DBCombo, или DBList.
DragDrop

Происходит при завершении операции перетаскивания (Drag&Drop). В обработку события передаются 3 аргумента - координаты курсора (X,Y), где был отпущен объект, и ссылка на объект (Source), который был перетащен.
DragOver

Происходит когда объект перетаскивается над получателем, но кнопка ещё не отпущена. Имеет 4 параметра. Координаты курсора, ссылка на объект, и текущее состояние (State As Integer):

0 = Enter (вошёл) (источник вошёл в область объекта).
1 = Leave (покинул) (источник ушёл из этой области).
2 = Over (над) (произошёл сдвиг в пределах области).
Error

Происходит только при работе с базами данных. Коркретно: при ошибке в доступе к данным при выполнении кода.

Имеет 2 параметра:

dataerr - номер произошедшей ошибки
response - номер, соответствующий выбранному в настройках (Settings):

Если vbDataErrContinue, то response = 0 (Продолжить)
Если vbDataErrDisplay, то response = 1 (Default) Показать сообщение об ошибке.
GotFocus

Происходит, когда объект получает фокус, или при нажатии кнопки Tab или кликом по объекту, а также при запуске метода SetFocus в программе. Форма получает фокус только тогда, когда все видимые элементы отключены (Enabled = False).
Initialize

Это событие имеет только форма.

Обрабатывается первым и один раз. Visual Basic вызывает его при первом создании формы. Здесь обычно размещают код, для инициализации нужных переменны в программе.
ItemCheck

Происходит когда у ListBox контрола свойство Style установлено в 1 (checkboxes) и выбран или сброшен флажок у какого-либо элемента (item) в контроле.

Передаётся один параметр:

index - номер элемента, который был выбран в ListBox.
KeyDown, KeyUp

Происходит когда юзер нажимает (KeyDown) или отпускает (KeyUp) клавишу, в то время как объект имеет фокус. Чтобы получить код клавиши, используйте событие KeyPress. Параметров нет.
KeyPress

Происходит когда юзер нажамает и отпускает клавишу на клавиатуре.

Событие имеет один параметр:

keyascii - код нажатой клавиши. Например, если нажать на клавишу "1" (основного ряда), то keyascii будет равен 49. Если нажать ESC, то 27, и и.д.

Если присвоить этой переменной 0, то нажатая буква (символ) не появится в текством поле. Иногда это бывает очень удобным. Например, можно сделать так, чтобы в текстовое поле можно было вводить только цифры. Вот пример:

LinkClose
LinkError
LinkNotify
LinkOpen

LinkClose: Происходит когда DDE соединение закрывается. Может произойти в любое время.

LinkError: Происходит при возникновении ошибки в ходе связи DDE.

LinkNotify: Происходит когда у источника меняются данные, на которые установлена ссылка DDE.

LinkOpen: Происходит при создании инициализации DDE связи с источником.

За подробностями пожалуйста обращайтесь к справочникам, т.к. эти события используются очень редко.
Load

Это событие имеет только форма.

Обрабатывается при загрузке формы в память. Происходит после события Initalize. Обычно код испольняется один раз. При запуске программы, это событие обрабатывается автоматически для той формы, которая загружается первой.

Это событие может выполняться несколько раз. Т.е. если вы выгрузите форму оператором Unload, а затем вновь загрузите оператором Load или методом Show, то это событие будет выполнено.
LostFocus

Происходит при потере объектом фокуса, или при нажатии Tab юзером, или при использовании метода SetFocus для другого объекта.
MouseDown, MouseUp

Происходят когда юзер нажимает (MouseDown) или отпускает (MouseUp) кнопку мыши.

Имеют 4 передаваемых параметра:

button - содержит integer - номер кнопки мыши. С помощью этого события можно опеределить какую кнопку нажал пользователь. Для этого используюся константы: vbLeftButton (левая), vbMiddleButton (средняя), vbRightButton (правая). Проверить можно примерно так:

If button = vbRightButton Then ...

shift - содержит integer - указывающее на состояние клавиш Shift, Alt и Ctrl. Бит 0 - Shift, бит 1 - Ctrl, бит 2 - Alt. Для опредения факта нажатия клавиш Ctrl и Alt можно использовать такой код:

If (Shift And (vbCtrlMask Or vbAltMask)) = (vbCtrlMask Or vbAltMask) Then ...

Т.е. мы проверяем содержит ли переменная Shift биты 1 и 2 (оператором And). Скобки везде обязательны. vbShiftMask, vbAltMask, vbCtrlMask - это обычные константы, содержащие маски битов:

vbShiftMask = 1 (нулевой бит) Bin: 00000001
vbCtrlMask = 2 (первый бит) Bin: 00000010
vbAltMask = 4 (второй бит) Bin: 00000100

x, y - координаты курсора мыши того места, где произошло событие MouseUp или MouseDown. Координаты всегда зависят от координытной системы, задаваемой свойствами ScaleHeight, ScaleWidth, ScaleLeft, ScaleTop объекта.
MouseMove

Происходит когда курсор мыши изменяет своё положение над объектом. Т.е. когда курсор стоит на месте, событие не происходит. При каждом сдвиге курсора - срабатывает.

Параметры те же, что и у MouseDown и MouseUp.
ObjectMove

Происходит немедленно после того, как OLE контейнер сдвигается или меняет размеры пока объект активен.

Передаваемые параметры:

left - координата левой грани OLE контейнера
top - координата верхней грани OLE контейнера
width - ширина OLE контейнера
height - высота OLE контейнера
OLECompleteDrag

Происходит когда компонент - источник "брошен" на компонент - цель, информируя объект о том, что либо завершён, либо отменён процесс перетаскивания.

Имеет один параметр:

effect - привожу оригинал: A long integer set by the source object identifying the action that has been performed, thus allowing the source to take appropriate action if the component was moved (such as the source deleting data if it is moved from one component to another). The possible values are listed in Settings.

А Settings может быть:

vbDropEffectNone = 0 - операция "бросания" (Drop) была отменена.
vbDropEffectCopy = 1 - показывать значок копирования данных.
vbDropEffectMove = 2 - "сбрасываемые" данные являются ссылкой на оригинальные данные.
OLEDragDrop

Это событие происходит когда на объект сбрасываются OLE данные. Например, происходит при перетаскивании на объект файлов из проводника, или перетаскивании изображения из Internet Explorer и т.п.

Замечание: Это событие происходит только в том случае, когда свойство OLEDropMode установлено в 1 (Manual).

Имеет очень много параметров:

data - объект типа DataObject. Имеет 4 метода и одно свойство - коллекцию файлов, перетаскивамых на объект. Для получения данных можно использовать метод GetData. Чтобы узнать формат данных, перекинутых на объект можно использовать метод GetFormat.

effect Long - привожу оригинал - set by the target component identifying the action that has been performed (if any), thus allowing the source to take appropriate action if the component was moved (such as the source deleting the data). The possible values are listed in Settings.

button - то же, что и в событии MouseDown(Up).

shift - то же, что и в событии MouseDown(Up).

x,y - то же, что и в событии MouseDown(Up).

Пример. Обработаем перетащенные на форму файлы. Не забудьте установить свойство OLEDropMode в 1.

Private Sub Form_OLEDragDrop _
(Data As DataObject, Effect As Long, _
Button As Integer, Shift As Integer, _
X As Single, Y As Single)
' перетаскиваются файлы?
If Data.GetFormat(vbCFFiles) = True Then
Dim c As Long
' пройдёмся по всей коллекции
For c = 1 To Data.Files.Count
' покажем имя перетащенного файла
MsgBox "Был перетащен файл: " & Data.Files(c)
Next c
End If
End Sub
OLEDragOver
Происходит при перетаскивании над объектом. Парметры - комбинация парамтров событий OLEDragDrop и обычного DragOver.
OLEGiveFeedback

Происходит после каждого события OLEDragOver. OLEGiveFeedback позволяет источнику обеспечивать визуальную "отдачу" пользователю, такое, как изменение курсора мыши (посмотрите на него при перетаскивании файлов в проводнике с нажатым Ctrl, - видите значок "+", вот это и есть та "отдача"?), которое будет говорить пользователю о том, что происходит.

Параметры - effect и

defaultcursors - boolean - разрешает или запрещает использование курсора по умолчанию. Если True - то используется курсор по умолчанию, если False, то использутся курсор, указанный пользователем в свойстве MousePointer объекта Screen.
OLEStartDrag

Происходит тогда, когда начинается перетаскивание (т.е. когда перетаскиваемый объект (файл, например) появляется над объектом приёмником). Имеет 2 параметры:

data - то же что и у события OLEDragDrop.

allowedeffects - Long - содержит поддерживаемые источником эффекты. Возможные значения описаны в Setting'сах.
Paint

Происходит когда часть или весь объект появляется на экране после сдвига или изменения размера. Событие происходит также при сдвиге окна, которое закрывает объект.

Разберём чуть подробнее:

Событие Paint полезно, если вы используете графические методы объекта (Line, PSet...) в коде. С помощью этого события вы можете убедиться в том, что данные перерисовались, когда это необходимо.

Событие Paint вызывается при запуске метода Refresh.

Если AutoRedraw установлено в True, то перерисовка происходит автоматически, таким образом, это событие теряет свою необходимость.

Если свойство ClipControls установлено в False, то графические методы в процедуре Paint воздействуют только на видимую часть формы; иначе, графические методы перерисовывают всю открытую часть формы (т.е. ту, которая не перекрыта такими элементами, как Image, Label, Line, и Shape).

Используя метод Refresh в событии Resize вызывает перерисовку всего объекта каждый раз, когда происходит изменение его размеров (Resize).

Замечание: Используя событие Paint для определённых задач, может произойти каскадирование событий (Т.е. просто напросто произойдёт рекурсия, когда Paint будет вызывать сам себя, и произойдёт переполнение стека). Чтобы этого избежать, нужно придерживаться следующих правил:

╥ Избегать вызова события Paint при сдвиге или изменении размеров объекта.
╥ Внутри события Paint изменять свойства, которые могут вызвать событие Paint. Такие, например, как BackColor.
╥ Включать метод Refresh метод внутрь Paint.
PathChange

Происходит при смене пути, установкой свойства FileName или Path в коде.

Замечание: Вы можете использовать это события, чтобы сообщить FileListBox'у о том, что путь у DirListBox изменился.
PatternChange

Происходит при изменении маски (такой, как "*.*") установкой свойств FileName или Pattern в коде.
QueryUnload

Это событие имеет только форма.

Происходит перед закрытием формы или приложения. Если закрывается MDI форма, то это событие происходит сначала для формы контейнера, и лишь потом для дочерних форм.

Это событие происходит перед событием Unload.

В обработчик данного события передаётся два параметра:

cancel - integer - если в обработчике события присвоить переменной cancel значение True, то выгрузка формы будет отменена. Если оставить там False, то форма благополучно выгрузится.

unloadmode - константа. Содержит значение - почему происходит выгрузка формы. Может принимать:

vbFormControlMenu = 0 - юзер выбрал команду Close (Закрыть) в меню приложения (слева вверху в заголовке формы).

vbFormCode = 1 - произошёл вызов оператора Unload в коде программы.

vbAppWindows = 2 - Windows завершает работу.

vbAppTaskManager = 3 - закрытие приложения происходит через Ctr+Alt+Del.

vbFormMDIForm = 4 - дочерняя MDI форма закрывается, т.к. закрывается главная.

Замечания:

Вообще, это событие обычно применяется для проверки завершённости некоторых действий. Или также, например, здесь можно спросить юзера, действительно ли он хочет выйти из приложения, или это произошло случаянно. Следать это можно примерно так:

Private Sub Form_QueryUnload _
(Cancel As Integer, _
UnloadMode As Integer)
Dim rez As VbMsgBoxResult
rez = MsgBox("Вы действительно" & _
" хотите выйти?", _
vbQuestion + vbYesNo)
If rez = vbNo Then Cancel = 1
End Sub
Reposition

Происходит когда запись становится текущей записью.

Замечания:

Когда Data контрол загружен, первая запись в объекте RecordSet становится текущей, и вызывается это событие. Когда бы юзер не кликнул любую кнопку на контроле Data, передвигаясь с записи на запись, или вы используете одно из методов Move в коде (такие, как MoveFirst, MoveNext, FindFirst..), или любое другое свойство, которое может изменить текущую запись - происходит событие Reposition.

Событие Validate происходит перед этим событием.
Resize

Происходит когда объект первый раз появляется или когда меняется состояние окна (например, при свёртывании и развёртывании окна). А также при смене размеров окна.

Это событие удобно использовать, если вы хотите сделать "растягивающийса" интерфейс. Т.е. когда все элементы на форме меняют свои размеры, в зависимости от текущих размеров формы. Код для изменения размеров этих элеметов как раз можно поместить в это событие.
Scroll

Происходит тогда, когда сдвигается полоса прокрутки (ScrollBar).

Замечания:

Для DBGrid это событие происходит, когда двигается вертикальная или горизонтальная полоса прокрутки.

Для ComboBox это событие происходит при сдвиге скролбара в выпадающем списке.

Вы можете использовать это события для синхронизации изменения положения полоски прокрутки и другими объектами, с которыми эта полоска связана. К примеру, в обработку этого события вставить код, который будет синхронизировать текущую позицию с другим элеметом. Поместите на форму HScroll и вставьте такой код:

Private Sub HScroll1_Scroll()
Form1.Caption = HScroll1.Value
End Sub

Теперь в заголовок формы будет меняться в соответствии со сменой положения полоски прокрутки.

Кстати, избегайте использования фукнции MsgBox в этом событии!
Terminate

Это событие имеет только форма.

Происходит когда все ссылки на экземпляры форм, MDI форм, элементы управления, классы удалены из памяти (установкий переменной в Nothing).

Это событие выполняется после события Unload, и выполняется самым последним в программе. Можете использовать его по своему усмотрению.
Timer

Это событие имеется только у элемента управления Timer.

Оно происходит через определённый интервал времени, указанный в его свойтве Interval.

Timer невидим для пользователя, и полезен для внутренних процессов программы.

Его можно использовать когда необходимо, чтобы некоторый код программы выполнился через определённый промежуток времени.

Например, с его помощью можно сделать часы. Для этого достаточно поместить на форму элемент Timer, установите его свойство Interval в 1000 (1 сек = 1000 мс), и вставить следующий код:

Private Sub Timer1_Timer()
Form1.Caption = Time
End Sub

Функция Time возвращает текущее системное время. Таким образом, каждую секунду будет выполнять событие Timer, и следовательно изменение заголовка формы.

Примечание: количество таймеров на форме не ограничено.
Unload

Это событие имеет только форма.

Происходит когда форма выгружается из памяти (оператором Unload, например, или нажатием на крестик). В дальнейшем она может быть загружена оператором Load.

При перезагрузке формы ВСЕ ЭЛЕМЕНТЫ УПРАВЛЕНИЯ ИНИЦИАЛИЗИРУЮТСЯ ЗАНОВО, т.е. все значения, которые были в них - теряются.
Updated

Происходит когда меняются данные (при работе с БД).

Имеет параметр Code - integer - описывает, как объект был изменён (описано в настройках). Может принимать следующие константы:

vbOLEChanged = 0 - Данные объекта изменились
vbOLESaved = 1 - Данные объекта были сохранены приложением
vbOLEClosed = 2 - Файл, на который ссылается объект был закрыт
vbOLERenamed = 3 - Файл, на который ссылается объект был переименован
Validate

Это событие нужно для проверки введённых данных. Например, в TextBox. Это событие выполняется только тогда, когда свойство объекта CausesValidation = True.

Рассмотрим пример, как можно проконтролировать данные, введённые в текстовое поле. Поместите на форму TextBox и вставьте код:

Private Sub Text1_Validate _
(Cancel As Boolean)
If Not (IsNumeric(Text1.Text)) Then
Text1.ForeColor = vbRed
MsgBox "Введите в TextBox числа"
Cancel = True
Else
Text1.ForeColor = vbButtonText
End If
End Sub

Этот код не примет введённый в TextBox текст, пока тот не будет являться числом. Если установить параметр Cancel в True, то фокус вернётся обратно TextBox.

Это событие происходит при потере фокуса у объекта.

Материал с сайта http://vb.hut.ru Copyright 2002 Volkov Anton. All rights reserved. [ Волков Антон ]


Для запуска программы из главного меню Windows выполните следующие действия

Рисование в графическом окне

конец

вопросы

задания

В Visual Basic можно рисовать в графическом окне графические примитивы, используя манипулятор мышь.

Создадим проект и напишем программу рисования в графическом окне (PictureBox) графических примитивов:

- отрезка прямой по двум заданным точкам;

- прямоугольника по координатам точек левого верхнего и правого нижнего угла;

- окружности по заданному центру и точке, лежащей на окружности.

Пример реализации интерфейса приложения (окна формы проекта) для решения задачи рисования графических примитивов.

Текст программы.

Событийная процедура Picture1 обрабатывает событие MouseDown, которое происходит, когда пользователь нажимает на кнопку мыши. В результате для объекта PictureBox определены координаты x, y курсора мыши того места, где произошло событие MouseDown.

В программе использован двухмерный массив p(i,j) из четырех элементов.

Индекс i определяет номер точки графического примитива 0 или 1:

- для линии точка 0 - начало отрезка, точка 1 - конец отрезка;

- для прямоугольника точка 0 - верхняя левая вершина, 1 - правая нижняя вершина;

- для окружности точка 0 - центр окружности, 1 - точка, лежащая на окружности.

Индекс j определяет? какая из координат точки задана: 0 - координата по оси Х, 1 - координата по оси Y.

Циклы по переменным i и j в конце событийной процедуры позволяют обнулить элементы массива, когда графический примитав (отрезок прямой, прямоугольник или окружность) уже вычерчен.

Дополнительно: описание событий в Visual Basic

ЗАДАНИЕ 3.
Создайте проект и напишите программу рисования треугольников и колец и вычисляющую площади нарисованных фигур.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложение для просмотра графических файлов

конец

вопросы

задания

В Visual Basic можно организовать вывод готового рисунка, созданного в каком-либо графическом редакторе на графическое поле PictureBox.

Picture1.Picture=LoadPicture(FullFileName)

где FullFileName - полное имя загружаемого файла, например c:\Мои документы\Рисунки\рicture01.jpg

Имя файла можно вводить из текстового поля (TextBox) или выбирать визуально, работая с файловой системой, как было описано в лабораторной работе № 5, тема 4.

Можно использовать другой способ визуального поиска и открытия файла - с помощью объекта CommonDialog. Этот объект будет доступен после размещения на панели элементов управления Visual Basic компоненты Microsoft Commom Dialog Control 6.0.

Создадим проект, позволяющий просматривать графические файлы .bmp, jpg, .gif. Для этого спроектируем форму с компонентами как показано на рисунке.

Текст программы.

CommonDialog1.Filter позволяет определить типы файлов (по маскам), которые будут отображаться в окне открытия файла.

Запустив программу, вы сможете визуально искать и открывать файл, используя стандартное окно открытия файла.

После поиска и открытия файла вы увидите выбранный вами графический файл

ЗАДАНИЕ 4.
Создайте проект, позволяющий просматривать графические файлы. Спроектируйте свою форму (рабочее окно) программы просмотра графических файлов. Используйте различные варианты поиска и открытия файла
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Многооконные приложения со стандартными формами и меню

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является изучение возможностей разработки многооконных приложений с использованием стандартных форм и текстового меню.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • Изучить возможности и порядок создания проектов многооконных приложений в Visual Basic

  • Изучить стандартные шаблоны форм в Visual Basic

  • Изучить возможности и порядок создания текстового меню в Visual Basic

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - создание проектов многооконных приложений в Visual Basic .

  • Задание 2 - использование стандартных шаблонов форм в Visual Basic.

  • Задание 3 - создание текстового меню в Visual Basic

  • Задание 4 - создание многооконного приложения (шаг1)

  • Задание 5 - создание многооконного приложения (шаг 2)

  • Задание 6 - создание полнофункционального многооконного приложения с системой меню

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он должен содержать:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанного проекта;

  • исходные тексты программ на Visual Basic для разработанного проекта;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Заключение и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены возможности разработки многооконных приложений с использованием стандартных форм и текстового меню.

Были рассмотрены темы:

  • Задание 1 - создание проектов многооконных приложений в Visual Basic .

  • Задание 2 - использование стандартных шаблонов форм в Visual Basic.

  • Задание 3 - создание текстового меню в Visual Basic

  • Задание 4 - создание многооконного приложения (шаг1)

  • Задание 5 - создание многооконного приложения (шаг 2)

  • Задание 6 - создание полнофункционального многооконного приложения с системой меню

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные тексты программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы


Вопросы к лабораторной работе

конец

вопросы

задания

  1. Как добавить в проект новую форму?

  2. Как создать текстовое меню приложения?

  3. Как создать пункты подменю в главном меню приложения?

  4. Какие возможности по корректировке структуры меню есть в Visual Basic?

  5. Как назначить "горячие клавиши" для пунктов текстового меню?

  6. Какие конструкции языка Visual Basic нужно использовать для открытия нового окна приложения?

  7. Какие конструкции языка Visual Basic нужно использовать для закрытия окна приложения?

  8. Как связать конкретный пункт меню с событийной процедурой?

  9. Для чего нужен стандартный шаблон AboutDialog?

  10. Для чего нужен стандартный шаблон Splash Screen?

  11. Как задать, какая из форм будет стартовать при запуске приложения?

  12. Для чего нужен элемент управления UpDown?

  13. Для чего нужен элемент управления Timer?

начало

назад

вперед

конец

вопросы


Задания к лабораторной работе

Все задания к лабораторной работе

конец

вопросы

задания

ЗАДАНИЕ 1.
Создайте проект с тремя формами. Расположите на формах кнопки, позволяющие переходить из одной формы в другую в соответствии со следующими правилами:
- из формы 1 должен быть предусмотрен переход в форму 2 и форму 3, при этом форма 1 должна быть невидима;
- из формы 2 должен быть предусмотрен переход в форму 3, при этом форма 2 должна оставаться видимой;
- из формы 3 должен быть предусмотрен переход в форму 1, при этом форма 2 и форма 3 должны быть невидимы.
ЗАДАНИЕ 2.
Включите в структуры создаваемого проекта (см. задание 1) стандартную форму About Dialog, поместив на форму 1 (Form1) кнопку для ее открытия.
Сохраните проект на диске.

ЗАДАНИЕ 3.
Включите в приложение текстовое меню, содержащие пункты "Файл" и "О программе". В пункте меню файл должно быть подменю "Выход", позволяющее завершить работу с программой.
Сохраните проект на диске.

ЗАДАНИЕ 4.
Создайте проект и напишите программу, позволяющую выводить на табло будильника текущее время (Time) и дату (Date), а также задавать время сигнала и включать звуковой сигнал в заданное время.
Сохраните проект на диске.
ЗАДАНИЕ 5.
Создайте систему текстового меню, реализующего заданные в описании задачи функции приложения а также формы, связанные с пунктами меню. Они могут отличаться от приведенных на этой странице примеров реализации форм.
Включите в состав проекта окно с информацией о программе, используя для этого стандартный шаблон AboutDialog.
Добавьте окно-заставку, которая будет запускаться при старте программы.
Сохраните проект на диске.
ЗАДАНИЕ 6.
Создайте все компоненты проекта "Будильник" в соответствии с заданием. Экранные формы компонентов интерфейса, содержащиеся на них управляющие элементы и текст программы могут существенно отличаться от приведенных в данном описании.
Сохраните проект на диске.
Индивидуальное задание (повышенной сложности)
Создайте универсальную программу Будильник - таймер, позволяющую:

1. Отображать на табло текущую дату и время в режиме будильника;

2. Отображать на табло текущее время и обратный отсчет времени в режиме таймера;

3. Отображать в виде индикатора (ProgressBar) время, оставшееся до звукового сигнала;

4. Задавать время включения звукового сигнала и интервал времени для таймера;

5. Обеспечивать повтор звукового сигнала через заданный промежуток времени;

6. Настраивать цветовое оформление (табло будильника-таймера и поле ввода времени звонка);

7. Настраивать функцию повтора звукового сигнала (включать и выключать функцию повтора и задавать время повтора);

8. Настраивать (выбирать) звуковой сигнал;

6. Отображать заставку программы при ее запуске и сведения о программе.

Возможна реализация других функций, не указанных в задании.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Многооконные приложения в Visual Basic

конец

вопросы

задания

Как правило, при создании сложного приложения в Visual Basic приходится включать в состав проекта несколько взаимосвязанных форм.

Главная форма создается автоматически при создании проекта. Именно она будет открываться по умолчанию, если не будет изменена структура проекта и не указана другая форма в качестве первого запускаемого объекта.

Для того, чтобы добавить в проект новую форму, необходимо в проводнике проекта вызвать контекстное меню.

В появившемся окне выбрать элемент Form и нажать кнопку Открыть.

После этого в проводнике проекта появится очередная форма

Поместим на форму 1 (Form1) кнопку

А в событийную процедуру, связанную с кнопкой запишем текст

Теперь, после запуска проекта, нажатие на кнопку "Открыть форму 2", расположенную на форме 1 вызовет открытие формы 2 (Form2) и она станет активной. При этом форма 1 останется на экране, но будет неактивной.

Если при переходе к форме 2 форму 1 нужно убрать с экрана, т.е. сделать невидимой, в событийную процедуру, связанную с кнопкой на форме 1 запишем текст

ЗАДАНИЕ 1.
Создайте проект с тремя формами. Расположите на формах кнопки, позволяющие переходить из одной формы в другую в соответствии со следующими правилами:
- из формы 1 должен быть предусмотрен переход в форму 2 и форму 3, при этом форма 1 должна быть невидима;
- из формы 2 должен быть предусмотрен переход в форму 3, при этом форма 2 должна оставаться видимой;
- из формы 3 должен быть предусмотрен переход в форму 1, при этом форма 2 и форма 3 должны быть невидимы.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Использование стандартных шаблонов форм в Visual Basic

конец

вопросы

задания

Для многократного использования удачных и хорошо зарекомендовавших себя интерфейсных решений можно создать собственные шаблоны и использовать их при проектировании новых приложений, а также использовать стандартные шаблоны форм.

Для того, чтобы добавить в проект новую форму, созданную на базе стандартного шаблона, необходимо в проводнике проекта вызвать контекстное меню, выполнить пункт добавления к проекту новой формы и в появившемся окне форм выбрать необходимый стандартный шаблон формы, после чего нажать кнопку Открыть.

В данном случае будет создан шаблондиалогового окно с краткой информацией о назначении приложения и его функциях. Для вызова формы с краткой информацией о назначении приложения и его функциях удобно использовать команду меню приложения About (О программе) или кнопку на главной форме

Вы можете заполнить поля формы, изменяя для каждого ее поля свойство Caption

В процессе разработки приложения можно использовать стандартные шаблоны, имеющиеся в Visual Basic.

ЗАДАНИЕ 2.
Включите в структуры создаваемого проекта (см. задание 1) стандартную форму About Dialog, поместив на форму 1 (Form1) кнопку для ее открытия.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Tема 11

Стандартные шаблоны Visual Basic

Шаблон About Dialog

Обычно в приложение добавляют диалоговое окно с краткой информацией о назначении приложения и его функциях. Для создания этого диалогового окна в Visual Basic можно использовать шаблон формы About Dialog

Для вызова формы с краткой информацией о назначении приложения и его функциях удобно использовать команду меню приложения About (О приложении) или кнопку на главной форме.

Шаблон About Dialog содержит следующие объекты:

- поле для отображения значка приложения. Для значка можно использовать графическое изображение эмблемы фирмы;

- текстовое поле Application Title (Заголовок приложения) для ввода заголовка приложения;

- текстовое поле Version (Версия) для вывода номера версии приложения;

- текстовое поле Арр Description (Описание приложения) для вывода описания приложения;

- текстовое поле Warning (Внимание) для вывода информации об авторских правах, работе с приложением и т. д.;

- кнопку ОК для выхода из этого окна;

- кнопку System Info (Системная информация) для вывода системной информации о параметрах компьютера.

Шаблон Dialog

Для выбора какого-либо действия, для подтверждения действия, для вывода какого-либо сообщения безо всяких действий можно использовать шаблон стандартного диалогового окна.

В этом шаблоне можно разместить предупреждающий текст, ввести элементы выбора (например, переключатели или раскрывающийся список) и в зависимости от ситуации, использовать готовые кнопки подтверждения выбора — ОК (Да) или Cancel (Отмена). Этим кнопкам можно оставить предложенные по умолчанию названия или переименовать.

Шаблон Log in Dialog

Для организации входа в приложение с использованием имени пользователя и пароля, как это часто делается в современных приложениях, можно воспользоваться шаблоном окна запроса имени и пароля пользователя — Log in Dialog. При входе в приложение необходимо будет ввести имя пользователя для регистрации и пароль для входа.

При несовпадении имени или пароля будет выдаваться соответствующее сообщение. Кнопки ОК и Cancel, расположенные в форме, предназначены для подтверждения входа в приложение или отказа, соответственно.

Шаблон Splash Screen

В приложение можно добавить диалоговое окно описания коммерческих атрибутов приложения, таких как:

- наименование приложения с эмблемой фирмы;

- наименование разработчика приложения и авторов;

- номер лицензии и кому принадлежит лицензия.

- версию приложения и рабочую платформу;

- атрибуты авторского права;

- краткие примечания к приложению.

Шаблон Tip of the Day

Visual Basic 6 при помощи стандартных шаблонов может помочь вам организовать службу ежедневных кратких полезных советов о работе приложения. Для этого можно использовать шаблон окна Tip of the Day (Ежедневный совет).


Для запуска программы из главного меню Windows выполните следующие действия

Создание текстового меню в Visual Basic

конец

вопросы

задания

Для создания системы текстового меню приложения сделайте созданную вами форму (Form1, задания 1 и 2) активной и выполните пункт меню Memu Editor... Visual Basic.

На экране появится окно редактора меню.

Его основными компонентами являются:

1. - поле для ввода наименования пункта меню, например Файл или О программе и т.д.

2. - имя пункта меню, которое будет присвоено соответствующей процедуре в тексте программы

3. - назначение "горячих клавиш", по которым может быть выполнен соответствующий пункт меню (по умолчанию отсутствуют).

4. - кнопка удаления активного пункта меню (выбранного в окне содержания меню (9)).

5. - кнопка вставки пункта меню

6. - кнопка перехода к очередному пункту меню (активация очередного пункта в окне 9)

7. - кнопки изменения уровня вложенноти пунктов меню (основное меню, подменю и т.д.)

8. - кнопки перемещения пунктов меню (изменение структуры меню)

9. - окно содержания меню.

Событийная процедура, связанная с пунктом меню открывается в редакторе исходного кода программы при щелчке мышью на соответствующем пункте меню.

ЗАДАНИЕ 3.
Включите в приложение текстовое меню, содержащие пункты "Файл" и "О программе". В пункте меню файл должно быть подменю "Выход", позволяющее завершить работу с программой.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание многооконного приложения (шаг 1)

начало

назад

вперед

конец

вопросы

задания

Рассмотрим последовательность создания многооконного приложения на примере разработки программы "Будильник".

Программа должна позволять:

1. Отображать на табло текущую дату и время;

2. Задавать время включения звукового сигнала;

3. Обеспечивать повтор звукового сигнала через заданный промежуток времени

4. Настраивать цветовое оформление (табло будильника и поле ввода времени звонка)

5. Настраивать функцию повтора звукового сигнала (включать и выключать функцию повтора и задавать время повтора).

6. Отображать заставку программы при ее запуске и сведения о программе.

Создадим форму, поместив на нее графическое окно (PictureBox), метку (Label)и таймер (Timer)/ Изменим имя метки, назвав ее tim

Напишем содержание событийной процедуры, связанная с таймером (Timer), которое позволит вывести на метку (tim) текущее время.

Добавим на форму поле и кнопку, позволяющие задавать время включения звукового сигнала будильника

Пример реализации интерфейса приложения проекта "Будильник"

Текст программы.

ЗАДАНИЕ 4.
Создайте проект и напишите программу, позволяющую выводить на табло будильника текущее время (Time) и дату (Date), а также задавать время сигнала и включать звуковой сигнал в заданное время.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Для запуска программы из главного меню Windows выполните следующие действия

Создание многооконного приложения (шаг 2)

начало

назад

вперед

конец

вопросы

задания

Создадим в программе систему текстового меню пример которого показан на рисунке

Для настройки функции повтора звукового сигнала создадим форму (Form2).

Пример реализации интерфейса формы настройки функций звукового сигнала.

Для задания времени повтора звукового сигнала использовано текстовое поле и связанный с ним элемент управления UpDown предназначенный для ввода пользователем числовой информации и представляющий собой две кнопки с направленными в противоположные стороны стрелками. Для установки связи необходимо в закладке Boddy свойств элемента управления UpDown указать элемент, с которым он будет использоваться (в нашем случае текстовое поле (Text1))

Один из вариантов реализации формы настройки цветов

При создании формы использованы элементы ImageList, ToolBar, Frame и Command.

при старте программы может запускаться заставка, которая создается с использованием стандартного шаблона Splash Screen.

Для того, чтобы при запуске программы открывалось именно это окно, необходимо изменить свойство проекта.

Указав на вкладке General окна свойств проекта именно это объект в качестве запускаемого в первую очередь.

ЗАДАНИЕ 5.
Создайте систему текстового меню, реализующего заданные в описании задачи функции приложения а также формы, связанные с пунктами меню. Они могут отличаться от приведенных на этой странице примеров реализации форм.
Включите в состав проекта окно с информацией о программе, используя для этого стандартный шаблон AboutDialog.
Добавьте окно-заставку, которая будет запускаться при старте программы.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Tема 11

Использование элементов ImageList и ToolBar

Для использование элементов ImageList и ToolBar необходимо подключить компоненты Microsoft Windows Common Controls 6.0

Создайте форму и поместите на нее компоненты ImageList, Frame и на него ToolBar

Выполните пункт настройки свойств компоненты ImageList, используя контекстное меню.

Поместите ссылки не графические файлы, содержащие фоновые цвета в список Images. Файлы, содержащие фоновые цвета, должны быть предварительно созданы с использованием любого графического редактора, например MS Paint/

Перейдите к настройкам свойств элемента управления ToolBar, используя контекстное меню. На вкладке General в окне ImageList выберите ImageList1.

Перейдите к вкладке Buttons. Создавайте кнопку на панели ToolBar используя в окне свойств кнопку Insert Button и определите для нее цвет, проставив соответствующую цифру в поле Image. После нажатия кнопки Применить, созданная на панели ToolBar кнопка окрасится в соответствующий цвет. Повторите эти операции столько раз, сколько кнопок должно быть на панель ToolBar.


Для запуска программы из главного меню Windows выполните следующие действия

Варианты экранных форм и текста программы

конец

вопросы

задания

Варианты экранных форм программы "Будильник"

Заставка программы

Главное окно программы.

Сообщение о наступлении заданного времени и включение повтора сигнала.

Сообщение о неверном формате ввода времени.

Настройка цветов.

Настройка сигнала будильника

Информационное окно "О программе"

Вариант текст а программы, связанный с главной формой (Form1).

Вариант текста программы, связанного с вспомогательной формой окна настройки сигнала (Form2).

Вариант текста программы, связанного с вспомогательной формой окна настройки цветов (Form3).

ЗАДАНИЕ 4.
Создайте все компоненты проекта "Будильник" в соответствии с заданием. Экранные формы компонентов интерфейса, содержащиеся на них управляющие элементы и текст программы могут существенно отличаться от приведенных в данном описании.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы


Интегрированная среда визуального объектно

Интегрированная среда
визуального объектно-ориентированного программирования Visual Basic 6.0

на главную страницу

Начало работы.. 2

Компоненты рабочей среды.. 3

Главное меню.. 3

Стандартная панель инструментов. 4

Окно конструктора форм.. 4

Панель элементов управления. 5

Окно редактора меню.. 5

Окно свойств. 6

Окно просмотра объектов. 7

Окно макета формы.. 8

Окно редактора исходного кода. 8

Окно проводника проекта. 8

Окно локальных переменных. 9

Окно контроля работы приложения. 9

Окно ручного ввода и выполнения команд.. 10

Настройка среды разработки. 10

Вкладка настроек редактора. 11

Вкладка стилей текста. 12

Вкладка настроек общих свойств среды.. 12

Вкладка настройки окон. 13

Вкладка Environment 14

Вкладка Advanced. 14

ПРИЛОЖЕНИЕ.. 16

Команды меню File. 16

Команды меню Edit 16

Команды меню View.. 17

Команды меню Project 17

Команды меню Format 18

Команды меню Debug. 18

Команды меню Run. 18

Команды меню Query. 18

Команды меню Diagram.. 19

Команды меню Tools. 19

Команды меню Add-Ins. 20

Команды меню Window.. 20

Команды меню Help. 20

Кнопки стандартной панели инструментов. 20

Кнопки панели элементов управления. 21

Начало работы

При запуске Visual Basic 6 на экране появляется диалоговое окно New Project (Новый проект), используя которое можно выбрать шаблон для нового проекта, запустить мастера создания проекта или открыть ранее созданный проект (рис. 1).

Рис. 1 Окно создания проекта

Это окно содержит вкладки следующего назначения:

- New (Новый) — содержит шаблоны и мастера для создания нового проекта;

- Existing (Существующий) — позволяет открыть ранее созданный проект или проекты-примеры, поставляемые с Visual Basic 6. Вкладка имеет раскрывающийся список, с помощью которого можно выбрать любую папку на имеющихся ресурсах компьютера;

- Recent (Недавно созданный) — содержит список проектов, открывавшихся в последнее время;

Для создания нового проекта используется вкладка New. На ней можно выбрать один из следующих типов шаблона проекта:

- Standard EXE — стандартное выполняемое приложение;

- ActiveX EXE — выполняемое приложение ActiveX;

- ActiveX DLL — динамическая библиотека ActiveX;

- ActiveX Control — элемент управления ActiveX;

- VB Application Wizard — мастер приложений;

- VB Wizard Manager — мастер создания пользовательских мастеров;

- Data Project — проект управления базой данных;

- IIS Application — приложение, размещаемое на сервере Web-узла (IIS — Internet Information Server);

- Addin — надстройка, дополнительные утилиты, расширяющие возможности приложений;

- ActiveX Document DLL — динамическая библиотека документов ActiveX;

- ActiveX Document EXE — выполняемое приложение документов ActiveX;

- DHTML Application — приложение, создающее динамические HTML-страницы.

к началу

Компоненты рабочей среды

После выбора типа проекта пользователь переходит непосредственно в инструментальную среду проектирования Visual Basic 6. Ее внешний вид показан на рис. 2

Рис. 2 Инструментальная среда Visual Basic 6.

Элементы среды:

- главное меню;

- стандартная панель инструментов;

- панель элементов управления;

- окно проводника проекта (Project);

- конструктор форм;

- окно свойств (Properties);

- окно макета формы (Form Layout);

- окно просмотра объектов (Object Browser);

- редактор исходного кода.

к началу

Главное меню

Главное меню, как и во всех приложениях Microsoft, представляет собой линейку раскрывающихся меню. Оно содержит следующие основные команды: File (Файл), Edit (Правка), View (Вид), Project (Проект), Format (Формат), Debug (Отладка), Run (Запуск), Query (Запрос), Diagram (Диаграмма), Tools (Сервис), Add-Ins (Надстройки), Window (Окно), Help (Справка).

Наиболее часто используемые команды меню отображены в виде кнопок со значками на стандартной панели инструментов, размещенной ниже меню. Рассмотрим основные команды главного меню.

Меню File (Файл) содержит команды для работы с файлами проекта. Используя эти команды, можно выполнять такие действия, как создание нового проекта, открытие проекта для внесения изменений, добавление проекта для параллельной работы над несколькими проектами или копирование форм из проекта в проект и т. п. Все команды этого меню перечислены в табл. 1- 13 Приложения.

Меню Edit (Правка) содержит команды, предназначенные для редактирования. Часть из них соответствует подобным командам редактирования других приложений Microsoft, например, отменить предыдущую команду, повторить предыдущую команду, вырезать фрагмент текста, скопировать фрагмент в буфер обмена. В составе этого меню целый набор команд для работы с таблицами базы данных: добавлять и удалять поля, назначать первичный ключ в таблице базы данных.

Меню View (Вид) содержит команды вызова окон и панелей инструментальной среды Visual Basic 6.

Меню Project (Проект) содержит команды управления проектом и его элементами. Они позволяют добавить в проект и удалить из него элементы проекта, такие как форма, программный модуль, класс и другие. С помощью команд данного меню вы также можете открыть окно свойств приложения, добавить ссылки на подключаемые библиотеки, добавить дополнительные компоненты на панель элементов.

Меню Format (Формат) содержит большое количество команд форматирования объектов в форме.

Меню Debug (Отладка) содержит команды, предназначенные для отладки приложения. Используя команды этого меню, можно установить точки останова программы и проверить значения выражении и переменных, выполняя программу по шагам.

Меню Run (Запуск) содержит команды управления запуском приложения. Используя команды данного меню, можно запустить приложение на выполнение с компиляцией или без компиляции, приостановить или прервать выполнение приложения.

Меню Query (Запрос) содержит команды создания и выполнения запросов к базе данных. При помощи этого меню, например, можно выполнить запрос, преобразовать результаты запроса в табличный вид.

Меню Diagram (Диаграмма) содержит команды построения диаграммы, отображающей структуру базы данных.

Меню Tools (Сервис) содержит команды управления настройками инструментария среды Visual Basic 6. Они позволяют добавить процедуру и определять ее атрибуты, вызвать окно редактора меню, изменить настройки программы в диалоговом окне Options (Параметры), а также управлять хранилищем проектов SourseSafe.

Меню Add-Ins (Надстройки) содержит команды вызова дополнительных утилит, часто называемых надстройками (add-ins).

Меню Window (Окно) содержит стандартные команды управления окнами. При вызове окон приложения меню Window пополняется соответствующими командами активизации окон приложения. При этом команды активизации окон называются по именам открытых окон.

Меню Help (Справка) содержит команды вызова справочной системы Visual Basic 6. При помощи этого меню можно вызывать справочную систему с различными вариантами представления информации. Отличие между ними состоит в открывающейся по умолчанию вкладке.

к началу

Стандартная панель инструментов

Команды, которые часто используются при работе, можно разместить в виде кнопок на панели инструментов. Можно также исключить из панели редко применяемые команды.

Кнопки панели инструментов снабжены всплывающими подсказками.

Стандартная панель инструментов, расположенная под главным меню, показана на рис. 3 (в том виде, в каком она настроена при установке Visual Basic 6).

Рис. 3 Стандартная панель инструментов

Если эта панель отсутствует в главном окне программы, для ее отображения в меню View (Вид) выберите команду Toolbars (Панели инструментов), а затем значение Standard (Стандартная).

На стандартной панели инструментов расположены кнопки для вызова наиболее часто употребляемых команд меню. Вы можете изменить расположение стандартной панели инструментов, разместив ее в нижней части главного окна, справа или слева. Для этого с помощью кнопки мыши захватите любую границу панели и переместите ее в любое удобное для вас место.

Описание наиболее часто используемые команд панели инструментов приведено в табл. 14 Приложения.

к началу

Окно конструктора форм

Окно конструктора форм является основным рабочим окном, в котором выполняется визуальное проектирование приложения. Это окно показано на рисунке.

Рис. 4 Окно конструктора форм

Вызвать это окно можно из главного меню командой Object (Объект) меню View (Вид) или командой View Object контекстного меню объекта, находящегося в группе Forms в проводнике проекта.

В окне конструктора форм визуально конструируются все формы приложения с использованием инструментария среды разработки.

Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять. При необходимости сетку можно отключать, воспользовавшись параметрами диалогового окна Options, открываемого командой Options (Параметры) из меню View (Вид).

Размер формы в окне можно изменять, используя маркеры выделения формы и мышь. Для изменения размера формы необходимо установить указатель мыши на маркер и, когда он примет вид двунаправленной стрелки, перемещать до получения требуемого размера.

к началу

Панель элементов управления

Панель элементов управления — основной рабочий инструмент при визуальной разработке форм приложения (рис. 5).

Панель элементов управления вызывается из меню View (Вид) командой Toolbox (Панель элементов управления). Для вызова этой панели можно воспользоваться также кнопкой Toolbox на стандартной панели инструментов.

Рис. 5. Панель элементов управления Visual Basic 6

В составе панели элементов управления содержатся основные элементы управления форм — метки, текстовые поля, кнопки, списки и другие элементы для быстрого визуального проектирования макета формы. На панели представлены кнопки, назначение которых описано в табл. 1.15.

Для размещения элементов управления в форме с помощью панели элементов выполните следующие действия:

1. Выделите требуемый элемент управления с помощью мыши.

2. Перейдите в окно конструктора форм. Указатель мыши при этом превратится в крестик, при помощи которого можно установить местоположение размещаемого объекта. Левой кнопкой мыши зафиксируйте позицию нового объекта и, удерживая кнопку, задайте размеры объекта.

к началу

Окно редактора меню

В окне редактора меню Menu Editor (рис. 6) можно создавать или редактировать строку меню для формы.

Рис. 6 Окно редактора меню

Для проектирования меню всех видов используется редактор меню Menu Editor (Редактор меню) среды проектирования IDE.

Редактор меню вызывается одним из следующих способов:

- командой Menu Editor (Редактор меню) меню Tools (Инструменты);

- нажатием кнопки Menu Editor на стандартной панели инструментов;

- нажатием комбинации клавиш <Ctrl>+<E>.

Редактор создает меню для активного в данный момент окна, то есть, если активно MDI-OKHO, проектируется меню для него, если активна дочерняя форма, проектируется меню для дочерней формы.

к началу

Окно свойств

Окно Properties (Свойства) предназначено для отображения и настройки свойств формы, а также размещенных в ней объектов. В нем, например, содержатся такие свойства выбранного объекта, как позиция в форме, высота, ширина, цвет (рис. 7).

Рис. 7 Окно свойств

Диалоговое окно Properties вызывается командой Properties Window (Окно свойств) из меню View (Вид), кнопкой Properties Window на стандартной панели инструментов или командой Properties контекстного меню выбранного объекта. Поскольку форма и элементы управления каждый сами по себе являются объектами, набор свойств в этом окне меняется в зависимости от выбранного объекта. При помощи вкладок Alphabetic (По алфавиту) и Categorized (По категориям) свойства объекта можно просмотреть в алфавитном порядке или по группам (категориям) соответственно.

В нижней части окна вы всегда найдете подсказку, поясняющую назначение выбранного атрибута объекта. Более подробную информацию найдете в справочной системе Visual Basic 6, нажав клавишу <Fl>. При этом необходимо предварительно выделить интересующее вас свойство.

Используя диалоговое окно Properties, можно изменить установленные по умолчанию свойства объектов. Часть свойств объекта, например, размеры и расположение объектов, можно задать перемещением объекта и изменением его размеров с помощью мыши в конструкторе форм.

Свойства, установленные в окне свойств, допускается изменять при выполнении приложения, написав соответствующие коды в процедурах, создаваемых с помощью редактора кода.

Как правило, форма содержит много объектов. Если выбрать сразу несколько объектов, то в окне свойств отобразятся общие для этих объектов свойства.

В начале изучения Visual Basic 6 в окне свойств Properties предпочтительнее пользоваться вкладкой Categorized (По категориям), так как на ней все свойства сгруппированы по типам и поэтому более понятны. На рис. 6 показана именно эта вкладка. В дальнейшем лучше пользоваться вкладкой Alphabetic (По алфавиту), где требуемое свойство можно быстрее найти по алфавиту.

Рассмотрим основные группы свойств, представленные на вкладке Categorized окна Properties.

Свойства, определяющие внешний вид объекта.

В группе Appearance (Оформление) окна Properties содержатся свойства объекта, которые задают атрибуты его внешнего вида. Основные свойства данной группы:

Caption | - задает текст в строке заголовка объекта;
BorderStyle | - задает стиль рамки объекта;
Palette | - устанавливает цветовую палитру;
Picture | - назначает значок, картинку для объекта. Используя данное свойство формы, можно задать фоновое графическое изображение.

Свойства, определяющие поведение объекта.

Свойства объектов, отвечающие за их поведение, собраны в группе Behavior (Поведение). Основные свойства данной группы:

Causes Validation | - устанавливает признак проверки условия достоверности данных при выходе из объекта;
Enabled | - разрешает или запрещает доступ к объекту;
MaxLength | - устанавливает максимальную длину данных в объекте;
Visible | - устанавливает видимость объекта.

Свойства, определяющие шрифт

Группа Font (Шрифт) содержит всего одно свойство Font, позволяющее с помощью диалогового окна Выбор шрифта задать шрифт текста объекта, размер, начертание.

Общие свойства

Свойства группы Misc задают общие атрибуты объекта, в том числе для его идентификации.

Name | - задает имя объекта;
Text | - устанавливает текст в поле по умолчанию;
Index | - задает уникальный индекс объекта в коллекции;

По имени, указанному в свойстве Name (Имя), объект идентифицируется в форме и в тексте программы. Поэтому необходимо иметь в виду, что в одной форме не может быть двух объектов с одинаковыми именами. По умолчанию это свойство устанавливается автоматически. Вместо имени, заданного по умолчанию, лучше использовать имя, отражающее его смысловое значение.

Свойства позиционирования

Группа Position (Расположение) окна Properties служит для позиционирования объектов в системе координат формы и установки размеров объектов.

Left | - задает положение объекта по горизонтальной оси от левого края формы или, в общем случае, от объекта-контейнера;
Top | - задает положение объекта по вертикальной оси от его верхнего края до верхней стороны формы;
Width | - задает горизонтальный размер (ширину) объекта;
Height | - задает вертикальный размер (высоту) объекта.

Свойства шкалы размеров объекта

Свойства группы Scale (Масштаб) устанавливают шкалу максимальных размеров объектов в системе координат формы.

ScaleLeft | - задает максимальное положение объекта по горизонтальной оси;
ScaleTop | - задает максимальное положение объекта по вертикальной оси;
ScaleWidth | - задает максимальный горизонтальный размер (максимальная ширина);
ScaleHeight | - задает максимальный вертикальный размер (максимальная высота).

к началу

Окно просмотра объектов

Для просмотра всех элементов, входящих в состав проекта. Visual Basic 6 предоставляет очень удобную возможность — окно просмотра объектов Object Browser (рис. 8).

Рис. 8. Окно просмотра объектов

В этом окне можно получить доступ не только ко всем элементам, которые входят в проект, но и их свойствам, методам, событиям. Окно просмотра объектов обычно не визуализировано и его можно вызвать командой Object Browser (Браузер объектов) из меню View (Вид).

к началу

Окно макета формы

Окно макета формы Form Layout (Макет формы) (рис. 9) вызывается командой Form Layout Window из меню View.

Рис. 9. Окно макета формы

В этом окне показывается уменьшенное изображение проектируемой формы в том виде, как эта форма будет выглядеть на экране монитора при выполнении приложения. Размеры формы в окне макета Form Layout пропорциональны размерам изображения монитора в этом же окне, то есть все реальные пропорции в точности соблюдены. Для проверки формы в работающем приложении откройте окно макета формы и запустите форму командой Start (Старт) из меню Run (Запуск).

При этом форма запускается точно в том виде, как она будет выглядеть в работающем приложении.

к началу

Окно редактора исходного кода

Редактор кода (рис. 10) — это мощный встроенный редактор с удобными средствами ввода исходного кода программы.

Рис.10 Редактор кода

Из меню View (Вид) перейти в редактор кода можно с помощью команды Code (Код). Для быстрого открытия окна редактора кода достаточно дважды щелкнуть левой кнопкой мыши, установив указатель на форме приложения. После начала редактирование кода программы имя открытого окна появляется и в списке команд перехода между окнами Window (Окно) главного меню. Переход между макетом и окном редактора кода можно выполнять, используя список меню Window.

Рис. 10. Окно редактора исходного кода

к началу

Окно проводника проекта

Окно проводника проекта Project (рис. 11) очень похоже на аналогичное окно проводника системы Windows и позволяет легко и быстро просматривать состав и свойства выбранного проекта, перемещаться между проектами, если их открыто сразу несколько, копировать необходимые объекты из окна одною проекта в другой, как это осуществляется в проводнике системы Windows.

Рис. 11. Окно проводника проекта

Проводник проекта можно вызвать командой Project Explorer (Проводник проекта) меню View (Вид) или комбинацией клавиш <Ctrl>+<R>.

При нажатии правой кнопки мыши в окне проводника появляется контекстное меню, содержащее команды для добавления, сохранения, удаления форм, элементов управления и других объектов.

Панель управления окна проводника проекта содержит три кнопки, которые имеют следующее назначение:

View code | - открывает окно редактора с кодом программы, выбранного в проводнике объекта;
View Object | - открывает в конструкторе форм выбранный объект;
Toggle Folders | - включает/выключает отображение папок.

к началу

Окно локальных переменных

Окно Locals (Локальные) предназначено для просмотра списка локальных переменных приложения и контроля за их значениями (рис. 12). Вызывается это окно командой Locals Window (Окно локальных переменных) меню View (Вид).

Рис. 12. Окно Locals

В окне Locals можно просмотреть локальные переменные, объявленные в текущей процедуре, их тип и значения. Эта информация автоматически появляется в окне при его вызове. Данное окно используется для отладки и проверки работы приложений. С помощью него можно проконтролировать все локальные переменные в точках останова программы.

При работе с окном Locals (Локальные) необходимо иметь в виду, что глобальные переменные в этом окне для просмотра недоступны.

Для выбора интересующей процедуры используется поле со списком. Нажав на кнопку с многоточием, можно выбрать интересующую процедуру из списка. Если значения переменных или их названия не помещаются в столбцах, то требуемые столбцы можно расширить, перемещая при помощи левой кнопки мыши границы столбцов в заголовке. Если окно открыто постоянно, то данные между точками останова программы при работе приложения автоматически обновляются.

В окне Locals можно не только просматривать переменные и их значения в данный момент работы программы. Очень полезным свойством этого окна является возможность изменять значения переменных для проверки реакции программы на эти значения. Для этого в столбце Value (Значение) необходимо щелкнуть на изменяемом значении. При этом значение переведется в режим редактирования, и его можно будет изменить. Клавишей <Enter> или перемещением указателя мыши на другое поле устанавливается новое значение, если оно имеет допустимое значение.

к началу

Окно контроля работы приложения

Для более полного контроля работы приложения (рис. 13) используется окно Watches (Наблюдение).

Рис. 13. Окно Watches

Это окно вызывается командой Watch Window (Окно наблюдения) меню View (Вид) и предназначено для определения значений выражений. В окне Watches можно выполнять действия, аналогичные выполняемым в окне Locals (Локальные). Так же, как и Locals, окно Watches используется при отладке приложения и проверке его работы.

к началу

Окно ручного ввода и выполнения команд

Окно Immediate (Непосредственное выполнение) предназначено для ручного ввода и выполнения команд Visual Basic 6 (рис. 14). Это окно появляется автоматически при прерывании работы программы в точках останова программы.

Рис. 14. Окно Watches

Для выполнения команды или оператора Visual Basic необходимо набрать строку команды и нажать клавишу <Enter>.

В сочетании с окнами Locals (Локальные) и Watches (Наблюдение), окно Immediate является удобным средством для отладки и проверки работы программы в пошаговом режиме. Проверяемые части или блоки программы можно копировать из программных модулей приложения в окно Immediate, и после проверки и внесения необходимых изменений по результатам контроля возвращать в модуль приложения.

к началу

Настройка среды разработки

Для настройки среды разработки программы Visual Basic используется диалоговое окно Options (Параметры), вызываемое из меню Tools (Сервис) командой Options (Параметры). Окно содержит шесть вкладок:

Editor (Редактор)

Editor Format (Форматы редактирования)

General (Основные настройки)

Docking (Инструменты среды)

Environment (Среда проектирования)

Advanced (Расширенные настройки)

Для настройки среды разработки (IDE) на вкладках используются группы флажков, переключателей, раскрывающиеся списки.

При изменении параметров для сохранения варианта настройки необходимо выйти из диалогового окна Options, нажав кнопку ОК.

Для отказа от всех осуществленных на вкладках изменений нажмите кнопку Отмена.

Рис. 15 Вкладка Editor

Рис. 16 Вкладка Editor Format

к началу

Вкладка настроек редактора

Самая первая вкладка диалогового окна Options — Editor (Редактор) (рис. 15). Здесь можно установить параметры работы редактора исходного кода приложения. Используя флажки группы Code Settings (Установки редактора кода), устанавливаются следующие параметры:

Auto Syntax Check (Автоматический контроль синтаксиса) | — автоматический контроль синтаксиса при вводе исходного кода приложения в редакторе;
Require Variable Declaration (Требование объявления переменных) | — если этот флажок установлен, любые переменные можно использовать только после их объявления;
Auto List Members (Автоматический вывод списка возможных свойств и методов объекта) | — автоматический вывод свойств и методов объекта при вводе текста программы. При этом методы и свойства отображаются в позиции курсора и их можно легко выбрать;
Auto Quick Info (Автоматический вывод синтаксиса функций) | — разрешение или запрет вывода информации о функциях и их параметрах при вводе текста программы;
Auto Data Tips (Автоматическое отображение значений) | — при отладке приложения отображает значение переменной, находящейся под указателем мыши;
Auto Indent (Автоматическая расстановка) | — автоматическая расстановка отступа при вводе программы. Отступы делают программу структурированной и понятной при чтении. Для сложных программ отступы просто обязательны.

В поле Tab Width указывается количество пробелов отступа при нажатии клавиши <ТаЬ>. По умолчанию установлено значение 8, но его можно изменить.

В группе Window Settings (Настройки окна) устанавливаются параметры, связанные с фрагментами текста:

Drag-and-Drop Text Editing (Перетаскивание текста) | — разрешает перетаскивание фрагментов текста программы;
Default to Full Module View (Отображение всех процедур) | — позволяет отображать в редакторе сразу все процедуры текущего объекта. Если этот флажок не установлен, процедуры можно просматривать по очереди;
Procedure Separator (Разделитель текста процедур) | — в режиме просмотра всех процедур проекта устанавливает между ними разделитель.

к началу

Вкладка стилей текста

На вкладке Editor Format (рис. 16) настраиваются стили текста исходного кода приложения — используемый шрифт, цвета, размер текста исходного кода в зависимости от назначения текста кода. Используя параметры данной вкладки, можно выделить цветом, шрифтом и размером шрифта основные элементы программы, например, основной текст, текст комментариев, точки остановки.

Для настройки форматов элементов кода необходимо выполнить следующее:

1. Выбрать в области Code Colors из списка типов программного текста настраиваемый тип.

2. Используя раскрывающиеся списки Foreground и Background, установить цвет текста и фона.

3. С помощью списков Font и Size задать наименование шрифта и его размер.

4. В области Sample просмотреть полученный результат осуществленных изменений.

5. Повторяя пункты с 1-го по 4-й, изменить все необходимые стили текста окна редактора кода.

6. Для сохранения установленных параметров, нажать кнопку ОК.

Рис. 17 Вкладка General

Рис. 18 Вкладка Docking

к началу

Вкладка настроек общих свойств среды

На вкладке General (рис. 17) диалогового окна Options размещены параметры, которые предназначены для управления общими свойствами среды проектирования. В области Form Grid Settings (Настройка сетки форм) находятся следующие параметры настройки:

Show Grid (Отображать сетку) | — устанавливает режим отображения линий координатной сетки при разработке макетов форм. Используя расположенные под флажком поля Width (Ширина) и Height (Высота), можно установить ширину и высоту ячеек сетки.
Align Controls to Grid (Привязать элементы управления к сетке) | — задает привязку элементов управления к шагу сетки при размещении их в макете формы.

В области Error Trapping (Реакция на ошибки) можно установить один из трех переключателей, которые задают вариант реакции приложения на возникающие при его работе ошибки:

Break on All Errors (Приостанавливаться по всем ошибкам) | — приостанавливать выполнение приложения при возникновении любой ошибки;
Break in Class Module (Приостанавливаться по ошибкам в классах) | — приостанавливать выполнение приложения при возникновении любой ошибки в модуле класса;
Break on Unhandled Errors (Приостанавливаться по неуправляемым ошибкам) | — приостанавливать выполнение приложения при возникновении любой необработанной ошибки, то есть при такой ошибке, для которой нет функции перехвата.

В области Compile (Компиляция) можно установить флажки, управляющие процессом компиляции программы:

Compile on Demand (Компиляция по мере необходимости) | — компиляция будет осуществляться только для тех разделов программы, которые необходимо выполнять. При этом при выполнении команды Start (Запустить) из меню Run (Запуск) приложение будет запускаться быстрее;
Background Compile (Фоновая компиляция) | — этот флажок дает возможность использовать время ожидания программы для ее компиляции.

Кроме перечисленных параметров, на этой вкладке есть еще два флажка следующего назначения:

Show ToolTips (Отображать подсказки) | — при установке этого флажка Visual Basic 6 отображает подсказку с описанием свойств объекта в макете формы, когда указатель мыши удерживается на объекте некоторое время;
Collapse Proj, Hides Windows (Сворачивать проект, скрыть окна) | — этот флажок заставляет сворачиваться все связанные с проектом окна при свертывании окна проекта.

к началу

Вкладка настройки окон

На вкладке Docking (рис. 18) диалогового окна Options все флажки объединены в одну группу Dockable Эти флажки определяют, какие окна среды разработки могут закрепляться ("приклеиваться") к краям главного окна программы Visual Basic. Наименования окон среды разработки перечислены в виде флажков. Настройка заключается в установке флажков для соответствующих им окон.

Immediate Window | — окно Immediate (Непосредственное выполнение)
Locals Window | — окно Locals (Локальные)
Watch Window | — окно Watches (Наблюдение)
Project Explorer | — проводник проекта
Properties Window | — окно свойств
Object Browser | — браузер объектов
Form Layout | — окно макета форм
Toolbox | — панель элементов управления
Color Palette | — цветовая палитра

Рис. 19 Вкладка Environment

Рис. 20 Вкладка Advanced

к началу

Вкладка Environment

Вкладка Environment (рис. 19)диалогового окна Options содержит три области. В области When Visual Basic starts (При запуске Visual Basic) можно установить переключатели:

Prompt for project (Приглашение для выбора образца проекта) | — указывает на необходимость открытия диалогового окна New Project (Новый проект) при запуске Visual Basic 6;
Create default project (Создавать проект по умолчанию) | — при запуске Visual Basic 6 создается установленный по умолчанию тип проекта.

Область When a program starts (При запуске программы) управляет возможностью сохранения проекта при запуске его на выполнение. Впоследствии при работе с большим проектом от сохранения можно отказаться для экономии времени. В данной группе переключателей устанавливается одна из следующих опций:

Save Changes (Сохранять изменения) | — сохранять изменения всегда;
Prompt To Save Changes (Сохранять изменения по запросу) | — сохранять проект с предварительным запросом на сохранение;
Don't Save Changes (He сохранять изменений) | — не сохранять осуществленных изменений.

Область Show Templates For (Показывать шаблоны) содержит список шаблонов, появляющихся в соответствующих диалоговых окнах при создании объектов. Используя расположенные здесь флажки, можно отказаться от части шаблонов, которые в данный момент не интересны. Для этого необходимо снять соответствующий флажок. Например, если вы не хотите, чтобы при создании форм появлялось диалоговое окно со списком шаблонов форм, вам необходимо снять флажок Form.

Поле Template Directory (Каталог шаблонов) вкладки назначает папку поиска шаблонов по умолчанию.

к началу

Вкладка Advanced

На вкладке Advanced (рис. 20) диалогового окна Options расположены три флажка, имеющих следующее назначение:

Background Project Load (Фоновая загрузка проекта) | — разрешает загрузку проекта в фоновом режиме, что дает возможность во время загрузки другого проекта продолжать работу над текущим;
Notify when changing shared project items (Сообщать об изменениях элементов проекта) | — сообщает об изменении общего для нескольких проектов объекта при одновременной работе над этими проектами;
SDI Development Environment (Назначить однодокументныи интерфейс) | — устанавливает однодокументныи интерфейс (SDI, Single-Document Interface) среды проектирования. По умолчанию используется многодокументный интерфейс (MDI, Multiple-Document Interface).

Используя поле External HTML Editor (Внешний редактор HTML) вкладки Advanced, можно установить редактор для работы с HTML-страницами.

к началу

ПРИЛОЖЕНИЕ

Команды меню File

Команда | Назначение
New Project (Новый проект) | Создает новый проект
Open Project (Открыть проект) | Открывает существующий проект
Add Project (Добавить проект) | Добавляет проект в группу для параллельной работы над несколькими проектами, копирования форм из проекта в проект или для его отладки
Remove Project (Исключить проект) | Удаляет проект из группы проектов
Save Project Group (Сохранить группу проектов) | Сохраняет группу проектов
Save Project Group As (Сохранить группу проектов как) | Сохраняет группу проектов под другим именем
Save <имя формы> (Сохранить форму) | Сохраняет форму с прежним именем
Save <имя формы> As (Сохранить форму как) | Сохраняет форму под другим именем
Print (Печать) | Открывает диалоговое окно Print
Print Setup (Настройка печати) | Открывает диалоговое окно настройки печати
Make <имя проекта>.ехе (Создать ехе-файл проекта) | Создает выполняемый файл текущего проекта
Make Project Group (Создать группу проектов) | Создает группу проектов
Exit (Выход) | Осуществляет выход из Visual Basic 6. В том случае, если в окне программы находятся не сохраненные результаты работы, появятся запросы о необходимости сохранения проектов, форм и других файлов

к началу

Команды меню Edit

Команда | Назначение
Undo (Отменить) | Отменяет предыдущую команду
Redo (Повторить) | Восстанавливает предыдущую команду
Cut (Вырезать) | Вырезает фрагмент текста
Сору (Копировать) | Копирует фрагмент в буфер обмена
Paste (Вставить) | Копирует содержимое из буфераобмена
Remove (Переместить) | Перемещает выделенное
Delete (Удалить) | Удаляет выделенное
Delete Table from Database (Удалить таблицу из базы данных) | Удаляет таблицу из базы данных
Select All (Выделить все) | Выделяет все
Select All Columns (Выделить все колонки) | Выделяет все колонки
Table: Set Primary Key (Таблица: Установить первичный ключ) | Определяет первичный ключ таблицы
Table: Insert Column (Таблица: Вставить поле) | Вставляет поле в таблицу
Table: Delete Column (Таблица: Удалить поле) | Удаляет поле из таблицы
Find (Найти) | Вызывает диалоговое окно поиска
Find Next (Найти следующее) | Ищет следующее значение, заданное для поиска
Replace (Заменить) | Ищет значение, заданное для поиска, и заменяет его новым значением
Go To Row: First (Перейти на запись: Первая) | Устанавливает указатель на первую запись
Go To Row: Last (Перейти на запись: Последняя) | Устанавливает указатель на последнюю запись
Go To Row: Next (Перейти на запись: Следующая) | Устанавливает указатель на следующую запись
Go To Row: Previous (Перейти на запись: Предыдущая) | Устанавливает указатель на предыдущую запись
Go To Row: Row (Перейти на запись: Запись) | Устанавливает указатель на запись с заданным номером
Go To Row: New (Перейти на запись: Новая) | Вставляет новую запись

к началу

Команды меню View

Команда | Назначение
Code (Код) | Открывает окно редактора программного кода
Object (Объект) | Открывает окно конструктора форм
Object Browser (Браузер объектов) | Открывает окно браузера объектов
Immediate Window (Окно непосредственного выполнения) | Открывает окно, предназначенное для ввода и непосредственного выполнения команд
Locals Window (Окно Локальные) | Открывает окно, предназначенное для просмотра значений переменных
Watch Window (Окно Наблюдение) | Открывает окно просмотра значений выражений
Project Explorer (Проводник проекта) | Открывает окно проводника проектов
Properties Window (Окно свойств) | Открывает окно свойств объектов Properties
Form Layout Window (Окно макета формы) | Открывает окно макета формы
Toolbox (Панель инструментов) | Отображает панель элементов управления
Data View Window (Окно просмотра данных) | Открывает окно просмотра данных
Color Palette (Цветовая палитра) | Отображает цветовую палитру
Toolbars (Панели инструментов) | Открывает меню, предназначенное для отображения в окне программы Visual Basic следующих панелей: Debug (Отладка), Editor (Редактор), Form Edit (Редактор форм), Standard (Стандартная панель инструментов)

к началу

Команды меню Project

Команда | Назначение
Add Form (Добавить форму) | Добавляет в окно проекта форму
Add MDI Form (Добавить форму окна MDI) | Добавляет MDI-форму
Add Module (Добавить модуль) | Добавляет программный модуль
Add Class Module (Добавить класс) | Добавляет пользовательский класс
Add User Control (Добавить элемент управления) | Добавляет пользовательский элемент управления
Add Property Page (Добавить страницу свойств) | Добавляет стандартную форму настройки свойств
Add WebClass (Добавить Web-класс) | Добавляет Web-класс
Add Data Report (Добавить отчет) | Добавляет в проект отчет
Add DHTML Page (Добавить страницу DHTML) | Добавляет страницу DHTML
Add Data Environment (Добавить среду данных) | Добавляет среду базы данных
Add File (Добавить файл) | Добавляет файл
Remove (Исключить) | Исключает файл из проекта
References (Ссылки) | Вызывает окно включения ссылок проекта на библиотеки
Components (Компоненты) | Открывает диалоговое окно Components, позволяющее добавить на панель элементов управления компоненты для их дальнейшего включения в проект приложения
Project Properties (Свойства проекта) | Открывает окно свойств проекта Project Properties

к началу

Команды меню Format

Команда | Назначение
Align (Выровнять) | Открывает меню, содержащее команды выравнивания объектов
Make Same Size (Установить подобный размер) | Открывает меню, содержащее команды, управляющие размерами объектов в форме
Horizontal Spacing (Горизонтальный интервал) | Устанавливает интервал между объектами в горизонтальном направлении
Vertical Spacing (Вертикальный интервал) | Устанавливает интервал между объектами в вертикальном направлении
Center in Form (Центрирование в форме) | Центрирует объекты в форме
Order (Порядок) | Направляет выбранный объект в нижний или верхний слой формы

к началу

Команды меню Debug

Команда | Назначение
Step Into (Шаг с заходом в процедуры) | Осуществляет пошаговое выполнение процедуры, включая также вызываемые ею процедуры
Step Over (Шаг без захода в процедуры) | Осуществляет пошаговое выполнение процедуры без трассировки вызываемых ею процедур
Step Out (Шаг с выходом из процедуры) | Выполнение программы осуществляется до выхода из текущей процедуры
Add Watch (Добавить окно Watch) | Открывает окно Add Watch (Добавить наблюдение) для ввода выражений, за значениями которых будет вестись наблюдение
Edit Watch (Открыть окно Edit Watch) | Открывает диалоговое окно Edit Watch для редактирования или удаления выражений, за значениями которых ведется наблюдение
Quick Watch (Открыть окно Quick Watch) | Открывает окно Quick Watch для просмотра значения выбранного выражения
Toggle Breakpoint (Установить точку останова) | Устанавливает точку останова
Clear All Breakpoints (Отменить все точки останова) | Удаляет все точки останова
Set Next Statement (Определить следующий оператор) | Устанавливает следующий оператор
Show Next Statement (Показать следующий оператор) | Показывает следующий оператор

к началу

Команды меню Run

Команда | Назначение
Start (Запустить) | Запускает приложение на выполнение
Start with Full Compile (Запустить с полной компиляцией) | Запускает приложение на выполнение с полной компиляцией
Break (Приостановить) | Останавливает выполнение приложения
End (Конец) | Прекращает выполнение приложения
Restart (Перезапустить) | Перезапускает приложение

к началу

Команды меню Query

Команда | Назначение
Run (Запустить) | Выполняет запрос
Clear Results (Очистить результаты) | Очищает результаты запроса
Verify SQL Syntax (Проверить синтаксис SQL) | Проверяет синтаксис запроса
Group By (Группировать) | Группирует данные в запросе
Change Type: Select (Модификация: Выбрать) | Создает запрос для выборки данных
Change Type: Insert (Модификация: Вставить) | Создает запрос, предназначенный для добавления данных в таблицу, используя значения других таблиц
Change Type: Insert Values (Модификация: Вставить значения) | Создает запрос, предназначенный для добавления данных в таблицу, используя заданные значения
Change Type: Update (Модификация: Изменить) | Создает запрос, предназначенный для изменения данных
Change Type: Delete (Модификация: Удалить) | Создает запрос, предназначенный для удаления данных
Change Type: Make Table (Модификация: Создать таблицу) | Создает новую таблицу на основе результатов выборки
Add to Output (Добавить поля) | Добавляет поля в список полей формируемой выборки
Sort Ascending (Сортировка по возрастанию) | Назначает сортировку по возрастанию
Sort Descending (Сортировка по убыванию) | Назначает сортировку по убыванию
Remove Filter (Удалить фильтр) | Удаляет фильтр
Select All Rows From <Table A > (Выбрать все записи из первой таблицы) | Создает внешнее соединение, которое выбирает все записи из первой таблицы, даже если они отсутствуют во второй таблице
Select All Rows From <ТаЫе В > (Выбрать все записи из второй таблицы) | Создает внешнее соединение, которое выбирает все записи из второй таблицы, даже если они отсутствуют в первой таблице

к началу

Команды меню Diagram

Команда | Назначение
New Text Annotation (Новый текст пояснения) | Добавляет пояснительный текст
Set Text Font (Установить шрифт) | Устанавливает шрифт
Add Related Tables (Добавить связанную таблицу) | Добавляет связанную таблицу
Show Relationship Labels (Показать связи) | Показывает наименования связей
Modify Custom View (Изменить представление) | Изменяет вид отображения таблиц в диаграмме
View Page Break (Показывает постраничную разбивку) | Показывает разбивку на страницы
Recalculate Page Break (Пересчитать постраничную разбивку) | Пересчитывает разбивку на страницы
Arrange Selection (Выравнивать выбранные) | Выравнивает выбранные таблицы
Arrange Tables (Выравнивать все таблицы) | Выравнивает все таблицы
Autosize Selected Tables (Авторазмер выделенных таблиц) | Автоматически устанавливает размер выбранных таблиц

к началу

Команды меню Tools

Команда | Назначение
Add Procedure (Добавить процедуру) | Добавляет процедуру
Procedure Attributes (Атрибуты процедуры) | Устанавливает атрибуты процедуры
Menu Editors (Редактор меню) | Вызывает окно редактора меню
Options (Параметры) | Открывает диалоговое окно Options для настройки параметров программы Visual Basic
SourseSafe (Хранилище) | Управляет хранилищем проектов

к началу

Команды меню Add-Ins

Команда | Назначение
Visual Data Manager (Менеджер баз данных) | Запускает менеджера управления базой данных
Add-In Manager (Менеджер надстроек) | Открывает диалоговое окно Add-In Manager, позволяющее добавить надстройку в Visual Basic 6

к началу

Команды меню Window

Команда | Назначение
Split (Разделить) | Разделяет окно
Tile Horizontally (Горизонтально) | Размещает окна горизонтально
Tile Vertically (Вертикально) | Размещает окна вертикально
Cascade (Каскадом) | Размещает окна каскадом
Arrange Icons (Упорядочение значков) | Изменяет размещение значков окон

к началу

Команды меню Help

Команда | Назначение
Context (Содержание) | Вызывает справочную систему с активной вкладкой Содержание
Index (Указатель) | Вызывает справочную систему с активной вкладкой Индекс
Search (Поиск) | Вызывает справочную систему с активной вкладкой Поиск
Technical Support (Техническая поддержка) | Вызывает справочную систему с информацией о службе технической поддержки Microsoft
Microsoft on the Web (Microsoft в Web) | Вызывает страницу Microsoft в Internet
About Visual Basic (0 Visual Basic) | Вызывает справочную информацию о пакете Visual Basic 6

к началу

Кнопки стандартной панели инструментов

Название (по всплывающей подсказке) | Назначение
Add Standard EXE Project (Добавить стандартный проект) | Добавляет стандартный ехе-проект
Add Form (Добавить форму) | Добавляет форму в проект
Menu Editor (Редактор меню) | Вызывает редактор меню
Open Project (Открыть проект) | Открывает проект
Save Project (Сохранить проект) | Сохраняет проект
Cut (Вырезать) | Вырезает информацию в буфер обмена
Copy (Копировать) | Копирует в буфер обмена
Paste (Вставить) | Вставляет информацию из буфера обмена
Find (Найти) | Осуществляет поиск информации по контексту
Can't Undo (Отмена предыдущего) | Отменяет предыдущее действие
Can't Redo (Отмена повторного) | Восстанавливает отмененное действие
Start (Запустить) | Запускает программу на выполнение
End (Закончить) | Прекращает выполнение программы
Break (Прервать) | Прерывает выполнение программы
Project Explorer (Проводник проекта) | Открывает окно проводника проектов
Properties Window (Окно свойств) | Открывает окно свойств
Form Layout Window (Окно макета форм) | Открывает окно макета формы
Object Browser (Браузер объектов) | Открывает окно браузера объектов
Toolbox (Панель элементов управления) | Открывает панель элементов управления
Data View Window (Окно просмотра данных) | Открывает окно просмотра данных
Visual Component Manager (Менеджер визуальных компонентов) | Открывает окно управления визуальными компонентами Visual Component Manager

к началу

Кнопки панели элементов управления

Название (по всплывающей подсказке) | Назначение
Pointer (Указатель) | Используется для позиционирования маркера (указателя) мыши
PictureBox (Графическое окно) | Размещает в форме графическое окно, предназначенное для объединения элементов в группы, для вывода в него графических изображений, а также текста, графических элементов и анимации
Label (Метка) | Размещает в форме объекты, предназначенные для создания текстовой информации, надписей и примечаний
TextBox (Текстовое поле) | Размещает в форме текстовое поле, предназначенное для ввода текстовой информации, чисел и дат
Frame (Рамка) | Создает в форме рамку с заголовком для группировки объектов в логическую группу
CommandButton (Кнопка управления) | Размещает в форме кнопки управления для инициации действий, выполнения команд, запуска программ
CheckBox (Флажок) | Размещает в форме флажок, предназначенный для формирования условий выполнения программ или каких-либо настроек, работающий по принципу "да — нет"
OptionBufrton (Переключатель) | Создает в форме переключатели для выбора режима работы или настроек выполнения программы
ComboBox (Поле со списком) | Создает в форме объект, содержащий одновременно поле ввода и раскрывающийся список
ListBox (Список) | Создает в форме список для выбора одного или нескольких значений из предлагаемого списка значений
HScrollBar (Горизонтальная полоса прокрутки) | Размещает в форме горизонтальную полосу прокрутки, используемую в качестве ползунка для выбора значения из заданного диапазона
VScrollBar (Вертикальная полоса прокрутки) | Размещает в форме вертикальную полосу прокрутки, используемую в качестве ползунка для выбора значения из заданного диапазона
Timer (Таймер) | Размещает в форме таймер
DriveListBox (Список устройств) | Создает в форме список устройств
DirListBox (Список папок) | Создает в форме древовидный список папок
FileListBox (Список файлов) | Создает в форме список файлов
Shape (Очертание) | Создает в форме геометрические фигуры, такие как прямоугольник, квадрат, круг, эллипс, прямоугольник и квадрат со скругленными углами
Line (Линия) | Создает линии
Image (Изображение) | Создает в форме поля, предназначенные для отображения графических изображений
Data (Данные) | Создает элемент управления данными в базе данных для перемещения по записям и отображения результата навигации

к началу